SourceOne Email Management : Les tâches échouent en raison d’une défaillance de la connexion SQL après la migration des bases de données SourceOne vers un nouveau serveur SQL
Summary: Les tâches échouent en raison d’un échec de la connexion SQL après la migration des bases de données SourceOne vers un nouveau serveur SQL. Error: SQL Server n’existe pas ou l’accès est refusé. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Après avoir déplacé des bases de données Dell-EMC SourceOne vers un nouveau serveur SQL et que le site utilise le même alias de serveur SQL, les tâches de gestion de la messagerie Dell-EMC SourceOne sont marquées comme « Failed » dans le nœud EMC SourceOne Jobs de l’application Console.
Le journal des événements EMC sur le worker SourceOne où la tâche a été attribuée consigne une erreur de connexion SQL :
« SQL Server does not exist or access denied ».
Cause
Ce problème peut se produire lorsque la configuration du serveur SQL a été configurée sur les serveurs SourceOne à l’aide de l’utilitaire de configuration du client SQL et que la configuration n’a pas été mise à jour avec les nouvelles informations du serveur SQL. Le client SQL est redirigé vers l’ancien serveur SQL alors que les paramètres de odbcad32.exe sont corrects.
Resolution
Exécutez C :\Windows\SYSWOW64\cliconfg.exe sur les serveurs Dell-EMC SourceOne.
Si l’onglet Alias est vide, cette solution ne s’applique pas.
S’il existe une entrée dans l’onglet Alias et que l’alias est valide pour le serveur SQL actuel,
modifiez la connexion et mettez à jour le nom du serveur avec le nouveau nom ou adresse IP du serveur SQL.
Si l’onglet Alias est vide, cette solution ne s’applique pas.
S’il existe une entrée dans l’onglet Alias et que l’alias est valide pour le serveur SQL actuel,
modifiez la connexion et mettez à jour le nom du serveur avec le nouveau nom ou adresse IP du serveur SQL.
Affected Products
SourceOneProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000063401
Article Type: Solution
Last Modified: 02 Jun 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.