SourceOne Email Management: Taken mislukken als gevolg van een SQL-verbindingsfout na het migreren van SourceOne-databases naar een nieuwe SQL-server

Summary: Taken mislukken omdat de SQL-verbinding is mislukt na het migreren van SourceOne-databases naar een nieuwe SQL-server. Fout: SQL Server bestaat niet en de toegang is geweigerd.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Na het verplaatsen van Dell-EMC SourceOne databases naar een nieuwe SQL server en de site dezelfde SQL serveralias gebruikt, worden Dell-EMC SourceOne Email Management taken gemarkeerd als 'Mislukt' in het EMC SourceOne Jobs-knooppunt van de Console-applicatie.
Het EMC-gebeurtenislogboek op de SourceOne-werker waaraan de taak is toegewezen, registreert een SQL-verbindingsfout:

"SQL Server bestaat niet of toegang geweigerd".

Cause

Dit probleem kan zich voordoen wanneer de SQL-serverconfiguratie is geconfigureerd op SourceOne-servers met behulp van de 'SQL Client Configuration Utility' en de configuratie niet is bijgewerkt met de nieuwe SQL-serverinformatie. De SQL-client wordt omgeleid naar de oude SQL-server, ook al zijn de odbcad32.exe instellingen correct.

Resolution

Voer C:\Windows\SYSWOW64\cliconfg.exe uit op Dell-EMC SourceOne servers.
Als het tabblad Alias leeg is, is deze oplossing niet van toepassing.
Als er een vermelding op het tabblad Alias is en de alias geldig is voor de huidige SQL-server,
bewerkt u de verbinding en werkt u de 'Servernaam' bij met de nieuwe SQL-servernaam of het nieuwe IP-adres.

Affected Products

SourceOne

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000063401
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.