SourceOne Email Management: Os trabalhos falham devido a uma falha de conexão SQL após a migração de bancos de dados SourceOne para um novo SQL Server

Summary: Os trabalhos falham devido a uma falha de conexão SQL após a migração de bancos de dados SourceOne para um novo SQL Server. Error: O SQL Server não existe ou acesso negado.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Depois de mover os bancos de dados Dell-EMC SourceOne para um novo SQL Server e o site estiver usando o mesmo alias SQL Server, os trabalhos de gerenciamento de e-mail do Dell-EMC SourceOne são marcados como "Failed" no nó EMC SourceOne Jobs do aplicativo Console.
O registro de eventos da EMC no trabalhador do SourceOne ao qual o trabalho foi atribuído registra um erro de conexão SQL:

"SQL Server não existe ou acesso negado".

Cause

Esse problema pode ocorrer quando a configuração do SQL Server foi configurada em servidores SourceOne usando o 'SQL Client Configuration Utility' e a configuração não foi atualizada com as novas informações do SQL Server. O SQL client está sendo redirecionado para o SQL Server antigo, mesmo que as configurações odbcad32.exe estejam corretas.

Resolution

Execute C:\Windows\SYSWOW64\cliconfg.exe em servidores Dell EMC SourceOne.
Se a guia Alias estiver vazia, essa solução não se aplicará.
Se houver uma entrada na guia Alias e o alias for válido para o SQL Server atual,
edite a conexão e atualize o 'Nome do servidor' com o novo nome ou endereço IP do SQL Server.

Affected Products

SourceOne

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000063401
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.