Data Domain : загрузка файла DDOS rpm с помощью графического интерфейса пользователя (Data Domain System Manager) может заполнить раздел /ddr

Summary: Загрузка RPM-файла DDOS с помощью графического интерфейса пользователя (Data Domain System Manager) может заполнить раздел /DDR

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



RPM-файл DDOS сначала сохраняется в папке /ddr/gui/temp при загрузке с помощью графического интерфейса пользователя (DDSM). После загрузки RPM перемещается в папку /ddr/var/releases.

Если в /ddr закончится место во время загрузки, это может повлиять на обновления реестра и вызвать панику / перезапуск файловой системы.  Это также может повлиять на другие службы (dd_procmon, dd_hd_rdb_tool, netmon, scm, sms и т. д.), которые записывают в /ddr.

Ниже приведены примеры ошибок, которые можно увидеть в messages.engineering, когда /ddr заполнен (обратите внимание, что ошибки не указывают на то, что /ddr/ стал полным из-за сбоя загрузки RPM):

 
22 янв 12:17:15 dd6300 dd_hd_rdb_tool: ERROR: Реестр /ddr/registry/p0/alerts_local.db3 SQL step 'step insert value' ошибка 13 (база данных или диск заполнены) (retries=0)


22 янв 12:17:23 dd6300 ddfs[30031]: ERROR: Реестр /ddr/registry/m0/system.db3 Ошибка 13 шага SQL «шаг вставки значения» 13 (база данных или диск заполнены) (retries=0)
22 янв 12:17:23 dd6300 ddfs[30031]: ERROR: Реестр /ddr/registry/m0/system.db3 SQL ошибка 13 (база данных или диск заполнены): сбросить вставку значения

22 янв 12:17:19 dd6300 netmon: ERROR: Реестр /ddr/registry/p0/config.db3 Ошибка 13 шага SQL «шаг вставки значения» 13 (база данных или диск заполнены) (retries=0)
22 янв 12:17:19 dd6300 netmon: ERROR: Реестр /ddr/registry/p0/config.db3 Ошибка SQL 13 (база данных или диск заполнены): сброс вставкизначения В других случаях, даже если пространство в /ddr не закончится полностью, использование пространства может стать достаточно высоким, чтобы не допустить модернизации.  
Ниже приведен пример сбоя предварительной проверки модернизации: 

# Выполняется предварительная проверка модернизации системы 7.1.0.5-643969.rpmВыполняется предварительная проверка модернизации:
Проблема с уровнем серьезности узла Решение---- -------- ------------------------------ --------0 КРИТИЧЕСКИ ВАЖНО: использование /ddr составляет 93% Свободное пространство /ddr---- -------- ------------------------------ --------Узел 0: фаза 1/1 (предварительная проверка 100%)**** Предварительная проверка модернизации обнаружила 1 блокирующую проблему. 

Cause

В разделе /DDR ограниченное пространство в нескольких моделях DDR.  Кроме того, размер RPM-файла DDOS в более поздних выпусках (например, DDOS 7.x) больше, поэтому есть вероятность, что больший размер RPM-файла DDOS в сочетании с меньшим (и наполовину заполненным) разделом /ddr в некоторых моделях DD может привести к нехватке дискового пространства под /ddr при загрузке RPM через графический интерфейс

.Кроме того, рекомендуется также ознакомиться со следующей статьей базы знаний, так как там описана аналогичная ошибка, которая может быть связана:После
обновления до DDMC 6.1 или 6.2 попытка загрузить файлы RPM из графического интерфейса пользователя завершается сбоем. Это также может произойти в DDOS при использовании графического интерфейса пользователя (DDSM)

Resolution

Если раздел /ddr заполняется, для очистки /ddr требуется доступ bash. Обратитесь за срочной помощью к своему поставщику услуг поддержки, с которым у вас заключен договор.

Чтобы избежать риска возникновения этой ошибки, не используйте пользовательский интерфейс для загрузки RPM-пакета.  Вот некоторые варианты:
  • Используйте «scp» для загрузки RPM-файла в Data Domain в каталог /ddr/var/releases/.
  • Сопоставьте папку /ddvar с клиентом CIFS и скопируйте RPM в папку /ddvar/releases.

Additional Information

Содержание этой статьи переведено на 17 языков: 
https://downloads.dell.com/TranslatedPDF/CS_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/DA_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/DE_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/ES-XL_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/FI_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/FR_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/IT_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/JA_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/KO_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/NL_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/NO-NO_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/PL_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/PT-BR_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/RU_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/SV_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/TR_KB541095.pdf
https://downloads.dell.com/TranslatedPDF/ZH-CN_KB541095.pdf

Affected Products

Data Domain

Products

Data Domain, DD OS 6.1, DD OS 7.0, DD OS 7.1
Article Properties
Article Number: 000063425
Article Type: Solution
Last Modified: 09 Oct 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.