Avamar: Procházení řešení Isilon zobrazí při problému s heslem pouze adresář "/ifs" a ověření pomocí příkazu curl

Summary: Při procházení úložiště Isilon NAS v uživatelském rozhraní Avamar se může zobrazit "/ifs" pouze v případě, že uživatel procházení ("av-browse-admin") má nesprávné heslo nebo heslo, jehož platnost vypršela. Otestujte pomocí příkazu "curl", zkontrolujte "isi auth users" view a resetujte heslo pomocí "isi auth users" modify --set-password '' --enabled true. Poté se zobrazí podadresáře. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Pozorované chování při procházení řešení Isilon pomocí softwaru Avamar.

Při procházení úložiště Isilon NAS z uživatelského rozhraní správce dochází k následujícímu:

  • Pouze nejvyšší úroveň /ifs zobrazí se adresář.
  • Žádné podadresáře ani soubory dole /ifs jsou viditelné.
  • Procházení uživatele (obvykle av-browse-admin) je přijata bez chyb.

Cause

Základní důvody omezené viditelnosti adresáře v nástroji Avamar Browse

Uživatelské rozhraní Avamar využívá volání rozhraní API Isilon založené na protokolu HTTP do clusteru Isilon, aby načetlo hierarchii oboru názvů. Pokud požadavek rozhraní API nelze ověřit nebo účet není v platném stavu, odpověď obsahuje pouze nejvyšší úroveň /ifs bez podadresářů.

  • Uživatel procházení má nesprávné heslo, což způsobí, že požadavek API selže při ověřování (obvykle av-browse-admin).
  • Platnost uživatelského účtu procházení vypršela, je uzamčen nebo zakázán, což také brání úspěšnému ověření.
  • Nesprávné vytvoření uživatele pro procházení (například nedodržení pokynů v uživatelské příručce NDMP) má za následek nedostatečná oprávnění k zobrazení seznamu níže uvedených adresářů /ifs. 
Pokud nastane některá z těchto podmínek, rozhraní API Isilon vrátí pouze kořenový obor názvů (/ifs) bez jakýchkoli podřízených položek, což vede k pozorovanému omezení prohlížení.

Resolution

Ověřte možnost Procházet přístup uživatele k řešení Isilon.

Otestujte připojení s účtem root

Pomocí curl Chcete-li požádat o výpis adresáře /ifs na uzlu Isilon. Nahradit [ISILON_IP] s IP pro správu libovolného uzlu.

curl -vk -u "root" -X GET "https://[ISILON_IP]:8080/namespace/ifs"

Otestujte připojení pomocí uživatele procházení Avamar

Pokud je kořenový požadavek úspěšný, opakujte test s procházecím uživatelem (výchozí av-browse-admin).

curl -vk -u "av-browse-admin" -X GET "https://[ISILON_IP]:8080/namespace/ifs"

 

VAROVÁNÍ: Prázdná odpověď nebo pouze /ifs Položka označuje problém s přihlašovacími údaji nebo stavem uživatele procházení.


Zkontrolujte stav procházení uživatele v řešení Isilon.

Chcete-li zobrazit atributy uživatele, spusťte v clusteru Isilon následující příkaz:

isi auth users view av-browse-admin

Hledejte pole, jako je vypršela platnost, uzamčeno nebo povoleno – pokud vypršela platnost uživatele, je uzamčen nebo zakázán, přejděte k dalším krokům.


Resetujte uživatelské heslo pro procházení.

Nahradit [NEW_PASSWORD] se zvoleným heslem. Zahrňte jednoduché uvozovky přesně podle obrázku.

isi auth users modify av-browse-admin --set-password '[NEW_PASSWORD]'


Povolit uživatele procházení (je-li zakázáno)

isi auth users modify av-browse-admin --enabled true

 

POZNÁMKA: Změna hesla může ovlivnit všechny ostatní služby, které spoléhají na stejné přihlašovací údaje. Před úpravou ověřte, zda tento účet nepoužívají žádné jiné procesy.


Znovu otestujte curl Žádost s aktualizovanými přihlašovacími údaji

curl -vk -u "av-browse-admin" -X GET "https://[ISILON_IP]:8080/namespace/ifs"

Úspěšná odpověď obsahuje seznam níže uvedených adresářů /ifs. Můžete se také dotazovat na hlubší cestu, například:

curl -vk -u "av-browse-admin" -X GET "https://[ISILON_IP]:8080/namespace/ifs/DIR"

 

Ověřte, že Avamar může procházet sdílenou složku Isilon.

V uživatelském rozhraní Avamar Administrator zkuste znovu procházet Isilon NAS. Nyní by měl být viditelný celý strom adresářů.

 

VAROVÁNÍ: Pokud problém přetrvává i po ověření přihlašovacích údajů a stavu uživatele, obraťte se na podporu společnosti Dell. Nesprávné úpravy nastavení ověřování mohou zabránit spuštění zálohování.

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for NDMP
Article Properties
Article Number: 000063862
Article Type: Solution
Last Modified: 22 Oct 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.