Avamar:ユーザーをrootに変更できず、suコマンドが「su: /bin/ksh: No such file or directory」

Summary: v7.3でrootユーザーシェルがインストールされていないシェルに変更された場合の対処方法を説明する短い記事(sudoを使用せずに問題を解決する)。

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Symptoms



「su -」を使用して管理者ユーザーからrootユーザーに昇格しようとすると、コマンドは機能せず、次のメッセージが返されます。
"su: /bin/ksh: No such file or directory"

Cause


これは、kornシェルがAvamarのv7.3には存在せず、rootアカウントがデフォルトで/etc/passwdで使用するように設定されているために発生します

確認するには、rootが現在使用しているシェルを確認します。

これは、管理者アカウントからのgetentコマンドで実行できます(どのアカウントから実行しても機能します)。

予期しない応答(問題を示す):
admin@avamar2:/bin/#: getent passwd root
root:x:0:0:root:/root:/bin/ksh

予想される応答(通常の出力):
admin@avamar1:~/>: getent passwd root
root:x:0:0:root:/root:/bin/bash

上記の出力で分かるように、avamar2はrootユーザーがkornシェルを使用するように設定されていることを報告します。korn シェルはバージョン 7.3 には存在しないため、これは問題です

この問題の根本原因は、Avamarのインストール後にrootユーザーの/etc/passwdエントリーが何者かによって変更されたことにあると思われます

Resolution

v7.3ではsudoを使用してroot設定を編集できないため、rootアカウントにログインして変更を行う必要があります。そのため、su コマンドで --shell=/bin/bash フラグを使用して、/etc/passwd で指定されたデフォルトのシェルをオーバーライドし、代わりに bash シェルを使用する必要があります

次の2つのコマンドを実行すると、最初にrootアカウントにアクセスし、次にrootアカウントのデフォルトシェルを/bin/bashに戻します。
 
1) su --shell=/bin/bash
2) chsh -s /bin/bash root

Affected Products

Avamar

Products

Avamar, Avamar Server
Article Properties
Article Number: 000063880
Article Type: Solution
Last Modified: 11 Oct 2024
Version:  3
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