Avamar: Zálohování VSS selže s chybou 32 pro EFIMicrosoftBootBCD kvůli problému s přístupem k souboru

Summary: Vyřešte selhání zálohování služby Avamar VSS (Stínová kopie svazku) s oddíly EFI a chybový kód 32 pomocí opravy hotfix založené na verzi doplňku Avamar VSS.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Byly pozorovány následující příznaky:

  • Zálohování VSS systému Windows pro Avamar se dokončí s výjimkami:
[avtar] direlem error:init_ntfs_hardlink: Open file for hardlink information failed 
"\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD", LastError=32 
(code 32: The process cannot access the file because it is being used by another process)

  • Proces avtar zobrazí tuto chybu:
avtar Error <5139>: File access share error "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD" 
(code 32: The process cannot access the file because it is being used by another process).

  • Problém byste měli vyřešit přidáním níže uvedeného příznaku do souboru avtar.cmd:
--x31=268435456
  • V některých případech problém přetrvává a zobrazí se nová chyba:
2024-11-04 21:15:17 avtar Info <5008>: Logging to C:\Program Files\avs\var\TXT_Daily_2030_8hrs-Test_Plantsec02-1730773800009#2-3015-VSS.log
2024-11-04 21:15:17 avtar Info <5174>: - Reading C:\Program Files\avs\var\avtar.cmd
2024/11/05-03:15:17.86100 [avtar]  uflags::parsefile  Printing flags from C:\Program Files\avs\var\avtar.cmd:
.cmd flag [1]: --x31=268435456
.cmd flag [2]: --debug=true

                              xxxxxxxxxxx

  <targetlist>
    <path name="\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\" />
  </targetlist>

               xxxxxxxxxxxxxxxxxxx

2024/11/05-03:15:28.74600 [avtar]  CBackupBCDUtility::exportTmpBCD out (The operation completed successfully.) return (0) bRet (1)
2024/11/05-03:15:28.74600 [avtar]  CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024/11/05-03:15:28.74600 [avtar]  filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024-11-04 21:15:28 avtar Error <16507>: Path "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD": Total processed bytes 24576 is inconsistent with original data size 28672
2024/11/05-03:15:28.85700 [avtar]  ucontainer::base::check_set subsequent error 80 - padded a file with zeros because we were unable to read all data from endfile not being set because we already have this error 0 - success
2024/11/05-03:15:28.85700 [avtar]  upath::parentdir() discarding non-entry element 'HarddiskVolume1'
2024/11/05-03:15:28.85700 [avtar]  upath::parentdir() discarding non-entry element 'Device'
2024/11/05-03:15:28.85700 [avtar]  upath::parentdir() discarding non-entry element 'GLOBALROOT'
2024/11/05-03:15:28.85700 [avtar]  CBackupBCDUtility::isBCDBackupIssue path(\\?\globalroot\device\harddiskvolume1\efi\microsoft\boot\bcd.log) : exit code 32 bRet 1
2024/11/05-03:15:28.85700 [avtar]  CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
2024/11/05-03:15:28.85700 [avtar]  filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
  • Výsledkem tohoto chování je zálohování, které se dokončí s chybami, což později vede k selhání všech pokusů o provedení úplného obnovení systému (BMR).
  • Ovlivněné prostředí: Všechny verze modulu Avamar VSS a Windows 2012 a novější, když jsou nakonfigurovány oddíly EFI.

Cause

Tento problém byl identifikován jako problém softwaru, ke kterému dochází v serverech Microsoft Windows 2012 a novějších verzích s nakonfigurovanými oddíly EFI.
 
Upozornění: Adresář BCD (Boot Configuration Data) uvedený v protokolu nelze vyloučit ze zálohy, protože po obnovení BMR bude nutné spustit systém Windows.

Pro více podrobností navštivte:

https://learn.microsoft.com/en-us/windows/win32/vss/using-vss-automated-system-recovery-for-disaster-recovery?redirectedfrom=MSDN(externí odkaz)

Resolution

Pokud dojde k chybě s kódem 32, když doplněk Avamar Windows VSS zálohuje "EFI\Microsoft\Boot\BCD". 
Nezapomeňte do souboru avtar.cmd přidat příznak "--x31=268435456" a nainstalujte opravu HotFix (HF) podle verze klientského modulu plug-in.

  • v19.9-100-78 => HF 338870 
  • v19.10-100-135 => Není k dispozici žádné HF, upgradujte na sestavení 166 a použijte odpovídající HF
  • v19.10-100-166 (SP1) => HF338885
  • v19.12-100-186 =>HF 338884

Chcete-li stáhnout opravu hotfix ze strany podpory společnosti Dell, postupujte podle kroků popsaných v článku Avamar: Jak najít a stáhnout opravu hotfix, opravu, instalaci nebo balíček upgradu produktu z webu podpory společnosti Dell

Chcete-li použít opravu hotfix, postupujte podle pokynů poskytnutých podporou společnosti Dell pomocí souboru README nebo si přečtěte článek znalostní databáze Dell pro konkrétní opravu hotfix.

Po instalaci opravy hotfix restartujte službu doplňku Avamar Windows VSS a zkuste znovu zálohovat adresář "EFI\Microsoft\Boot\BCD".

Zkontrolujte, zda byl problém vyřešen – zkontrolujte, zda protokoly Avamar neobsahují chyby související s adresářem "EFI\Microsoft\Boot\BCD".

Upozornění: Pokud problém přetrvává i po instalaci opravy hotfix, požádejte o další pomoc podporu společnosti Dell.

Affected Products

Avamar Client for Windows

Products

Avamar, Avamar Server, Avamar Virtual Edition
Article Properties
Article Number: 000063956
Article Type: Solution
Last Modified: 06 Aug 2025
Version:  13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.