Avamar: 파일 액세스 문제로 인해 EFIMicrosoftBootBCD에 대한 오류 32와 함께 VSS 백업이 실패함
Summary: Avamar VSS 플러그인 버전을 기반으로 한 핫픽스를 사용하여 EFI 파티션 및 오류 코드 32로 인한 Avamar VSS(Volume Shadow Copy Service) 백업 실패 문제를 해결합니다.
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Symptoms
다음과 같은 증상이 관찰되었습니다.
- Avamar Windows VSS 백업이 다음 예외와 함께 완료됩니다.
[avtar] direlem error:init_ntfs_hardlink: Open file for hardlink information failed
"\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD", LastError=32
(code 32: The process cannot access the file because it is being used by another process)
- avtar 프로세스에서 다음 오류가 표시됩니다.
avtar Error <5139>: File access share error "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD"
(code 32: The process cannot access the file because it is being used by another process).
- avtar.cmd 파일에 아래 플래그를 추가하면 문제가 해결됩니다.
--x31=268435456
- 경우에 따라 문제가 지속되고 새 오류가 표시됩니다.
2024-11-04 21:15:17 avtar Info <5008>: Logging to C:\Program Files\avs\var\TXT_Daily_2030_8hrs-Test_Plantsec02-1730773800009#2-3015-VSS.log
2024-11-04 21:15:17 avtar Info <5174>: - Reading C:\Program Files\avs\var\avtar.cmd
2024/11/05-03:15:17.86100 [avtar] uflags::parsefile Printing flags from C:\Program Files\avs\var\avtar.cmd:
.cmd flag [1]: --x31=268435456
.cmd flag [2]: --debug=true
xxxxxxxxxxx
<targetlist>
<path name="\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\" />
</targetlist>
xxxxxxxxxxxxxxxxxxx
2024/11/05-03:15:28.74600 [avtar] CBackupBCDUtility::exportTmpBCD out (The operation completed successfully.) return (0) bRet (1)
2024/11/05-03:15:28.74600 [avtar] CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024/11/05-03:15:28.74600 [avtar] filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD)
2024-11-04 21:15:28 avtar Error <16507>: Path "\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD": Total processed bytes 24576 is inconsistent with original data size 28672
2024/11/05-03:15:28.85700 [avtar] ucontainer::base::check_set subsequent error 80 - padded a file with zeros because we were unable to read all data from endfile not being set because we already have this error 0 - success
2024/11/05-03:15:28.85700 [avtar] upath::parentdir() discarding non-entry element 'HarddiskVolume1'
2024/11/05-03:15:28.85700 [avtar] upath::parentdir() discarding non-entry element 'Device'
2024/11/05-03:15:28.85700 [avtar] upath::parentdir() discarding non-entry element 'GLOBALROOT'
2024/11/05-03:15:28.85700 [avtar] CBackupBCDUtility::isBCDBackupIssue path(\\?\globalroot\device\harddiskvolume1\efi\microsoft\boot\bcd.log) : exit code 32 bRet 1
2024/11/05-03:15:28.85700 [avtar] CBackupBCDUtility::convert2TempBCDPath pathOld(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
2024/11/05-03:15:28.85700 [avtar] filestream::fileopen openBCD convert2new path(\\?\GLOBALROOT\Device\HarddiskVolume1\EFI\Microsoft\Boot\BCD.LOG) pathNew(C:\Temp\av_bcd_tmp-20241104_211528\BCD.LOG)
- 이 동작으로 인해 백업이 오류와 함께 완료되어 나중에 BMR(Bare Metal Recovery)을 수행하려는 시도가 실패하게 됩니다.
- 영향을 받는 환경: 모든 버전의 Avamar VSS 플러그인 및 EFI 파티션이 구성된 경우 Windows 2012 이상
Cause
이 문제는 EFI 파티션이 구성된 Microsoft Windows 2012 Server 이상 버전에서 발생하는 소프트웨어 문제로 확인되었습니다.
주의: 로그에 인용된 BCD(Boot Configuration Data) 디렉토리는 BMR 복구 후 Windows로 부팅해야 하므로 백업에서 제외할 수 없습니다.
자세한 내용은 다음을 확인하십시오.
Resolution
Avamar Windows VSS 플러그인이 "EFI\Microsoft\Boot\BCD"를 백업할 때 코드 32 오류가 발생하는 경우
avtar.cmd 파일에 "--x31=268435456" 플래그를 추가하고 클라이언트 플러그인 버전에 따라 HF(HotFix)를 적용해야 합니다.
- v19.9-100-78 => HF 338870
- v19.10-100-135 => 사용 가능한 HF가 없습니다. 빌드 166으로 업그레이드하고 해당 HF를 적용하십시오.
- v19.10-100-166(SP1) => HF338885
- v19.12-100-186 => 고주파338884
Dell 지원 측에서 핫픽스를 다운로드하려면 Avamar: Dell 지원 웹사이트에서 제품 핫픽스, 패치, 설치 또는 업그레이드 패키지를 찾아 다운로드하는 방법
핫픽스를 적용하려면 README 파일을 사용하여 Dell 지원에서 제공하는 지침을 따르거나 특정 핫픽스에 대한 Dell 기술 자료 문서를 참조하십시오.
핫픽스를 적용한 후 Avamar Windows VSS 플러그인 서비스를 재시작하고 "EFI\Microsoft\Boot\BCD" 디렉토리를 다시 백업합니다.
Avamar 로그에서 "EFI\Microsoft\Boot\BCD" 디렉토리와 관련된 오류가 있는지 확인하여 문제가 해결되었는지 확인합니다.
주의: 핫픽스를 적용한 후에도 문제가 지속되면 Dell 지원 부서에 문의하여 추가 지원을 받으십시오.
Affected Products
Avamar Client for WindowsProducts
Avamar, Avamar Server, Avamar Virtual EditionArticle Properties
Article Number: 000063956
Article Type: Solution
Last Modified: 06 Aug 2025
Version: 13
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