ScaleIO: Виправлення MDM_Disconnect помилок
Summary: Право власності на основний диспетчер метаданих (MDM) часто переходить між серверами MDM.
Symptoms
Під час використання інструменту showevents.py з'являється така подія:
6956 2017-07-06 18:21:05.803 MDM_CLUSTER_LOST_CONNECTION WARNING The MDM, ID 27fea9a11c073e82, lost connection
У журналах trc вторинного сервера MDM відображається таке:
06/07 18:21:05.486947 0x7ffbc89feeb0:netPath_IsKaNeeded:01858: :: Connected Live CLIENT path 0x7ffb9400a060 of portal 0x7ffb94003780 net 0x7ffbac0044b0 socket 17 inflights 0 didn't receive message for 3 iterations from 10.xxx.xxx.xxx:9011. Marking as down
Cause
Розрив з'єднання MDM зазвичай відбувається, коли вторинні MDM або тай-брейк не бачили підтримки протягом періоду очікування 500 мілісекунд.
Resolution
Перевірте мережеві інтерфейсні карти (NIC) на серверах MDM і TB на наявність скинутих пакетів:
[root@scaleio-1 ~]# ifconfig ens192 ens192: flags=4163 mtu 1500 inet 10.xxx.xxx.xxx netmask 255.xxx.xxx.0 broadcast 10.xxx.xxx.xxx inet6 fe80::250:56ff:feb7:2a06 prefixlen 64 scopeid 0x20 ether 00:50:56:b7:2a:06 txqueuelen 1000 (Ethernet) RX packets 311779767 bytes 53460032583 (49.7 GiB) RX errors 0 dropped 41 overruns 0 frame 0 TX packets 312147963 bytes 45970694962 (42.8 GiB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
Крім того, перевірте затримку з'єднання між вузлами MDM і TB за допомогою команди ping:
[root@scaleio-1 ~]# ping 10.xxx.xxx.xxx PING 10.xxx.xxx.xxx (10.xxx.xxx.xxx) 56(84) bytes of data. 64 bytes from 10.xxx.xxx.xxx: icmp_seq=1 ttl=64 time=0.414 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=2 ttl=64 time=0.395 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=3 ttl=64 time=0.370 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=4 ttl=64 time=0.399 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=5 ttl=64 time=0.497 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=6 ttl=64 time=0.534 ms
Якщо затримка змінюється або наближається до 500 мс, це може бути проблемою для відключення.
Існують також немережеві причини відключення MDM. Якщо процес зависає або не отримує достатніх ресурсів процесора, він не може своєчасно надіслати пакет підтримки. Перевірте систему на завантаженість процесора за допомогою команди top.
У системах VMware віртуальна машина (VM) може не отримувати достатньо ресурсів, якщо система має перевищену підписку. Ви можете перевірити, чи це так, вивчивши час готовності процесора для віртуальної машини.