스케일IO: MDM_Disconnect 오류 문제 해결
Summary: 기본 MDM(메타데이터 관리자) 소유권은 MDM 서버 간에 자주 이동합니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
showevents.py 도구를 사용할 때 다음 이벤트가 나타납니다.
6956 2017-07-06 18:21:05.803 MDM_CLUSTER_LOST_CONNECTION WARNING The MDM, ID 27fea9a11c073e82, lost connection
보조 MDM 서버의 trc 로그에 다음이 표시됩니다.
06/07 18:21:05.486947 0x7ffbc89feeb0:netPath_IsKaNeeded:01858: :: Connected Live CLIENT path 0x7ffb9400a060 of portal 0x7ffb94003780 net 0x7ffbac0044b0 socket 17 inflights 0 didn't receive message for 3 iterations from 10.xxx.xxx.xxx:9011. Marking as down
Cause
MDM 연결 해제는 일반적으로 보조 MDM 또는 TieBreaker가 500밀리초의 제한 시간 내에 연결 유지를 확인하지 못한 경우에 발생합니다.
Resolution
MDM 및 TB 서버의 NIC(Network Interface Card)에서 패킷 손실이 있는지 확인합니다.
[root@scaleio-1 ~]# ifconfig ens192 ens192: flags=4163 mtu 1500 inet 10.xxx.xxx.xxx netmask 255.xxx.xxx.0 broadcast 10.xxx.xxx.xxx inet6 fe80::250:56ff:feb7:2a06 prefixlen 64 scopeid 0x20 ether 00:50:56:b7:2a:06 txqueuelen 1000 (Ethernet) RX packets 311779767 bytes 53460032583 (49.7 GiB) RX errors 0 dropped 41 overruns 0 frame 0 TX packets 312147963 bytes 45970694962 (42.8 GiB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
또한 ping 명령을 사용하여 MDM 노드와 TB 간의 연결 레이턴시를 확인합니다.
[root@scaleio-1 ~]# ping 10.xxx.xxx.xxx PING 10.xxx.xxx.xxx (10.xxx.xxx.xxx) 56(84) bytes of data. 64 bytes from 10.xxx.xxx.xxx: icmp_seq=1 ttl=64 time=0.414 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=2 ttl=64 time=0.395 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=3 ttl=64 time=0.370 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=4 ttl=64 time=0.399 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=5 ttl=64 time=0.497 ms 64 bytes from 10.xxx.xxx.xxx: icmp_seq=6 ttl=64 time=0.534 ms
레이턴시가 다양하거나 500ms에 가까운 경우 연결 해제 문제일 수 있습니다.
MDM 연결이 끊긴 이유는 네트워크 외의 이유도 있습니다. 프로세스가 중단되거나 적절한 CPU 리소스를 수신하지 못하는 경우 keepalive 패킷을 적시에 보낼 수 없습니다. top 명령을 사용하여 시스템의 CPU 사용률을 확인합니다.
VMware 시스템에서는 시스템이 초과 할당된 경우 VM(Virtual Machine)에 충분한 리소스가 수신되지 않을 수 있습니다. VM에 대한 CPU 준비 시간을 검사하여 이러한 상황인지 확인할 수 있습니다.
Affected Products
VxFlex Product FamilyProducts
PowerFlex Software, VxFlex Product FamilyArticle Properties
Article Number: 000064168
Article Type: Solution
Last Modified: 20 May 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.