Data Domain: Problemy podczas dodawania trasy w DDMC 2.0

Summary: W oprogramowaniu DataDomain Management Center w wersji 2.0.x wystąpiła wada, która powoduje niepowodzenie dodawania tras statycznych z poziomu interfejsu wiersza polecenia lub graficznego interfejsu użytkownika ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Ze względu na defekt w kodzie DataDomain Management Center (DDMC) w wersji 2.0.x klient nie będzie mógł dodać tras statycznych za pośrednictwem interfejsu CLI lub graficznego interfejsu użytkownika.

Wszystkie próby i odmiany poleceń dodawania trasy zakończą się niepowodzeniem, na przykład następujące działania w trybie administratora lub SE:
# net route add -net 10.154.x.x maska sieci 255.255.255.0 gw 10.157.x.x dev ethV1
# net route add ipversion ipv4 -net 10.154.x.x maska sieci 255.255.255.0 gw 10.157.x.x dev ethV1
# net route add ipversion ipv4 -net 10.154.x.x maska sieci 255.255.255.0 gw 10.157.x.x ethV1



Wszystkie polecenia zwracają ten sam wynik:

Error: Błąd systemowy polecenia trasy.

Jeśli klient lub pomoc techniczna sprawdzi plik messages.engineering (poprzez "log view debug/messages.engineering", jeśli używasz CLI), można znaleźć następujące komunikaty o błędach:

gru 8 13:18:17 GDS-BEGIA-0418 sms: INFORMACJE: sms_net_add_route_job: Polecenie trasy: /ddr/bin/ddroute.py add -net 10.154.x.x maska sieci 255.255.255.0 gw 10.157.x.x ethV1 gru 8 13:18:17 GDS-BEGIA-0418 sms: UWAGA: Uruchom: /ddr/bin/ddroute.py add - net 10.154.33.0 maska sieci 255.255.255.0 gw 10.157.x.x ethV1 gru 8 13:18:17 GDS-BEGIA-0418 sms: UWAGA: błąd trasy exec:127 gru 8 13:18:17 GDS-BEGIA-0418 sms: UWAGA: sms_net_add_route_job: Polecenie trasy nie powiodło się: Podczas wykonywania wewnętrznego polecenia wystąpił błąd.: gru 8 13:18:17 GDS-BEGIA-0418 ddsh: UWAGA: MSG-DDSH-00017: (tty=pts/0, session=21095) root: polecenie "net route add -net 10.154.x.x netmask 255.255.255.0 gw 10.157.64.94 ethV1" zakończone kodem: 41

Niektórzy klienci mogą nawet zauważyć, że DDMC , pomimo rozruchu i dostępności za pośrednictwem konsoli VMware, nie można uzyskać dostępu przez SSH, a nawet ping nie działa. Ponieważ domyślna brama DDMC, jeśli jest skonfigurowana, jest trasą statyczną, dodawanie nie powiedzie się podczas uruchamiania DDMC 2.0.0.x, dlatego jeśli klient spróbuje uzyskać dostęp do DDMC z sieci, do której maszyna wirtualna nie jest bezpośrednio podłączona, DDMC nie będzie osiągalne dla ping, SSH lub graficznego interfejsu użytkownika.
 

 

Cause

Przyczyną tego problemu są pewne rozległe zmiany w podstawowym silniku routingu, które zostały wykonane w DDMC 2.x i DDOS 6.x w celu zaimplementowania "routingu opartego na zasadach". Podczas przenoszenia konfiguracji routingu z wcześniejszych wydań do nowych skrypt otoki o nazwie "/ddr/bin/ddroute.py" zostanie uruchomiony przez DDMC podczas dodawania tras trwałych skonfigurowanych w rejestrze, ale skrypt nie przeanalizuje poprawnie danych wejściowych i może nie dodać niektórych tras.

Resolution

Ta usterka została częściowo usunięta i obecnie naprawiona w niektórych przypadkach w wersjach DDMC 2.0.1.0 i 2.1.0.0.

Jeśli nawet po uaktualnieniu do wymienionych wersji brama domyślna nie zostanie automatycznie dodana do DD podczas rozruchu, klient może użyć następującego polecenia CLI z hosta DDMC, aby dodać trasę ręcznie. Trasa zostanie dodana i będzie zachowywana po ponownym uruchomieniu:

# net route set gateway DEFAULT_GW_IP_ADDRESS


W przypadku innych tras statycznych innych niż brama domyślna klient może również użyć następującego interfejsu wiersza polecenia (przykład, aby skierować cały ruch do prywatnej sieci 192.168.1.0/24 przez interfejs ethV0, używając adresu IP 192.168.1.1 jako adresu IP dla następnego przeskoku):

# net route add net 192.168.1.0 netmask 255.255.255.0 gw 192.168.1.1 dev ethV0

Affected Products

Data Domain

Products

Data Domain, PowerProtect Data Domain Management Center
Article Properties
Article Number: 000064214
Article Type: Solution
Last Modified: 11 Oct 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.