DDOS 5.7: Přístup k souboru se systémem CIFS ve fondu MTree, který je cílem replikace fondu MTree, způsobuje po upgradu paniku nebo restartování systému DDFS nebo zpracování zastaralých souborů

Summary: Pokus o přístup k souborům ve fondu MTree nástroje Data Domain Restorer (DDR) používaném jako cíl pro replikaci fondu MTree prostřednictvím protokolu CIFS může způsobit paniku / restartování systému DDFS nebo zastaralé zpracování souborů po upgradu systému DDOS 5.7 nebo novějších ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Zařízení Data Domain Restorer (DDR) lze nakonfigurovat tak, aby replikovala obsah jednotlivých fondů MTree v jednom systému do vzdáleného systému prostřednictvím replikace MTree (MREPL). Přestože je fond MTree v cíli pouze ke čtení, lze jej stále používat pro přístup k replikovaným souborům za účelem čtení/obnovení/hlášení nebo další odchozí replikace.

Pokud cílový systém DDR využívá systém DDOS 5.7 a k fondu MTree používanému jako cíl pro protokol MREPL se přistupuje prostřednictvím systému CIFS, může v procesu DD FS docházet k panice/restartování (což způsobí přerušení běhu zálohování/obnovení/replikace) z důvodu chyby v kódu, s možnými podpisy PANE, jak je znázorněno níže:

 

PANIKA: fmcl/fm_inode.c: fm_iput_unpin: 468: fm_iput_unpin se nezdařilo. Direnty jsou stále přítomny. PANIKA: ddr/fm/fm_server.c: fms_write_segs: 1891: str == NULL PANIKA: ddr/fm/fm_dm1_access.c: fm_dm1_access_intern: 203: fms_is_private_file_handle(&attr-fh>) &&&cred != g_nocred_p

Kromě toho se u klienta CIFS, který se připojuje k fondu MTree prostřednictvím systému CIFS, mohou zobrazit chyby "invalid handle". Upozorňujeme, že tento problém se týká pouze modulů DDR se systémem DDOS 5.7 a netýká se žádné jiné verze systému DDOS.
 

Existuje také další možný projev stejného problému, ke kterému může dojít v systému DDOS 6.x nebo novějších, i když je popsaná závada opravena (verze viz níže). Původní oprava nedokázala identifikovat jinou cestu kódu pro stejnou chybu (konkrétně když je cílový soubor FS pro fond MTree používaný pro přístup k souborům prostřednictvím systému CIFS 100% plný), což může mít za následek stejný řetězec PANIC níže, což bylo od té doby opraveno v některých verzích systému DDOS 6.x:

09/12 01:56:30.847 (TID 0x7f557410ec20): ERROR: MSG-INTRNL-00001: PANIKA: fmcl/fm_inode.c: fm_iput_unpin: 469: fm_iput_unpin se nezdařilo. Direnty jsou stále přítomny.



Cause

Systém DDOS 5.7 a novější (který zcela změnil základní implementaci SMB/CIFS v systému DDOS) obsahují nové funkce umožňující stavové popisovače souborů CIFS. Tento problém je způsoben chybou ve způsobu, jakým tyto stavové popisovače souborů CIFS interagují s funkcí replikace MTree.

Resolution

Oprava tohoto problému byla zahrnuta do následujících vydání oprav hotfix/patch systému DDOS (poznámka: od září 2019 již není verze DDOS 5.7 podporovaná):
  • DDOS 5.7.1.10 a novější
  • DDOS 5.7.2.0 a novější
  • DDOS 5.7.32.0 (tato verze se vztahuje pouze na virtuální zařízení Data Domain Virtual Edition / DDVE)
Zákazníci by v tuto chvíli měli provést upgrade na podporovanou verzi systému DDOS 6.x, protože ukončení podpory pro řadu DDOS 5.7 skončilo 31. ledna 2019.


V případě výjimečné závady, ke které může dojít, když je systém FS fungující jako cíl pro MREPL 100% plný, není oprava v žádné verzi systému DDOS 5.7, ale existuje v následujících pozdějších (a aktuálně podporovaných) vydáních:
  • DDOS 6.0.2.40 a novější
  • DDOS 6.1.2.30 a novější
  • DDOS 6.2.0.20 a novější
Stejně jako v tomto případě (když je problémový DD FS 100 %) nemusí být okamžitě možné upgradovat DDOS kvůli nedostatku místa na FS, možné zástupné řešení může být:
  • Zakažte veškerý příjem a protokoly, které se používají, a také replikaci.
  • Spusťte proces clean (i když je soubor FS 100% plný, měl by se dokončit v pořádku) a počkejte na dokončení
  • Pokud by nyní soubor souborů neměl být 100% plný, věnujte čas odebrání dalších záloh, kontrole starých snapshotů atd. a spusťte čištění znovu
  • Pokud je množství místa na disku dostatečné k tomu, aby nedošlo k opětovnému zaplnění systému souborů, znovu povolte protokoly a obnovte zálohování
  • Naplánujte upgrade na pevnou verzi na pozdější dobu
Pokud je systém souborů mimo provoz nebo opakovaně selhává, kontaktujte svého smluvního poskytovatele podpory, abychom vám mohli pomoci s alternativním zástupným řešením.

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000064526
Article Type: Solution
Last Modified: 11 Sep 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.