DDOS 5.7: MTreeレプリケーションのデスティネーションであるMTreeでCIFSを使用してファイルにアクセスすると、アップグレード後にDDFSパニックが発生したり、再起動したり、ファイル ハンドルが古くなったりします

Summary: CIFSプロトコルを介してMTreeレプリケーションのデスティネーションとして使用されているData Domain Restorer (DDR)のMTree内のファイルにアクセスしようとすると、DDOS 5.7以降のリリースのアップグレード後にDDFSパニック/再起動または古いファイル ハンドルが発生することがある

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Symptoms



DDR (Data Domain Restorers) は、MTree レプリケーション (MREPL) を介して、1 つのシステム上の個々の MTree の内容をリモート システムにレプリケートするように構成できます。デスティネーション上のMTreeは読み取り専用ですが、読み取り/リストア/レポート作成、またはさらなる送信レプリケーションのためにレプリケートされたファイルにアクセスするために使用できます

宛先DDRがDDOS 5.7を実行していて、MREPLの宛先として使用されるMTreeにCIFS経由でアクセスする場合、DD FSプロセスで、コードの欠陥が原因でパニック/再起動が発生する(バックアップ/リストア/レプリケーションの実行が中断される)ことがあります。次に示すように、パニック シグネチャが発生する可能性があります。

 

パニック:fmcl/fm_inode.c:fm_iput_unpin: 468: fm_iput_unpinが失敗しました。ディレントはまだ存在しています。 パニック: ddr/fm/fm_server.c: fms_write_segs: 1891: str == NULL パニック: ddr/fm/fm_dm1_access.c: fm_dm1_access_intern: 203: fms_is_private_file_handle(&attr->fh) && cred != g_nocred_p

また、CIFS経由でMTreeに接続しているCIFSクライアントに「invalid handle」エラーが表示されることがあります。この問題は、DDOS 5.7を実行しているDDRにのみ影響し、DDOSの他のリリースには適用されないことに注意してください。
 

また、説明されている不具合が修正された場合でも、DDOS 6.x以降のリリースで同じ問題が発生する可能性があります(リリースについては、以下を参照)。元の修正では、同じ欠陥(CIFS経由でファイルへのアクセスに使用されているMTreeのデスティネーションFSが100%フルの場合)に対する別のコード パスの特定に失敗しました。これにより、以下の同じパニック文字列が生成される可能性があり、その後、一部のDDOS 6.xリリースで修正されました。

09/12 01:56:30.847 (tid 0x7f557410ec20): ERROR: MSG-INTRNL-00001: パニック:fmcl/fm_inode.c:fm_iput_unpin: 469: fm_iput_unpinが失敗しました。ディレントはまだ存在しています。



Cause

DDOS 5.7以降(DDOSの基盤となるSMB/CIFS実装を完全に変更)には、ステートフルCIFSファイル ハンドルを可能にする新機能が含まれています。この問題は、これらのステートフルCIFSファイル ハンドルがMTreeレプリケーション機能と連携する方法の欠陥が原因で発生します。

Resolution

この問題の修正は、DDOSの次のホットフィックス/パッチ リリースに含まれていることに注意してください(2019年9月現在、DDOS 5.7はサポート対象外のリリースです)。
  • DDOS 5.7.1.10以降
  • DDOS 5.7.2.0以降
  • DDOS 5.7.32.0(このリリースはData Domain Virtual Edition/DDVE仮想アプライアンスにのみ適用)
DDOS 5.7ファミリーのサポートは2019年1月31日に終了しました。


MREPLのデスティネーションとして機能するFSが100%フルのときに発生する可能性のあるまれな不具合については、DDOS 5.7バージョンのどのバージョンにも修正はありませんが、次の新しい(および現在サポートされている)リリースには修正されています。
  • DDOS 6.0.2.40以降
  • DDOS 6.1.2.30以降
  • DDOS 6.2.0.20以降
このケース(問題のあるDD FSが100%の場合)のように、FSスペースの不足によりDDOSをすぐにアップグレードできない場合があります。考えられる回避策は次のとおりです。
  • 使用されているすべての取得とプロトコル、およびレプリケーションを無効にします
  • クリーンを実行し(FSが100%フルの場合でも、正常に完了するはずです)、完了するまで待ちます
  • FSが100%フルではなくなったので、時間をかけて追加のバックアップを削除し、古いスナップショットなどを確認して、もう一度クリーンを実行します
  • FSが再びいっぱいになるのを防ぐのに十分なディスク領域がある場合は、プロトコルを再度有効にして、バックアップを再開します
  • 修正済みリリースへのアップグレードを後で計画する
FSのダウンまたはクラッシュが繰り返し発生する場合は、契約しているサポート プロバイダーにご連絡ください。代替の回避策をお手伝いいたします。

Affected Products

Data Domain

Products

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Article Properties
Article Number: 000064526
Article Type: Solution
Last Modified: 11 Sep 2025
Version:  4
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