DDOS 5.7: MTree çoğaltma hedefi olan MTree'de CIFS içeren dosyaya erişmek, yükseltmeden sonra DDFS paniklerine veya yeniden başlatmalara ya da eski dosya işlemelerine neden oluyor

Summary: CIFS protokolü aracılığıyla MTree çoğaltması için hedef olarak kullanılan bir Data Domain Restorer (DDR) MTree'sindeki dosyalara erişmeye çalışmak, DDOS 5.7 veya sonraki sürümleri yükselttikten sonra DDFS paniklerine/yeniden başlatmalarına veya eski dosya işlemelerine neden olabilir ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Data Domain Geri Yükleyiciler (DDR'ler), MTree Çoğaltma (MREPL) aracılığıyla bir sistemdeki ayrı MTree'lerin içeriğini uzak bir sisteme çoğaltmak için yapılandırılabilir. Hedefteki MTree salt okunur olmasına rağmen, okuma/geri yükleme/raporlama veya daha fazla giden çoğaltma için çoğaltılmış dosyalara erişmek için kullanılabilir.

Hedef DDR'de DDOS 5.7 çalıştırılıyorsa ve MREPL için hedef olarak kullanılan bir MTree'ye CIFS aracılığıyla erişilirse DD FS işlemi, koddaki bir kusur nedeniyle aşağıda gösterildiği gibi olası PANIC imzalarıyla PANIC imzalarıyla PANIC'ler/yeniden başlatmalar yaşayabilir (yedeklemeleri/geri yüklemeleri/çoğaltmaları çalıştırmada kesintiye neden olabilir):

 

PANIC: fmcl/fm_inode.c: fm_iput_unpin: 468: fm_iput_unpin başarısız oldu. Direntler hala mevcut. PANIC: ddr/fm/fm_server.c: fms_write_segs: 1891: str == NULL PANIC: ddr/fm/fm_dm1_access.c: fm_dm1_access_intern: 203: fms_is_private_file_handle(&attr-fh>) && cred != g_nocred_p

Ayrıca, CIFS aracılığıyla MTree'ye bağlanan CIFS istemcisi "geçersiz tanıtıcı" hatalarıyla karşılaşabilir. Bu sorunun yalnızca DDOS 5.7 çalıştıran DD'leri etkilediğini ve DDOS un diğer sürümleri için geçerli olmadığını unutmayın.
 

Ayrıca, açıklanan kusur düzeltilmiş olsa bile aynı sorunun DDOS 6.x veya sonraki sürümlerde ortaya çıkabilecek başka bir olası belirtisi daha vardır (sürümler için aşağıya bakın). Orijinal düzeltme, aynı hata için başka bir kod yolu tanımlayamadı (yani, CIFS aracılığıyla dosyalara erişmek için kullanılan MTree için hedef FS %100 dolu olduğunda), bu da aşağıda aynı PANIC dizesine neden olabilir ve o zamandan beri bazı DDOS 6.x sürümlerinde düzeltildi:

09/12 01:56:30.847 (tid 0x7f557410ec20): ERROR: MSG-INTRNL-00001: PANIC: fmcl/fm_inode.c: fm_iput_unpin: 469: fm_iput_unpin başarısız oldu. Direntler hala mevcut.



Cause

DDOS 5.7 ve üzeri sürümler (DDOS'ta temel alınan SMB/CIFS uygulamasını tamamen değiştirmiştir), durum bilgisi olan CIFS dosya tanıtıcılarına olanak tanıyan yeni işlevler içerir. Bu sorun, bu durum bilgisi olan CIFS dosya işleyicilerinin MTree çoğaltma işleviyle etkileşim biçimindeki bir kusurdan kaynaklanır.

Resolution

Bu sorun için DDOS'un aşağıdaki düzeltme/yama sürümlerine bir düzeltme eklendiğini unutmayın (not: Eylül 2019, DDOS 5.7 artık desteklenen bir sürüm değildir):
  • DDOS 5.7.1.10 ve sonraki sürümler
  • DDOS 5.7.2.0 ve sonraki sürümler
  • DDOS 5.7.32.0 (bu sürüm yalnızca Data Domain Virtual Edition/DDVE sanal aygıtları için geçerlidir)
DDOS 5.7 ailesi için destek sonlandırma süresi 31 Ocak 2019'da sona erdiğinden, müşterilerin şu anda desteklenen bir DDOS 6.x sürümüne yükseltmeleri gerekir.


MREPL için hedef olarak hareket eden FS %100 dolu olduğunda rastlanabilecek köşe durumu hatası için hiçbir DDOS 5.7 sürümünde düzeltme yoktur ancak aşağıdaki sonraki (ve şu anda desteklenen) sürümlerde mevcuttur:
  • DDOS 6.0.2.40 ve sonraki sürümler
  • DDOS 6.1.2.30 ve sonraki sürümler
  • DDOS 6.2.0.20 ve sonraki sürümler
Bu durumda olduğu gibi (sorunlu DD FS %100 olduğunda) FS alanı yetersizliği nedeniyle DDOS'u yükseltmek hemen mümkün olmayabilir, olası bir geçici çözüm şu şekilde olabilir:
  • Kullanılan tüm alma ve protokollerin yanı sıra çoğaltmayı devre dışı bırakma
  • Temiz çalıştırın (FS %100 dolu olsa bile sorunsuz bir şekilde tamamlanmalıdır) ve tamamlanmasını bekleyin
  • FS artık %100 dolu olmayacağına göre ek yedekleri kaldırmak, eski anlık görüntüleri kontrol etmek vb. için zaman ayırın ve tekrar temiz çalıştırın
  • Disk alanı miktarı FS'yi tekrar doldurmaktan kaçınmak için yeterli olduğunda protokolleri yeniden etkinleştirin ve yedeklemeleri sürdürün
  • Sabit bir sürüme yükseltmeyi daha sonra planlayın
FS çalışmıyorsa veya tekrar tekrar çöküyorsa, alternatif bir geçici çözüm konusunda yardımcı olabilmemiz için lütfen sözleşmeli destek sağlayıcınızla iletişime geçin.

Affected Products

Data Domain

Products

Data Domain
Article Properties
Article Number: 000064526
Article Type: Solution
Last Modified: 11 Sep 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.