Cisco DCNM 7.2(2a) Error: FATAL: password authentication failed for user "dcnmuser"
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
- Unable to log into DCNM. Receiving the following error message:
Unable to connect to DCNM server
- Unable to restart the DCNM SAN service. Receiving the following error message:
Unable to connect to database
Reason: FATAL: password authentication failed for user "dcnmuser"
- Tried installing Postgres DB first and saw that the Postgres service did not come up after the installation.
Cause
Two causes were identified as contributing to this issue:
- The initial install of DCNM was using the domain administrator and not the local administrator on DCNM server itself.
- The default port 5432 used by PosgreSQL was being used by another application on the DCNM server so the connection to the DB was impacted due to this.
Resolution
- Installed Postgres using Run as Administrator option.
- The default listening port 5432 of Postgres was occupied so another available listening port was used.
- Installed DCNM by pointing to the existing installed Postgres DB.
Affected Products
Connectrix MDS-Series Data Center Network ManagerProducts
Connectrix MDS-Series Data Center Network ManagerArticle Properties
Article Number: 000064942
Article Type: Solution
Last Modified: 23 Sep 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.