ViPR SRM: Isilon Clusters Interfaces report showing all aggregate interfaces as 'Down'
Summary: Isilon interfaces summary report showing all aggregate network interfaces as 'Down' due to invalid status returns from the REST API.
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Symptoms
Isilon network interfaces status report found in ViPR SRM at:
"All >> Report Library >> EMC Isilon >> Clusters Summary >> <HOSTNAME> >> Node Details >> <NODE> >> Interfaces" displays the status of all aggregate network interfaces as "Down" as per the screenshot below:
"All >> Report Library >> EMC Isilon >> Clusters Summary >> <HOSTNAME> >> Node Details >> <NODE> >> Interfaces" displays the status of all aggregate network interfaces as "Down" as per the screenshot below:
Cause
Current ViPR SRM Isilon collector XML code returns the following three possible values for network interface status that is provided by the Isilon REST API:
<replace value="3" by="100" />
<replace value="2" by="50" />
<replace value="1" by="0" />
Whereby status values 2 and 3 are deemed "Up" and value 1 is set to "Down." However, the Isilon REST API calls are returning a value of "0" for all aggregate interfaces, which is not defined in ViPR SRM Isilon collector XML code. This then defaults this value to "0," hence rendering all aggregate interface statuses in ViPR SRM to "Down."
The following script, when performed against the Isilon node, reports on the status of both physical and aggregate Isilon network interfaces:
# ====================
# script begin
for i in 1 2 3 4 5 6 7 8
do
echo "iface $i"
echo "--------"
curl -k -u "<user>:<password>" -H "Content-Type: application/json" -X GET "https://$1:8080/platform/1/statistics/current?key=node.net.iface.name.$i&key=node.net.iface.status.$i"
done
# script end
# ========================
Before performing the above script, enter the root user ID and password of the Isilon node and pass the IP address of Isilon node as the script argument.
<replace value="3" by="100" />
<replace value="2" by="50" />
<replace value="1" by="0" />
The following script, when performed against the Isilon node, reports on the status of both physical and aggregate Isilon network interfaces:
# ====================
# script begin
for i in 1 2 3 4 5 6 7 8
do
echo "iface $i"
echo "--------"
curl -k -u "<user>:<password>" -H "Content-Type: application/json" -X GET "https://$1:8080/platform/1/statistics/current?key=node.net.iface.name.$i&key=node.net.iface.status.$i"
done
# script end
# ========================
Before performing the above script, enter the root user ID and password of the Isilon node and pass the IP address of Isilon node as the script argument.
Resolution
ViPR SRM Engineering team have acknowledged the issue and are working to incorporate the fix into the next release of ViPR SRM.
Note: As of date this solution was updated (that is, August 2021), as per Isilon Engineering, it was noticed that this issue is in OneFS 8.1.2.0 which has reached End of Standard Support. The issue does not exist in OneFS 8.2.0 or higher. Since 8.1.2 is end of standard support, it is not fixed in the now deprecated version of OneFS. If the issue exists in OneFS 8.2.0 or higher (8.2.1, 8.2.2, 9.0), raise a support request with Isilon customer service team, so that Isilon Engineering can address the issue.
Note: As of date this solution was updated (that is, August 2021), as per Isilon Engineering, it was noticed that this issue is in OneFS 8.1.2.0 which has reached End of Standard Support. The issue does not exist in OneFS 8.2.0 or higher. Since 8.1.2 is end of standard support, it is not fixed in the now deprecated version of OneFS. If the issue exists in OneFS 8.2.0 or higher (8.2.1, 8.2.2, 9.0), raise a support request with Isilon customer service team, so that Isilon Engineering can address the issue.
Additional Information
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- On the EMC Online Support site, select Support > Support By Product.
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Affected Products
SRMArticle Properties
Article Number: 000065064
Article Type: Solution
Last Modified: 16 Aug 2021
Version: 3
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