VNXe: Reset the Admin Password from UEMCLI Client (Windows)

Summary: Reset the Admin Password from UEMCLI Client (Windows)

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Symptoms



Issue : Unable to reset the admin Credentials of the VNXe using Unisphere CLI Client .Getting errors of Access Denied and Operation failed .

1)Error Codes  : Operation failed. Error code: 0x6000002. You are not authorized to perform the requested operation. Access is denied. (Error Code:0x6000002)
2)Error Codes : Operation failed. Error code: 0x100000a .The system was unable to connect to the storage server. (Error Code:0x100000a)
3)Error Codes : 'uemcli.exe' is not recognized as an internal or external command, operable program or batch file.

Cause

Cause : To use the Uemcli scripts from the host it s necessary to install and launch the Unisphere CLI ADD  ON at Host end.
The basic reason for the above all error codes might be due to invalid Credentials and Unisphere CLI version issues with the Host .
Need to check the admin credentials and its proper usage as per the below syntax  .
Also, need to check that the proper version of the Unisphere CLI is installed on the Host .
i.e. Unisphere CLI for Windows 32-bit/64-bit .
e.g for Windows 64-bit , click on the below link to download the Unisphere CLI :
https://download.emc.com/downloads/DL53565_VNXe_Unisphere_CLI_(Windows_32-bit)_1.5.4.1.0027-1.exe?source=OLS

Resolution

Resolution :
Need to follow procedure for installing and launching :
To install the Unisphere CLI client:
1. Go to the EMC Online Support website. 
2. Download the Unisphere CLI client for your operating system.
3. Perform the following based on your operating system:
 
  On Windows, double-click the installer executable and follow the prompts. The default installation location is:
C:\Program Files\EMC\Unisphere CLI
 
Note: The installation directory is added to the PATH system variable.
 
Launch the Unisphere CLI client : 
 
To launch the Unisphere CLI client, perform the following in a command prompt based on your operating system:
== On Windows, type: uemcli.exe
Execute the below commands from Host : 
1)      Ping <IP address of VNXe you want reset the admin Password>
2)      Issue the command to check the user list : 
uemcli -d 10.xx.xx.xxx -u Local/admin -p <Password of admin user> /user/account show
 
3)      Note the user Id for which you want to reset the password . 
uemcli -d 10.xx.xx.xxx -u Local/admin -p <Password of admin user> /user/account -id user_admin set -passwdSecure  force
 
C:\Users\pach>uemcli -d 10.xx.xx.xxx -u Local/admin -p Nasadmin@161# /user/account show
Storage system address: 10.xx.xx.xxx
Storage system port: 443
HTTPS connection
 
1:    ID   = user_admin
      Name = admin
      Role = administrator
      Type = local
  
C:\Users\pach>uemcli -d 10.xx.xx.xxx -u Local/admin -p Nasadmin@161# /user/account -id user_admin set -passwdSecure -force
Storage system address: 10.xx.xx.xxx
Storage system port: 443
HTTPS connection
 
[Secure] Type a new password for a local user.
Password:
Confirm password:
ID = user_admin
Operation completed successfully.

Affected Products

VNXe1 Series

Products

VNXe1 Series
Article Properties
Article Number: 000065278
Article Type: Solution
Last Modified: 06 Nov 2025
Version:  3
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