RecoverPoint. На сервере перехватывается исключение [ java.lang.NullPointerException ] при изменении параметров NTP в графическом интерфейсе пользователя или интерфейсе командной строки

Summary: Клиенты могут обнаружить, что невозможно изменить сервер NTP сразу после обновления кода до версии 4.1.2.x или 4.3.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Обновление RP до 4.1.2.x или 4.3 с предыдущих версий:

RecoverPoint Splitter: Программное обеспечение Splitter
EMC для VNX: Программное обеспечение EMC RecoverPoint 4.1.2.x
: EMC RecoverPoint (RP4VM) 4.3

 

Влияние на клиента: Если первичная или вторичная служба DNS не предопределена, изменить IP-адрес сервера NTP невозможно из-за исключения нулевого указателя (NPE).

Влияние на RP: NPE выбрасывается из installation_server при попытке изменить настройки.



Симптомы, найденные в журналах:

Исключение перехвачено на сервере [java.lang.NullPointerException].

В installation_server логах есть (Pathfile: files/files/kos/installationLogs/server.log)

2016-01-11 20:25:59,687 [CommandWorker-6] (Command.java:69) ERROR - Command#run() throwable. UID ошибки: 9dda9d2a-9037-405a-bb7f-e01f009baebd java.lang.NullPointerException at com.kashya.installation.server.commands.global.modify.modifications.DnsModifier.isSiteChanged(DnsModifier.java:10)




Cause

В процессе модификации installation_server проверяет каждую деталь в globalsystemconfig.xml на предмет изменений. Когда он проверяет DNS, он выдает NPE, так как DNS не настроен. Этого не должно происходить, так как DNS не является обязательным.

Resolution

Временное решение.

Для данной проблемы существует решение, но требуется вмешательство сотрудников службы технической поддержки EMC. Для устранения этой проблемы персоналу службы поддержки необходим доступ к системе хранения. Обратитесь в центр поддержки заказчиков EMC или к своему представителю по обслуживанию для получения технической помощи и укажите идентификатор решения в базе знаний EMC.


Решение.

Эта проблема устранена в следующих версиях RecoverPoint: 4.1.SP3, 4.3.SP1 и 4.4.P1
Чтобы определить, подходит ли модернизация для вашей среды, обратитесь в центр поддержки заказчиков EMC или к своему менеджеру по обслуживанию и укажите идентификатор этого решения.



Affected Products

RecoverPoint

Products

RecoverPoint
Article Properties
Article Number: 000065291
Article Type: Solution
Last Modified: 04 Aug 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.