ViPR Controller - User authentication failed when discovering VPLEX Storage Provider
Summary: This article talks about Error 16001: Unable to contact the SMI-S provider and has steps to check the state of the setup.
Symptoms
When discovering a VPLEX Storage Provider, it fails with error:
Error 16001: Unable to contact the SMI-S proivider
Unable to call Storage Provider successfully. Caused by: Failed to establish a connection to the storage provider
And in the controllersvc logs you will find the following:
connectivity response is {
"response": {
"context": null,
"message": "User authentication failed.",
"exception": null,
"custom-data": null
}
If you cannot see the above response in the logs, open a putty session and run the following curl command to check the communication between ViPR nodes and VPLEX API:
curl --insecure -i -H "Accept: application/json" -H "username: <username_defined_in_storage_provider" -H "password: <user_password>" https://<vplex url>:443/vplex/clusters/
Cause
- The user account that is assigned to the storage provider is either the "service" account or another user created account.
- When the user is using LDAP, user authentication fails when the user account is not "admin".
Resolution
Actions to make:
- Navigate to the Storage Provider.
- Select the VPLEX storage provider.
- Change the user to "admin".
- Type the password associated with the "admin" account.
- Rediscover VPLEX Storage Provider.
- Navigate to Storage Systems.
- Rediscover VPLEX Storage System.