ViPR Controller - User authentication failed when discovering VPLEX Storage Provider

Summary: This article talks about Error 16001: Unable to contact the SMI-S provider and has steps to check the state of the setup.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When discovering a VPLEX Storage Provider, it fails with error:

 

Error 16001: Unable to contact the SMI-S proivider
Unable to call Storage Provider successfully. Caused by: Failed to establish a connection to the storage provider


And in the controllersvc logs you will find the following:

 

connectivity response is {
    "response": {
        "context": null,
        "message": "User authentication failed.",
        "exception": null,
        "custom-data": null
    }


If you cannot see the above response in the logs, open a putty session and run the following curl command to check the communication between ViPR nodes and VPLEX API:


curl --insecure -i -H "Accept: application/json" -H "username: <username_defined_in_storage_provider" -H "password: <user_password>" https://<vplex url>:443/vplex/clusters/

 

Cause

  • The user account that is assigned to the storage provider is either the "service" account or another user created account.
  • When the user is using LDAP, user authentication fails when the user account is not "admin".
     

Resolution

Actions to make:

  1. Navigate to the Storage Provider.
  2. Select the VPLEX storage provider.
  3. Change the user to "admin".
  4. Type the password associated with the "admin" account.
  5. Rediscover VPLEX Storage Provider.
  6. Navigate to Storage Systems.
  7. Rediscover VPLEX Storage System.

Affected Products

VPLEX Series
Article Properties
Article Number: 000065647
Article Type: Solution
Last Modified: 21 Apr 2025
Version:  3
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