Certains ou tous les services ne démarrent pas automatiquement au démarrage (Linux ou Windows)

Summary: Lors d’un démarrage/redémarrage d’un serveur SRM, certains ou tous les services ne démarrent pas.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Lors du démarrage|redémarrage d’un serveur SRM, certains ou tous les services ne démarrent pas.  Les services peuvent être lancés avec succès avec
'manage-modules.sh|manage-modules.cmd service start <module>'.

Sur un serveur Linux SRM, des tests supplémentaires avec le script de démarrage, /etc/init.d/apg-service, montrent que la commande status ne fonctionne pas correctement : « service agp-services status » ne renverra pas les services qui n’ont pas démarré.

Cause

Le mode de démarrage du service a été défini sur Manuel ou Désactivé.

Resolution

Dans Centralized Management-Physical>Overview-SRM< server-Collector-Manager<>> Modules>, cliquez sur le bouton « Configure Service ».>  Assurez-vous que le mode de démarrage du service est défini sur Auto.
 
 Bouton « Configure Service » dans la gestion centralisée
 
Il existe également un fichier /opt/APG/Collecting/Collector-Manager/<collector-manager>/conf/service-user.properties qui affiche le paramètre du mode de démarrage :
cat service-user.properties
#This file has been automatically (re)generated.
#Fri Jul 29 12:24:02 EDT 2016
startup=manual

Additional Information

Consultez l’article 000469626 de la base de connaissances, Watch4net | EMC M&R | ViPR SRM : les services ne démarrent pas automatiquement après le redémarrage du serveur (Linux) pour des vérifications supplémentaires à effectuer sur les serveurs Linux SRM.

Affected Products

SRM
Article Properties
Article Number: 000065756
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.