PowerFlex:无法运行 ScaleIO 命令。Error: MDM failed command
Summary: 无法运行 ScaleIO 命令,错误:“MDM failed command.Status:会话登录无效,然后重试。”
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
尝试从主元数据管理器 (MDM) 运行命令时,ScaleIO 命令失败并显示无效会话:
# scli --mdm_ip --login --username admin Enter password: Logged in. User role is Administrator. System ID is XXXXXXXXX # scli --mdm_ip --query_all_volumes Error: MDM failed command. Status: Invalid session. Please login and try again.
Cause
导致 MDM 拒绝连接的问题是 CallHome 用户“Monitor”每十分钟再次登录一次,并且未注销。这会导致用户登录会话累积并填满会话表,然后硬超时才会踢出它们。
Resolution
删除(或注释)以下两行: mdm/cfg/conf.txt,在两个 MDM 上:
user_session_hard_timeout_secs=86400 user_session_timeout_secs=28800 Stop CallHome service temporarily
/opt/emc/scaleio/callhome/bin/delete_service.sh
重新启动 MDM 服务:
kill
等待 10 分钟,然后尝试发出 scli 命令,然后再次启动 call-home 服务。
./opt/emc/scaleio/callhome/bin/create_service.sh
Additional Information
如果 ScaleIO CLI 会话超时,也会出现此错误。
Affected Products
PowerFlex SoftwareProducts
PowerFlex SoftwareArticle Properties
Article Number: 000065938
Article Type: Solution
Last Modified: 19 Sep 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.