Data Domain: EVT-QUOTA-00002: Raggiunto limite rigido della quota MTree
Summary: Questo articolo della Knowledge Base fornisce informazioni su come e come risolvere gli avvisi sulle quote rigide in un Data Domain.
Symptoms
Gli utenti che hanno effettuato l'accesso a un Data Domain possono visualizzare avvisi come "Mtree Quota hard limit reached", ad esempio:
sysadmin@dd# alerts show current Id Post Time Severity Class Object Message ---- ------------------------ -------- ---------- --------------------------- ------------------------------------------------ m0-7 Tue Aug 13 20:05:23 2019 CRITICAL Filesystem Mtree=/data/col1/quota_test EVT-QUOTA-00002: Mtree Quota hard limit reached. ---- ------------------------ -------- ---------- --------------------------- ------------------------------------------------ There is 1 active alert.
Cause
La causa di questo avviso è che la quota rigida è assegnata a un MTree in Data Domain e la quantità di dati (pre-compressione) nell MTree ha raggiunto il limite rigido configurato. Le quote rappresentano un modo utile per gestire la crescita dei dati in MTrees separati, con il "soft limit" che genera un avviso che indica che la quantità di dati pre-compressione nell MTree ha superato la soglia. Pertanto, l'amministratore del backup dispone di preavviso e tempo sufficiente per verificare se la crescita è quella prevista nel caso in cui siano necessarie azioni correttive.
Tuttavia, una volta raggiunto il limite rigido della quota MTree configurato, non sono consentite ulteriori scritture sull MTree fino a quando l'amministratore, tramite l'applicazione di backup, non rimuove alcuni dei file nell MTree o, in alternativa, aumenta o rimuove il limite di quota rigido per l MTree.
Per visualizzare i valori di quota configurati per un MTree, utilizzare un comando simile al seguente:
sysadmin@dd# quota capacity show mtrees /data/col1/quota_test Mtree Pre-Comp (MiB) Soft-Limit (MiB) Hard-Limit (MiB) --------------------- -------------- ---------------- ---------------- /data/col1/quota_test 6 2 6 --------------------- -------------- ---------------- ----------------
Per una stima approssimativa di come vengono utilizzati i dati dello spazio su disco, in particolare gli MTrees, consultare l'articolo 465216 della Knowledge Base: Domande frequenti su Data Domain Operating System (DDOS) Misurazione e reporting della capacità fisica (PCM/PCR)
Resolution
Quando viene raggiunto un limite rigido della quota per un MTree, viene generato un avviso e ulteriori backup non riescono su tale MTree fino a quando l'amministratore non aumenta o rimuove il limite di quota rigido per l MTree (o alcuni backup nell MTree non vengono rimossi). Il semplice tentativo di rimuovere l'avviso non consente di riprendere i backup sull MTree. Una volta che il limite rigido non viene più raggiunto, l'avviso dovrebbe scomparire da solo, altrimenti cancellarlo manualmente come indicato di seguito:
sysadmin@dd# alerts clear alert-id m0-7
Opzione 1:
Se l'amministratore ritiene che il numero di backup nell MTree sia corretto, gli utenti possono scegliere di aumentare il limite di quota rigida per l MTree a un valore più elevato:
# quota capacity set mtrees /data/col1/quota_test hard-limit 100 MiB
Opzione 2:
Se l'amministratore non ritiene necessario impostare una quota rigida sull MTree, gli utenti potrebbero voler rimuovere completamente la quota rigida da tale MTree:
# quota capacity reset mtrees /data/col1/quota_test hard-limit
Se gli utenti desiderano rimuovere entrambe le impostazioni di quota per l MTree, utilizzare invece:
# quota capacity reset mtrees /data/col1/quota_test
Opzione 3:
La quota potrebbe aver consentito al cliente di realizzare più backup del necessario nell MTree in alert. In tal caso, il passaggio successivo consiste nell'utilizzare l'applicazione di backup per far scadere i file di backup non necessari.
Quando i file di backup sono scaduti e i file nel Data Domain vengono rimossi dall MTree, la pre-compressione si riduce e il limite rigido non viene più raggiunto (anche se potrebbe essere necessario cancellare manualmente l'avviso). In ogni caso, lo spazio su disco utilizzato dai backup eliminati viene recuperato da Data Domain soltanto dopo l'esecuzione e il completamento della pulizia di Data Domain.