Dell Unity : Unity inaccessible après le redémarrage du processeur de stockage principal lors de la mise à niveau

Summary: Cet article explique pourquoi les services de gestion Unity deviennent inaccessibles après le redémarrage du processeur de stockage principal lors d’une mise à niveau. (Corrigible par l’utilisateur) ...

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Symptoms

Le processeur de stockage principal redémarre pendant le processus de mise à niveau.

Les services de gestion Unity deviennent inaccessibles lors du redémarrage du processeur de stockage principal du processus de mise à niveau du code.

L’adresse IP Unity ne peut pas être interrogée par une commande ping, et Unisphere ne se charge pas.

L’accès aux données n’est pas affecté.

Cause

Dans Unity, le processeur de stockage principal gère les services de gestion (l’adresse IP).
Lorsque le processeur de stockage principal redémarre, les services de gestion basculent sur le processeur de stockage secondaire (homologue).

Problème 1 :
Si le processeur de stockage secondaire n’est pas connecté au même réseau de gestion que le processeur principal, l’adresse IP Unity devient inaccessible lorsque le service de gestion bascule.

Exemple:
Avant la mise à niveau :
  • Le SP A correspond au processeur de stockage principal et le SP B au processeur de stockage secondaire
  • Le SP A est connecté au réseau de gestion à partir duquel Unisphere est accessible.
  • Le SP B n’est pas connecté au même réseau que le SP A.
Lorsque le SP A redémarre pendant la mise à niveau :
  • Le SP B devient le processeur de stockage principal et le SP A devient le processeur de stockage secondaire.
  • Les services de gestion étant associés au SP B, l’adresse IP de gestion Unity est inaccessible.
Problème 2 :
Un deuxième problème peut se produire lorsque le basculement entre les processeurs de stockage se produit et que nous usurpons l’adresse MAC sur le nouveau processeur de stockage. Certains environnements utilisateur peuvent récupérer la nouvelle adresse MAC « dupliquée » et bloquer l’accès au port du commutateur, ce qui entraîne une perte d’accès.
 
Remarque : Une nouvelle amélioration de l’utilitaire de bilan de santé préalable à la mise à niveau (PUHC) a été introduite dans Unity OE 5.3 et versions ultérieures.

Cette amélioration recherche d’éventuels problèmes de connectivité sur les ports de gestion. Voir Dell Unity : Le bilan de santé préalable à la mise à niveau se termine avec l’avertissement : platform ::check_management_port_2 (corrigible par l’utilisateur)
Test of the management port configuration indicates there may be a problem with the management port VLAN settings that could cause loss of management functionality during storage processor reboots associated with the upgrade. Some valid network configurations can also make this test fail. Ensure that the alternate management port is properly configured. See KB#000066048 for recommended VLAN management port guidelines. You can safely ignore this warning if there is not a real issue.
Capture d’écran de l’interface utilisateur de l’avertissement PUHC :


Capture d’écran du nouvel avertissement PUHC
ce message d’avertissement indique que la baie Unity n’a pas pu confirmer la connectivité réseau de gestion du processeur de stockage (SP) homologue. La nouvelle amélioration PUHC d’Unity OE 5.3 lance une sonde ARP (Address Resolution Protocol) sur le réseau. Cela permet de confirmer tout problème de connectivité sur le processeur de stockage homologue, dans le cas où les opérations de gestion sont basculées sur le processeur de stockage homologue.

Le PUHC envoie une sonde ARP au lieu d’un ping ARP standard. L’adresse IP de gestion n’est active que sur le processeur de stockage principal, et non sur l’homologue. C’est la raison pour laquelle la vérification doit être une sonde ARP sur l’homologue. Le processeur de stockage non principal (homologue) ne dispose pas d’adresse IP configurée pour un ARP standard. Par conséquent, la demande ARP doit être envoyée avec la version 0.0.0.0 renseignée et est une sonde ARP.

Ce message d’avertissement s’affiche si aucune réponse n’est reçue de la sonde ARP.

Cet avertissement ne signifie pas que la liaison de port n’était pas fonctionnelle pour un port de gestion du SP avant la mise à niveau. Si tel était le cas, le bilan de santé préalable à la mise à niveau le récupérerait (comme indiqué dans l’article Dell Unity : Échec du bilan de santé avec le message [Code d’erreur : platform ::check_peer_management_port_link_2] (corrigible par l’utilisateur)

Resolution

Pendant le PUHC avant la mise à niveau :
Le message d’avertissement ci-dessous est un avertissement léger et non un échec :
Warning Code: platform::check_management_port_2
Utilisez l’une des options décrites dans l’article ci-dessous pour basculer les opérations de gestion sur le processeur de stockage homologue afin de tester sa connectivité avec le réseau. Dell Unity : Exécution d’un basculement des services de gestion (ECOM) (corrigible par Dell)

Dans cet article, vous pouvez également redémarrer le processeur de stockage principal actuel pour basculer les opérations de gestion sur le processeur de stockage homologue. Les opérations de gestion peuvent être perdues jusqu’à 10 minutes au cours du processus de basculement. Une fois les opérations de gestion restaurées, vérifiez que le processeur de stockage homologue est désormais le processeur de stockage principal. Si les opérations de gestion fonctionnent correctement sur le SPA et le SPB après les tests de basculement, ce message d’avertissement peut être ignoré en toute sécurité.

Pendant la mise à niveau :
Cet avertissement peut être ignoré s’il n’a été détecté qu’au milieu de la mise à niveau. Cliquez sur le bouton « Réessayer » pour poursuivre la mise à niveau.  

Contactez le support Dell et citez cet article de la base de connaissances, au cas où le bouton « Réessayer » ne fonctionnerait pas.

Après une mise à niveau réussie :
L’avertissement ci-dessous
Warning Code: platform::check_management_port_2
Peut être ignoré en toute sécurité si ce message d’avertissement a été reçu après une mise à niveau réussie vers Unity OE 5.3 ou une version ultérieure.

Additional Information

Cet article de la base de connaissances s’applique à tous les redémarrages du processeur de stockage principal, et pas uniquement aux mises à niveau.

Exemples de problème : 
  • Dans un cas, un SP était connecté au réseau de gestion tandis que l’autre câble de gestion du SP était branché sur un commutateur iSCSI.
  • Dans un autre cas, un SP était connecté au réseau de gestion tandis que l’autre câble de gestion du SP était branché sur le port du commutateur se connectant à un autre réseau via un VLAN différent.
À partir de Unity OE version 5.3, un nouveau test fait partie de l’utilitaire de vérification de l’intégrité préalable à la mise à niveau (PUHC) pour vérifier cette condition.  Ce test vérifie à la fois les SP principal et secondaire.  Le nouveau test (différent du test actuel où nous vérifions que les ports ne sont pas arrêtés) utilisera l’utilitaire « arp ping » (arping) pour vérifier si l’interface autorise le trafic ARP (Address Resolution Protocol) via son interface.  En général, les commutateurs sont configurés pour bloquer les diffusions ARP sur les VLAN. Dans la plupart des cas, ce test est fiable pour déterminer si les VLAN des ports de gestion sont correctement configurés.  Ce test peut produire un faux négatif si le commutateur est configuré pour autoriser les diffusions sur les VLAN, et le test peut produire un faux positif lorsque les diffusions sont désactivées, même au sein d’un VLAN.  Mais dans la plupart des cas, dans des conditions normales, ce nouveau test détermine si les ports de gestion sont correctement configurés dans un VLAN.

Affected Products

Dell EMC Unity Family

Products

Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
Article Properties
Article Number: 000066048
Article Type: Solution
Last Modified: 21 Jun 2024
Version:  8
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