Data Domain : l’utilisation de l’espace de collecte de données a dépassé le seuil
Summary: Data Domain envoie des alertes indiquant qu’il est pratiquement saturé (90-100 %). Cet article permet d’analyser la cause réelle en cas de problème survenant lors de la suppression des fichiers ou lorsque DD a atteint sa limite de capacité. ...
Symptoms
ddboost@prdctdd50# alerts show current Id Post Time Severity Class Object Message ----- ------------------------ -------- ---------- ------------- ---------------------------------------------------------------------------- p0-69 Fri Jun 2 20:36:00 2017 CRITICAL Filesystem FilesysType=2 EVT-SPACE-00004: Space usage in Data Collection has exceeded 100% threshold. ----- ------------------------ -------- ---------- ------------- ---------------------------------------------------------------------------- There is 1 active alert. ddboost@prdctdd50# df -kh Active Tier: Resource Size GiB Used GiB Avail GiB Use% Cleanable GiB* ---------------- -------- --------- --------- ---- -------------- /data: pre-comp - 1678028.9 - - - /data: post-comp 165663.3 165663.3 0.0 100% 28605.6 /ddvar 47.2 10.5 34.3 23% - /ddvar/core 984.3 368.6 565.7 39% - ---------------- -------- --------- --------- ---- --------------
Cause
- Les sauvegardes ne sont pas arrivées à expiration et DD contient un grand nombre d’anciens fichiers.
- DD contient un grand nombre de petits fichiers.
- DD est une source de réplication de collecte.
- Les snapshots de structure MTree hébergent des données.
- Un important décalage de réplication empêche les données d’être nettoyées pendant l’opération de nettoyage.
- L’utilisateur a atteint le niveau maximal d’ingestion de données dans DD.
Resolution
Suivez les étapes ci-dessous pour résoudre le problème.
- Vérifiez s’il y a une quantité importante de données nettoyables. Si tel est le cas, lancez un nettoyage manuel pour récupérer de l’espace.
- Les sauvegardes ne sont pas arrivées à expiration. DD contient un grand nombre d’anciens fichiers.
- Vérifiez la règle de rétention actuelle définie dans le logiciel de sauvegarde.
- Consultez la section File Distribution pour obtenir les logs d’autosupport les plus récents.
Distribution des fichiers
----------------- 59,343 files in 243 directories Count Space ----------------------------- -------------------------- Age Files % cumul% GiB % cumul% --------- ----------- ----- ------- -------- ----- ------- 1 day 1,486 2.5 2.5 6447.1 0.9 0.9 1 week 7,477 12.6 15.1 74390.0 10.1 11.0 2 weeks 12,183 20.5 35.6 94039.1 12.8 23.7 1 month 13,050 22.0 57.6 134241.0 18.2 41.9 2 months 3,432 5.8 63.4 111922.9 15.2 57.1 3 months 2,417 4.1 67.5 51673.8 7.0 64.1 6 months 2,562 4.3 71.8 154479.7 21.0 85.1 1 year 2,806 4.7 76.5 35099.5 4.8 89.8 > 1 year 13,930 23.5 100.0 74979.7 10.2 100.0 --------- ----------- ----- ------- -------- ----- -------Si DD contient des fichiers plus anciens que la durée définie dans la règle de rétention actuelle, vérifiez au niveau du logiciel de sauvegarde, car les fichiers n’expireront pas conformément à la règle.
- Si la règle a été récemment modifiée, il est possible que certains fichiers soient ingérés avec l’ancienne règle de rétention. Faites expirer manuellement les anciennes sauvegardes à partir du logiciel de sauvegarde.
- Si la règle de rétention et la distribution des fichiers sont conformes, poursuivez la procédure.
- DD contient un grand nombre de petits fichiers.
Data Domain File System est conçu pour segmenter l’ingestion de données en segments de 4 Ko à 12 Ko à des fins de déduplication. Les fichiers d’une taille inférieure à 12 Ko peuvent potentiellement occuper plus d’espace sur DD qu’ils ne le feraient sur un stockage normal. Si le système comporte de nombreux fichiers de 10 Ko ou moins, cela peut avoir un impact sur l’utilisation du stockage.
Vérifiez ce point dans les logs d’autosupport de DD. L’histogramme des petits fichiers se trouve sous File Distribution :
Count Space ----------------------------- -------------------------- Size Files % cumul% GiB % cumul% --------- ----------- ----- ------- -------- ----- ------- 1 KiB 8 0.0 0.0 0.0 0.0 0.0 10 KiB 32,792 25.1 25.1 0.2 0.0 0.0 100 KiB 32,774 25.1 50.2 2.0 0.0 0.0 500 KiB 10,607 8.1 58.3 2.3 0.0 0.0 1 MiB 1,653 1.3 59.6 1.2 0.0 0.0 5 MiB 8,036 6.2 65.7 17.5 0.0 0.0 10 MiB 2,377 1.8 67.6 15.6 0.0 0.0 50 MiB 6,680 5.1 72.7 152.1 0.0 0.0 100 MiB 1,153 0.9 73.5 72.1 0.0 0.0 500 MiB 517 0.4 73.9 120.5 0.0 0.0 1 GiB 322 0.2 74.2 233.4 0.0 0.0 5 GiB 1,432 1.1 75.3 3767.4 0.2 0.2 10 GiB 581 0.4 75.7 4416.6 0.2 0.4 50 GiB 23,715 18.2 93.9 606656.4 28.3 28.7 100 GiB 3,999 3.1 96.9 272684.4 12.7 41.4 500 GiB 3,456 2.6 99.6 982062.1 45.8 87.2 > 500 GiB 536 0.4 100.0 268000.0 12.5 99.7 --------- ----------- ----- ------- -------- ----- -------
Si c’est le cas, Dell Technologies recommande de configurer la procédure de sauvegarde afin de réduire la fréquence d’ingestion des petits fichiers. Modifiez la méthodologie de sauvegarde de manière à intégrer tous les fichiers de petite taille dans un seul fichier d’archive plus volumineux (tel qu’un fichier .tar ou .gz) avant de les écrire sur le DD.
- Les snapshots de structure MTree hébergent des données.
- Vérifiez la présence d’anciens snapshots qui n’ont pas expiré ou la présence de snapshots qui ont expiré et qui contiennent des données. Pour toutes les structures MTree, exécutez la commande suivante :
# snapshot list mtree /data/col1/<Mtree_name>
- Si d’anciens snapshots ont été détectés, qu’ils sont toujours présents et qu’ils contiennent des données, vérifiez s’il est possible de forcer leur expiration. Si c’est le cas, forcez l’expiration des snapshots.
# snapshot expire <snapshot_name> mtree /data/col1/<Mtree_name>
- Démarrez et arrêtez le nettoyage pour supprimer ces snapshots qui ont expiré :
# filesys clean start# filesys clean stop
- Vérifiez si les snapshots sont supprimés pour les structures MTree dont les snapshots viennent d’expirer :
# snapshot list mtree /data/col1/<Mtree_name>
- Si le snapshot est toujours présent, suivez la procédure Data Domain : impossible de supprimer le snapshot Mtree_replication (en anglais).
- Un important décalage de réplication empêche les données d’être supprimées pendant l’opération de nettoyage.
- Exécutez la commande suivante pour vérifier si une réplication est configurée dans DD :
# replication show config
- Exécutez la commande suivante pour vérifier si une alerte indique un décalage de réplication ou une synchronisation dans DD :
# alerts show current
- Vérifiez si la sortie de la commande indique une taille de données nettoyables :
# df
- Si le décalage de réplication est important, cassez la paire et lancez le nettoyage pour récupérer de l’espace dans DD. Une fois l’opération terminée, resynchronisez la réplication.
- Voir Data Domain : casser ou resynchroniser la réplication d’annuaires (en anglais) pour savoir comment caser et resynchroniser la réplication d’annuaires.
- L’utilisateur a atteint le niveau maximal d’ingestion de données dans DD.
Si aucune des causes ci-dessus ne semble correspondre au problème, cela signifie que DD a atteint sa capacité maximale et que l’utilisateur doit y ajouter davantage d’espace de stockage.
Additional Information
Pour plus d’informations, voir cette vidéo :
Comment résoudre le problème d’utilisation de l’espace de collecte de données sur Dell Data Domain
Durée : 00:06:35 (hh:mm:ss)
Sous-titres : aucun disponible.