NetWorker : Dépannage des erreurs de « délai d’expiration d’inactivité »
Summary: Les sauvegardes échouent avec des erreurs de délai d’inactivité.
Symptoms
Symptômes
- Error:
Inactivity timeout - Échec des sauvegardes en raison d’une erreur de délai d’expiration d’inactivité
- Sauvegardes abandonnées en raison d’une erreur de délai d’expiration d’inactivité
- Error:
(client):(save set) has been inactive for (number) minutes - Error:
SYSTEM STATE:\ aborted due to inactivity - Error:
nsrexec: clientname has been abandoned by nsrexec - Error:
nsrexecd: Recvd signal to kill process group - aborted due to inactivity - Error:
nsrexec: Attempting a kill on remote save - Les sauvegardes échouent avec des erreurs de délai d’inactivité
- Error:
inactivity timeoutPendant une sauvegarde incrémentielle - Error:
No full backups of this save set were found in the media database; performing a full backup - Échec des sauvegardes incrémentielles
- Les sauvegardes ne répondent plus
Cause
NetWorker fournit les attributs « Inactivity Timeout » à différents emplacements :
- Délai d’inactivité de la tâche du serveur NetWorker :
- Délai d’inactivité de l’action :
Le NetWorker Administration Guide fournit des informations supplémentaires sur les paramètres de « délai d’inactivité » : NetWorker Documentation
Resolution
En général, un délai d’inactivité peut être déclenché pour de nombreuses raisons.
Des erreurs de délai d’expiration d’inactivité se produisent souvent lorsque le client analyse un système de fichiers volumineux. Si quelques fichiers ont été modifiés, le flux de sauvegarde suivant peut être considérablement retardé. Cette condition peut être résolue en augmentant la valeur de l’attribut « Inactivity Timeout » pour l’action de sauvegarde NetWorker qui signale l’erreur. Définissez la valeur sur 0 pour désactiver le délai d’expiration. Observez ensuite la durée du saveset et définissez le délai d’inactivité sur ce nombre de minutes ou plus.
Si le délai d’expiration n’est pas dû à l’une des raisons énumérées ci-dessus, vérifiez les éléments suivants :
- Vérifiez que le client NetWorker n’a pas été mis hors tension et que le câble réseau est branché.
- Les tentatives de sauvegarde échouent toujours.
- Toutes les résolutions de noms entre le client NetWorker et le serveur de sauvegarde ont réussi : NetWorker : Pratiques d’excellence en matière de résolution de noms
- Vérifiez que tous les alias connus du client NetWorker ont été saisis dans l’attribut Alias de la ressource Client NetWorker.
- Toutes les cartes réseau et tous les commutateurs ont les mêmes paramètres Duplex, Vitesse, MTU et autres.
- Les paramètres de parallélisme sont correctement définis. Consultez le Guide d’optimisation et de planification des performances de NetWorker : NetWorker Documentation
- Vérifiez le paramètre TCP/IP ajustable. Consultez le Guide d’optimisation et de planification des performances de NetWorker : NetWorker Documentation
Pare-feu :
Si un pare-feu sépare le NetWorker Server et le NetWorker Client, ouvrez suffisamment de ports dans la plage de connexion NetWorker pour permettre une communication correcte. NetWorker Server peut atteindre le client, mais il se peut que le client ne parvienne pas à ouvrir de nouveaux ports pour répondre. Processus et ports NetWorker
Remarque : Consultez votre réseau ou votre équipe de sécurité pour surveiller le trafic du pare-feu pendant l’action qui échoue avec des erreurs de délai d’expiration et surveiller les problèmes de communication.
Configuration de NetWorker :
- Ce problème s’est produit en raison de la corruption des fichiers sur le disque. Vérifiez la somme de contrôle ou la date des fichiers pour garantir leur intégrité. Supprimez, déplacez ou corrigez le fichier corrompu ou utilisez la directive NetWorker pour l’ignorer.
- L’endommagement du fichier de ressource NetWorker, en particulier de la ressource de sauvegarde ou d’action de clonage, provoque parfois des erreurs de délai d’expiration d’inactivité. Essayez de supprimer la ressource de l’action de sauvegarde ou de clonage en échec et de la recréer. Vous pouvez également essayer de restaurer le fichier de ressource NetWorker à partir d’un moment antérieur au début des erreurs. Cela nécessite généralement l’engagement du support NetWorker pour effectuer NetWorker Server Disaster Recovery (NSRDR)
- La corruption des index de fichiers client NetWorker ou de la base de données des médias est connue pour entraîner des erreurs de délai d’expiration d’inactivité. Exécutez
nsrck -L6pour tenter de réparer des index ou d’exécuternsrck -L7pour restaurer les index. Pour la base de données des supports, la corruption peut être corrigée en récupérant une base de données de supports plus ancienne. Cela nécessite généralement l’engagement du support NetWorker pour effectuer NetWorker Server Disaster Recovery (NSRDR).
- Redémarrez les processus NetWorker pour effacer les caches qui peuvent être obsolètes.
nsr_shutdown systemctl start networker OR /etc/init.d/networker start
net stop nsrexecd /y For NetWorker servers: net start nsrd For NetWorker Management Console Servers: net start nsrexecd net start gstd For NetWorker client systems: net start nsrexecd
- Redémarrez le serveur et le client afin d’effacer la mémoire de tout fragment de code mort et de réinitialiser toutes les applications et le système d’exploitation.
Additional Information
| Pour obtenir des références supplémentaires sur la configuration et l’analyse des performances de NetWorker, reportez-vous à : NetWorker général : Réglage du serveur NetWorker pour obtenir des performances optimales KB-205851 Configuration des sauvegardes NetWorker multirésidentes KB-204258 Exécution d’un test BIGASM KB-205896 Parallélisme et sessions cibles KB-202942 DNS réseau : Dépannage des problèmes de résolution DNS et de noms KB-125514 Comment configurer les zones de recherche DNS directes et inversées KB-198676 Conditions et outils du support DNS - Diagnostic KB-197647 DNS - Paramètres de connexion réseau KB-198751 Ports et pare-feu de gestion de réseau : Calcul et configuration des plages de ports NetWorker KB-173639 À l’aide de la commande NetWorker « nsrrpcinfo » KB-199703 Paramètres des ports du pare-feu NetWorker KB-203593 |