Data Protection Advisor (DPA): A solicitação de coleta de dados continua excedendo o tempo de espera após o aumento do valor do tempo de espera do comando
Summary: Data Protection Advisor (DPA): A solicitação de coleta de dados continua excedendo o tempo de espera, embora os valores já tenham sido aumentados
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
As solicitações de coleta de dados continuam falhando com erros de tempo de espera excedido depois de aumentar o valor do tempo de espera do comando para a solicitação
Cause
O valor do tempo de espera do comando, ajustável na GUI, controla por quanto tempo a solicitação aguardará para que cada comando individual emitido pela solicitação seja concluído antes de acionar um erro de tempo de espera excedido. Há uma configuração Request Timeout adicional que controla por quanto tempo a solicitação aguardará para que todos os comandos executados pela solicitação sejam concluídos, e é necessário aumentar esse valor também. Por padrão, o valor de Request Timeout é uma hora e não pode ser ajustado na GUI.
Resolution
É possível aumentar o valor de Request Timeout atualizando o dpaagent_config.xml, que tem a seguinte localização padrão:
Linux: <Install Directory>/agent/etc/dpaagent_config.xml
Windows: <Install Directory>\agent\etc\dpaagent_config.xml
Antes de editar o arquivo dpaagent_config.xml, faça uma cópia dele caso seja necessário reverter.
Abaixo, é apresentado um exemplo de arquivo dpaagent_config.xml:
<AGENTCONFIG>
<VERSION>600</VERSION>
<AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
<SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
<LOGLEVEL>Info</LOGLEVEL>
</AGENTCONFIG>
Deve-se adicionar a seguinte tag ao arquivo dpaagent_config.xml para aumentar o valor de Request Timeout:
<REQUESTTIMEOUT>Value</REQUESTTIMEOUT>
Observe que o valor do tempo de espera é definido em segundos. O valor de Request Timeout precisará ser definido de tal forma que permita que a solicitação seja concluída com sucesso. Abaixo está um exemplo de um arquivo dpaagent_config.xml com o valor de Request Timeout definido como 24 horas:
<AGENTCONFIG>
<VERSION>600</VERSION>
<AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
<SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
<LOGLEVEL>Info</LOGLEVEL>
<REQUESTTIMEOUT>86400</REQUESTTIMEOUT>
</AGENTCONFIG>
Assim que o dpaagent_config.xml tiver sido atualizado, reinicie os serviços do DPA Agent para que o novo valor de Request Timeout seja habilitado.
Entre em contato com o suporte técnico da Dell EMC para obter mais detalhes ou informações.
Linux: <Install Directory>/agent/etc/dpaagent_config.xml
Windows: <Install Directory>\agent\etc\dpaagent_config.xml
Antes de editar o arquivo dpaagent_config.xml, faça uma cópia dele caso seja necessário reverter.
Abaixo, é apresentado um exemplo de arquivo dpaagent_config.xml:
<AGENTCONFIG>
<VERSION>600</VERSION>
<AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
<SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
<LOGLEVEL>Info</LOGLEVEL>
</AGENTCONFIG>
Deve-se adicionar a seguinte tag ao arquivo dpaagent_config.xml para aumentar o valor de Request Timeout:
<REQUESTTIMEOUT>Value</REQUESTTIMEOUT>
Observe que o valor do tempo de espera é definido em segundos. O valor de Request Timeout precisará ser definido de tal forma que permita que a solicitação seja concluída com sucesso. Abaixo está um exemplo de um arquivo dpaagent_config.xml com o valor de Request Timeout definido como 24 horas:
<AGENTCONFIG>
<VERSION>600</VERSION>
<AGENTVERSION>18.2.0.1579597783</AGENTVERSION>
<SERVERNAME>DPA-APP-EXAMPLE-SERVER</SERVERNAME>
<SERVERPORT>9002</SERVERPORT>
<SERVERSSL>true</SERVERSSL>
<LOGFILE>/opt/emc/dpa/agent/logs/dpaagent.log</LOGFILE>
<LOGLEVEL>Info</LOGLEVEL>
<REQUESTTIMEOUT>86400</REQUESTTIMEOUT>
</AGENTCONFIG>
Assim que o dpaagent_config.xml tiver sido atualizado, reinicie os serviços do DPA Agent para que o novo valor de Request Timeout seja habilitado.
Entre em contato com o suporte técnico da Dell EMC para obter mais detalhes ou informações.
Affected Products
Data Protection AdvisorProducts
Data Protection AdvisorArticle Properties
Article Number: 000069191
Article Type: Solution
Last Modified: 23 Sep 2024
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.