Endast RecoverPoint Classic: Anslutningsproblem mellan olika RecoverPoint-systemobjekt
Summary: Problem med låsboxar gör att objekt visas som okända.
Symptoms
Anslutningsproblem mellan olika objekt i RecoverPoint Classic-systemet .
Felen är relaterade till specifika RecoverPoint Appliance-enheter (RPA:er).
Systemvarningar och CLI get_system_status Visa olika anslutningsrelaterade problem.
Ett eller flera av följande fel kan inträffa:
RPA:
WARNING: States of all RPAs are unknown WARNING: LAN connection between all RPAs is unknown WARNING: RPA 2 in Site2: LAN network interface status is unknown
Volymer:
WARNING: States of all devices are unknown WARNING: User volume [VM1_CG, prod, VM2_0_0_scsi] is unknown to RPA x WARNING: Journal volume [VM2_CG, prod, IOFilter_JVOL_00005] is unknown to RPA x
Splitters:
WARNING: States of all splitters are unknown ERROR: RP_esxi_cluster-xx.xx.xx.xx1's connection status with RPA x is unknown ERROR: RP_esxi_cluster-xx.xx.xx.xx0's connection status with RPA x is unknown ERROR: RP_esxi_cluster-xx.xx.xx.xx2's connection status with RPA x is unknown ERROR: RP_esxi_cluster-xx.xx.xx.xx3's connection status with RPA x is unknown
WAN-problem:
Items: WARNING: No remote communication between clusters in the system Items: WARNING: Data link status is unknown for RPA 1 between clusters Site2 and Site1, WARNING: Data link status is unknown for RPA 2 between clusters Site2 and Site1
Exempel på fel i kontrollloggar (uppackade*/files/home/kos/control/result.log):
2020/05/08 19:23:03.235 - #2 - 21038/20782 - lockboxSet: fips-security: lockboxSet: inserting to lockbox: name = SiteUID_List value.size() = 18 2020/05/08 19:23:03.236 - #1 - 21038/20782 - Lockbox: The Lockbox contains no entries. 2020/05/08 19:23:03.236 - #2 - 20916/20782 - WatchDogLEPInterface: service manager expects watchdog keep-alive notification messages! 2020/05/08 19:23:03.236 - #1 - 21038/20782 - Lockbox: insert: Can't open lockbox: -35 2020/05/08 19:23:03.236 - #1 - 21038/20782 - ControlCryptoUtils: fips-security: lockboxSet: error updating value in lockbox: -35 2020/05/08 19:23:03.236 - #2 - 21038/20782 - aux::updateLockboxWithKvolTriplet: fips-security: error writing updated site list into lockbox. 2020/05/08 19:23:03.236 - #0 - 20916/20782 - LEP2: errno=0 WatchDog 0 time is low (lease =-39.6798)! RPA might be rebooted. 2020/05/08 19:23:03.237 - #2 - 21034/20782 - BC::handleUpdateLockboxWithKvolTriplet: fips-security: auxAsyncWorker returned error. rc=MRC_LOCKBOX_ACCESS_ERROR 2020/05/11 16:54:53.366 - #1 - 1702/1644 - Lockbox: Lockbox tampering was detected, so it cannot be read. 2020/05/11 16:54:53.366 - #2 - 1702/1644 - lockboxGet: fips-security: error=-60 2020/05/11 16:54:53.366 - #0 - 1702/1644 - BSAFE_FIPS_TLSHandler: errno=2 loadLocalCert: Unable to get server certificate from lockbox 2020/05/11 16:54:53.366 - #0 - 1702/1644 - BSAFE_FIPS_TLSHandler: errno=2 init: Unable to retrieve server certificate 2020/05/11 16:54:53.366 - #0 - 1702/1644 - xTE: errno=2 1762817320: MessageHandler::open()unable to initialize a socket handler!
Cause
Lockbox-filerna på RPA:n är skadade på något sätt, så RPA:n kan inte använda certifikat för att kommunicera med andra objekt.
Den kanske inte kan kommunicera med något objekt i systemet, inklusive andra RPA:er, uppdelningar (alla volymer under dessa delare), andra platser osv.
En av de möjliga orsakerna till att den säkra databasen skadas är ett fullständigt filsystemscenario på RPA:n.
Resolution
Lösning:
Kör följande skript för att rensa problem med lockbox på var och en av de berörda RPA:erna.
RPA:erna kan startas om ibland när skriptet körs.
Logga in som boxmgmt-användare med PuTTY eller SSH och välj sedan följande: [2] Inställningar -> [8] Avancerade alternativ -> [4] Kör skript -> Klistra in skriptet nedan:
MWRjNmQ3ZGY2YzM2NWI0NWFjNTQ5NmE1MjliYzg2ZjMKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOgpGaW5kIGFuZCBmaXggbG9ja2JveCBpc3N1ZXMKQXNz aWYgSGFsClZFUlNJT049JChncmVwIHRfd2luSW5zdGFsbFNoaWVsZFZlcnNpb24gL2hvbWUva29z L2tib3gvc3JjL2luaXRpYWxpemF0aW9uL3R3ZWFrX3BhcmFtcy90d2Vhay5wYXJhbXMudmVyc2lv bnxncmVwIC1vICJbMS05XS4qWzAtOV0iKQpNQUpPUlZFUlNJT049IiR7VkVSU0lPTjowOjF9IgpN SU5PUlZFUlNJT049IiR7VkVSU0lPTjoyOjF9IgppZiBbICRNQUpPUlZFUlNJT04gLWd0IDUgXSB8 fCAoWyAkTUFKT1JWRVJTSU9OIC1lcSA1IF0gJiYgWyAkTUlOT1JWRVJTSU9OIC1nZSAzIF0pOyB0 aGVuCglpZiBbWyBgemVncmVwIC1hICJyZXRyaWV2ZTogZmFpbGVkIHRvIHJldHJpZXZlIGl0ZW0u KnByaXZfY3VycnxMb2NrYm94IHRhbXBlcmluZ3xNUkNfTE9DS0JPWF9BQ0NFU1NfRVJST1IiIC9o b21lL2tvcy9jb250cm9sL3Jlc3VsdC5sb2cubGF0ZXN0IC9ob21lL2tvcy9jb250cm9sL3Jlc3Vs dC5sb2cucHJldmlvdXMuZ3p8d2MgLWxgIC1ndCAwIF1dOyB0aGVuCgkJZWNobyAiTG9ja2JveCBp c3N1ZXMgd2VyZSBmb3VuZCwgYnV0IHNpbmNlIHRoaXMgaXMgNS4zLCBQbGVhc2UgY29udGFjdCBh IFJlY292ZXJQb2ludCBTdXBwb3J0IFNNRS4iCgkJZXhpdCAwCgllbHNlCgkJZWNobyAiTm8gaXNz dWVzIGZvdW5kIgoJCWV4aXQgMAoJZmkKZWxzZQoJaWYgW1sgYHplZ3JlcCAtYSAiTG9ja2JveCB0 YW1wZXJpbmd8TVJDX0xPQ0tCT1hfQUNDRVNTX0VSUk9SIiAvaG9tZS9rb3MvY29udHJvbC9yZXN1 bHQubG9nLmxhdGVzdCAvaG9tZS9rb3MvY29udHJvbC9yZXN1bHQubG9nLnByZXZpb3VzLmd6fHdj IC1sYCAtZ3QgMCBdXTsgdGhlbgoJCWVjaG8gIkRldGVjdGVkIGxvY2tib3ggaXNzdWUuIENsZWFy aW5nIGl0IGFuZCByZXN0YXJ0aW5nIGNvbnRyb2wiCgkJcm0gLWYgL2hvbWUva29zL2xvY2tib3gv KgoJCXBraWxsIC05IGNvbnRyb2xfcHJvY2VzcwoJZWxzZQoJCWVjaG8gIk5vIGlzc3VlcyBmb3Vu ZCIKCWZpCmZpCg== #
Tryck på Retur, ange ditt namn för att tillämpa skriptet.
Resolution:
Dell Technologies tekniker undersöker problemet. En permanent lösning håller på att tas fram. Kontakta Dell Technologies kundsupportcenter eller din servicerepresentant för hjälp och hänvisa till detta lösnings-ID.
Additional Information
Viktig information:
Denna KB är endast för RecoverPoint Classic och RecoverPoint för VM version 5.2 och äldre.
FÖRSÖK INTE att köra lösningen på RecoverPoint för VM 5.3 och senare!
För RecoverPoint för VM 5.3 och senare använder du RecoverPoint för virtuella datorer: Ingen kommunikation mellan fjärrklustren på grund av att lockbox är skadad (inloggning krävs)
För RecoverPoint Classic:
Det signerade skriptet nedan kan aktivera felsökning av lockbox som kan hjälpa tekniker att förstå orsakerna till problem med lockbox i framtiden.
Om en användare har sett detta inträffa utan orsak kan vi aktivera felsökningsloggning och samla in loggar efter att det har inträffat igen.
Aktivera felsökningsloggning, logga in som boxmgmt/admin på varje RPA och kör följande skript:
OWFkNmQ5YWEzMWRjZDk0ZWIxZTRiMzQ4ZTFkZTYyNTQKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOjEwMTAzCkxvY2tib3ggZGVidWcgdHJhY2Ugc2V0CkVF CiMhL2Jpbi9iYXNoCmVjaG8gIlN0YXJ0IGFkZGluZyB0cmFjZSBDU1RfVFJBQ0UsQ0xCX1RSQUNF IGluIGZpbGUgL2V0Yy9yYy5sb2NhbCIKc2VkIC1pICcvbGRjb25maWcvaSBcZXhwb3J0IENTVF9U UkFDRT0iL3Vzci9DU1RfVFJBQ0UuTE9HIicgL2V0Yy9yYy5sb2NhbApzZWQgLWkgJy9sZGNvbmZp Zy9pIFxleHBvcnQgQ0xCX1RSQUNFPSIvdXNyL0NMQl9UUkFDRS5MT0ciJyAvZXRjL3JjLmxvY2Fs CkNTVF9UUkFDRV9DT1VOVD1gZ3JlcCAnZXhwb3J0IENTVF9UUkFDRT0iL3Vzci9DU1RfVFJBQ0Uu TE9HIicgL2V0Yy9yYy5sb2NhbCB8IHdjIC1sYApDTEJfVFJBQ0VfQ09VTlQ9YGdyZXAgJ2V4cG9y dCBDTEJfVFJBQ0U9Ii91c3IvQ0xCX1RSQUNFLkxPRyInIC9ldGMvcmMubG9jYWwgfCB3YyAtbGAK aWYgW1sgKCAiJENTVF9UUkFDRV9DT1VOVCIgLWd0IDAgKSAmJiAoICIkQ0xCX1RSQUNFX0NPVU5U IiAtZ3QgMCApIF1dCnRoZW4KICAgICBlY2hvICJBZGRlZCBib3RoIENTVF9UUkFDRSxDTEJfVFJB Q0Ugc3VjZXNzZnVsbHkiCiAgICAgZWxzZQogICAgICAgICAgZWNobyAiQ291bGQgbm90IGFkZCBD U1RfVFJBQ0UsQ0xCX1RSQUNFIHN1Y2Vzc2Z1bGx5IgogICAgICAgICAgZmkK #
Starta sedan om RPA:n och vänta tills den upprepas.