Celerra/VNX: AV 서버가 응답하지 않아 최종 사용자가 CIFS 공유에 액세스할 수 없는 경우
Summary: AV 서버가 응답하지 않아 최종 사용자가 공유에 액세스할 수 없었습니다. SPE(Symantec Protection Engine)가 AV 서버에서 제거됨에 따라 어레이에서 많은 CIFS 차단 스레드가 발생했습니다.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
SPE(Symantec Protection Engine) AV 소프트웨어가 AV 서버에서 제거되어 AV 서버가 VNX 어레이의 공유를 검색하지 않습니다.
고객이 CIFS 공유에 액세스할 수 없었습니다.
많은 바이러스 백신이 최종 사용자의 공유 액세스를 취소하는 SERVER_LOG에서 메시지를 차단했습니다.
2020-04-17 14:42:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 407 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 14:57:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 1307 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:12:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 2207 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:27:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 3107 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:42:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 4008 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:57:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 4908 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 16:12:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 5808 seconds: 서버 작업에 영향을 미칠 수 있습니다.
AV 서버에 문제가
있음을 보여 주는 SERVER_LOG 메시지2020-04-17 14:14:09: 벤처캐피탈: 3: 33: CAVA 서버 X.X.X.X 오류: AV_NOT_FOUND.
VNX 상자에서 SERVER_XXXX 명령을 실행할 수 없습니다.
[nasadmin@ ~] $ server_date server_2
server_2 :
오류 5 : server_2 : Input/Output errorTimed out
[nasadmin@ ~]$ server_viruschk server_2
server_2 :
Error 4020: server_2 : 입/출력 오류
시간 초과
또한 server_setup 명령을 실행하여 Data Mover에서 바이러스 검사 서비스를 중지할 수 없으므로 CIFS 서비스를 재개하기 위해 SMB 차단 스레드를 지울 수 있습니다.
[nasadmin@ ~] $ server_setup server_2 -P viruschk -o stop
server_2 :
오류 4020 : server_2 : 입/출력 오류
시간 초과
고객이 CIFS 공유에 액세스할 수 없었습니다.
많은 바이러스 백신이 최종 사용자의 공유 액세스를 취소하는 SERVER_LOG에서 메시지를 차단했습니다.
2020-04-17 14:42:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 407 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 14:57:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 1307 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:12:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 2207 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:27:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 3107 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:42:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 4008 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 15:57:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 4908 seconds: 서버 작업에 영향을 미칠 수 있습니다.
2020-04-17 16:12:01: 커널: 3: 3: ThreadsServicesSupervisor: Service:ANTIVIRUS Pool:AV_Others BLOCKED for 5808 seconds: 서버 작업에 영향을 미칠 수 있습니다.
AV 서버에 문제가
있음을 보여 주는 SERVER_LOG 메시지2020-04-17 14:14:09: 벤처캐피탈: 3: 33: CAVA 서버 X.X.X.X 오류: AV_NOT_FOUND.
VNX 상자에서 SERVER_XXXX 명령을 실행할 수 없습니다.
[nasadmin@ ~] $ server_date server_2
server_2 :
오류 5 : server_2 : Input/Output errorTimed out
[nasadmin@ ~]$ server_viruschk server_2
server_2 :
Error 4020: server_2 : 입/출력 오류
시간 초과
또한 server_setup 명령을 실행하여 Data Mover에서 바이러스 검사 서비스를 중지할 수 없으므로 CIFS 서비스를 재개하기 위해 SMB 차단 스레드를 지울 수 있습니다.
[nasadmin@ ~] $ server_setup server_2 -P viruschk -o stop
server_2 :
오류 4020 : server_2 : 입/출력 오류
시간 초과
Cause
원인:- SPE(Symantec Protection Engine)가 NAS 공유를 스캔하는 두 AV 서버에서 제거되었습니다. AV 서버가 ping 명령에 응답하고 있었지만 실제 스캔은 이러한 시스템에서 수행되지 않았습니다. 이로 인해 CIFS가 스레드를 차단하여 공유 액세스를 취소했습니다.
종료 정책이 "shutdown=Viruschecking"으로 설정되었습니다. 세 번째 AV 서버가 활성 상태였지만 많은 검색 요청으로 과부하되어 CIFS가 스레드를 차단했습니다.
종료 정책이 "shutdown=Viruschecking"으로 설정되었습니다. 세 번째 AV 서버가 활성 상태였지만 많은 검색 요청으로 과부하되어 CIFS가 스레드를 차단했습니다.
Resolution
서비스를 다시
복원하는 방법에는 두 가지가 있습니다.1. Antivirus 관리자에게 문의하여 공유를 검색하지 않는 AV 서버를 확인하고 AV 서버를 재부팅하거나 AV 서버 시스템에서 CAVA 서비스를 종료하도록 요청해야 합니다. 이렇게 하면 리소스가 확보되어 사용자가 보호되지 않은 공유에 액세스할 수 있습니다.
2. 다음 해결 방법은 VNX 지원 팀에 문의하여 Data Mover의 강제 패닉을 수행하는 것입니다. 이렇게 하면 전체 Data Mover가 모든 CIFS 및 NFS 클라이언트의 액세스 권한을 취소하게 됩니다.
복원하는 방법에는 두 가지가 있습니다.1. Antivirus 관리자에게 문의하여 공유를 검색하지 않는 AV 서버를 확인하고 AV 서버를 재부팅하거나 AV 서버 시스템에서 CAVA 서비스를 종료하도록 요청해야 합니다. 이렇게 하면 리소스가 확보되어 사용자가 보호되지 않은 공유에 액세스할 수 있습니다.
2. 다음 해결 방법은 VNX 지원 팀에 문의하여 Data Mover의 강제 패닉을 수행하는 것입니다. 이렇게 하면 전체 Data Mover가 모든 CIFS 및 NFS 클라이언트의 액세스 권한을 취소하게 됩니다.
Additional Information
대부분의 경우 AV 서버는 CIFS 차단 스레드로 인해 CIFS 사용자가 공유에 액세스할 수 없도록 합니다. Data Mover에서 바이러스 검사 서비스를 중지하여 대부분의 경우 서비스를 복구할 수 있습니다. 그러나 AV 소프트웨어가 제거되거나 AV 소프트웨어 서비스가 중단되어 AV 서버가 문제를 일으키는 드문 경우가 있습니다. 이러한 상황에서는 보안/안티바이러스 팀을 참여시켜 AV 서버를 확인하고 분류해야 합니다. 이렇게 하면 AV 서버를 재시작하거나 AV 서버에서 AV 에이전트를 중지하여 리소스를 해제하고 고객이 공유에 액세스할 수 있도록 하므로 서비스가 다시 복원됩니다.
Affected Products
VNX/VNXeProducts
VNX/VNXeArticle Properties
Article Number: 000072342
Article Type: Solution
Last Modified: 11 Nov 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.