Celerra/VNX: Конечные пользователи не могут получить доступ к общим ресурсам CIFS из-за того, что серверы антивирусной защиты не отвечают

Summary: Конечные пользователи не смогли получить доступ к общим ресурсам, так как серверы антивирусной защиты не отвечали. Из-за удаления SPE (Symantec Protection Engine) с серверов антивирусной защиты в массиве было заблокировано много потоков CIFS. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Программное обеспечение SPE (Symantec Protection Engine) удалялось с серверов антивирусной защиты, в результате чего серверы антивирусной защиты не сканировали общие ресурсы из массива VNX.


Клиентам не удавалось получить доступ к общим ресурсам CIFS.


Многие антивирусные программы блокируют сообщения на SERVER_LOG, отзывая доступ к общему ресурсу у конечных пользователей.


2020-04-17 14:42:01: ЯДРО: 3. 3. ThreadsServicesSupervisor: Сервис:Пул антивирусов:AV_Others ЗАБЛОКИРОВАН на 407 секунд: Это может повлиять на работу сервера.
2020-04-17 14:57:01: ЯДРО: 3. 3. ThreadsServicesSupervisor: Сервис:Пул антивирусов:AV_Others ЗАБЛОКИРОВАН на 1307 секунд: Это может повлиять на работу сервера.
2020-04-17 15:12:01: ЯДРО: 3. 3. ThreadsServicesSupervisor: Сервис:Пул антивирусов:AV_Others ЗАБЛОКИРОВАН на 2207 секунд: Это может повлиять на работу сервера.
2020-04-17 15:27:01: ЯДРО: 3. 3. ThreadsServicesSupervisor: Сервис:Пул антивирусов:AV_Others ЗАБЛОКИРОВАН на 3107 секунд: Это может повлиять на работу сервера.
2020-04-17 15:42:01: ЯДРО: 3. 3. ThreadsServicesSupervisor: Сервис:Пул антивирусов:AV_Others ЗАБЛОКИРОВАН на 4008 секунд: Это может повлиять на работу сервера.
2020-04-17 15:57:01: ЯДРО: 3. 3. ThreadsServicesSupervisor: Сервис:Пул антивирусов:AV_Others ЗАБЛОКИРОВАН на 4908 секунд: Это может повлиять на работу сервера.
2020-04-17 16:12:01: ЯДРО: 3. 3. ThreadsServicesSupervisor: Сервис:Пул антивирусов:AV_Others ЗАБЛОКИРОВАН на 5808 секунд: Это может повлиять на работу сервера.

SERVER_LOG сообщения, показывающие, что в работе антивирусного сервера возникли проблемы.

2020-04-17 14:14:09: Виртуальный канал: 3. 33: Ошибка на сервере CAVA X.X.X.X: AV_NOT_FOUND.


Не удается выполнить команды SERVER_XXXX на устройстве VNX. 

[nasadmin@ ~]$ server_date server_2
server_2 :
Ошибка 5: server_2 : Ошибка ввода/выводаТайм-аут

[nasadmin@ ~]$ server_viruschk server_2
server_2 :
Ошибка 4020: server_2 : Ошибка
ввода-вывода Время ожидания истекло

. Кроме того, не удалось выполнить команду server_setup, чтобы остановить сервис антивирусной проверки в модуле переноса данных, который мог бы очистить заблокированные потоки SMB для возобновления работы служб CIFS.

[nasadmin@ ~]$ server_setup server_2 -P viruschk -o stop
server_2 :
Ошибка 4020: server_2 : Ошибка
ввода-вывода Время ожидания истекло

Cause

Причина: SPE (Symantec Protection Engine), который сканировал общие ресурсы сетевой системы хранения данных, был удален из двух серверов антивирусной защиты. Серверы антивирусной защиты отвечали на команды ping, но на этих машинах сканирование не выполнялось. Это приводило к блокировке потоков CIFS и отзыву доступа к общему ресурсу.

Политика завершения работы была установлена на «shutdown=Viruschecking», у нас был третий работающий сервер антивирусной защиты, но он был перегружен большим количеством запросов на сканирование, в результате чего CIFS блокировал потоки.

Resolution

Существует два возможных способа восстановления служб
: 1. Необходимо обратиться к администраторам антивирусной защиты, чтобы проверить серверы антивирусной защиты, которые не сканируют никакие общие ресурсы, и попросить их перезагрузить сервер антивирусной защиты или завершить работу службы CAVA на компьютерах этого сервера антивирусной защиты. Как только они это сделают, ресурсы будут освобождены, что позволит пользователям получить доступ к общим ресурсам без защиты.

2. Следующее решение состоит в принудительном вызове паники модуля переноса данных путем привлечения поддержки VNX, что приведет к тому, что весь модуль переноса данных отзовет доступ всех клиентов CIFS и NFS.
                                       

Additional Information


В большинстве случаев серверы антивирусной защиты блокируют потоки CIFS, не позволяя пользователям CIFS получать доступ к общим ресурсам. В большинстве случаев можно восстановить службы обратно, остановив службу антивирусной проверки в модуле переноса данных. Но в редких случаях антивирусные серверы вызывают проблемы из-за удаления антивирусного программного обеспечения или зависания программных служб антивирусной защиты. В этих условиях необходимо привлечь команду безопасности/антивируса для проверки серверов антивирусной защиты и сортировки. Это позволит восстановить службы обратно, так как они перезапустят серверы антивирусной защиты или остановят работу агента антивирусной защиты на серверах антивирусной защиты, что высвободит ресурсы и позволит заказчику получить доступ к общим ресурсам.

Affected Products

VNX/VNXe

Products

VNX/VNXe
Article Properties
Article Number: 000072342
Article Type: Solution
Last Modified: 11 Nov 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.