Avamar – Zálohování Oracle RMAN selhalo s chybou "Failed to konsolide backup on Avamar server"

Summary: Avamar – Zálohování Oracle RMAN selhalo s chybou "Failed to konsolide backup on Avamar server"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Zálohování Avamar pomocí Oracle RMAN selže s chybou "Nepodařilo se konsolidovat zálohu na serveru Avamar"

Níže je uveden výpis protokolu s chybami hlášenými relací protokolu doplňku avoracle.  Zobrazí se na samém konci zálohování po úspěšném dokončení všech relací avtar
 
...
2020-03-20 15:53:56 avoracle Informace <18470>: create_new_workorder: 9158
2020-03-20 15:53:56 avoracle informace 10684<>: Nastavení verze zprávy ctl na hodnotu 3 (od 1)
2020-03-20 15:53:56 avoracle Informace 16136<>: Nastavení maximální velikosti zprávy ctl na hodnotu 268435456
2020-03-20 15:54:00 avoracle info <0000>: sbtbackup: avtar byl úspěšně spuštěn
2020-03-20 16:54:35 chyba <avoracle 43210>: Konsolidace zálohy na serveru Avamar se nezdařila
2020-03-20 16:54:46 avoracle Info <6686>: Proces 306793 (/usr/local/avamar/ora_rac/bin/avtar) pro pracovní příkaz Oracle_EMR_L0_Backup_Group-1584673881637#0 spuštěn
2020-03-20 16:55:59 avoracle info <6688>: Proces 306793 (/usr/local/avamar/ora_rac/bin/avtar) dokončen (kód 0: úspěch)
2020-03-20 16:55:59 chyba <avoracle 43351>: Vytvoření pohledového pohledu se nezdařilo. Data databáze však byla úspěšně zálohována a jsou označena jako skrytá záloha. Obnovení je k dispozici pouze prostřednictvím rozhraní příkazového řádku. Informace o obnovení skrytých záloh naleznete v dokumentaci k zásuvnému modulu.

Protokol ukazuje, že po dokončení všech relací avtar se proces zasekl na 1 hodinu, než byla nahlášena chyba "Failed to konsolide backup on Avamar server".  K této chybě došlo těsně před zahájením relace Snapview.

2020-03-20 16:54:35 chyba <avoracle 43210>: Konsolidace zálohy na serveru

Avamar se nezdařila- Protokolování ukazuje, že relace snapview byla úspěšně dokončena
2020-03-20 16:54:46 avoracle Info <6686>: Proces 306793 (/usr/local/avamar/ora_rac/bin/avtar) pro pracovní příkaz Oracle_EMR_L0_Backup_Group-1584673881637#0 spuštěn 2020-03-20 16:55:59 avoracle info <6688>: Proces 306793 (/usr/local/avamar/ora_rac/bin/avtar) dokončen (kód 0: úspěch)

- Po dokončení snapview avoracle vypíše další chybu: "Vytvoření snapview se nezdařilo. Data databáze však byla úspěšně zálohována a jsou označena jako skrytá záloha. Obnovení je k dispozici pouze prostřednictvím rozhraní příkazového řádku.

Tato záloha není ve skutečnosti skrytá, je viditelná z uživatelského rozhraní Avamar (AUI) nebo grafického uživatelského rozhraní Java a lze ji obnovit. Úloha zálohování v monitoru aktivity však ukazuje, že selhala. 


 

Cause

Došlo k velkému počtu relací avtar, které mohou způsobit, že dokončení procesu shrnutí služby avoracle bude trvat déle.  Časový limit procesu zabalení vypršel po jedné hodině.  

Resolution

Problém lze vyřešit snížením počtu relací avtar, které se vytvářejí, nebo prodloužením časového limitu procesu zabalení prostřednictvím příznaku wrapupprocesstimeoutsecs.

Ve výchozím nastavení je příznak "filesperset" v modulu Oracle (avoracle)
nastaven na "1". Tuto hodnotu lze zvýšit na hodnotu "5" nebo vyšší.
Upozorňujeme, že zvýšení hodnoty filesPerset by ovlivnilo rychlost deduplikace zálohování.


kA23a000000GJKyCAO_2_0

Pokud záloha používá skript RMAN, přidejte příznak do skriptu rman.  Níže je uveden příklad:
alokovat kanál C0 maxopenfiles = 5 typ zařízení sbt;

Volitelně můžete také přidat příznak avoracle do datové sady, abyste prodloužili časový limit zabalení. Ve výchozím nastavení je to 3600 sekund:
--[avoracle]WrapUpProcessTimeOutSecs=5400

Chcete-li přidat speciální příznaky pro změnu chování zásuvných modulů, podívejte se na 
KB 490673 – Jak dodávat specializované příznaky do záloh Avamar

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for Oracle
Article Properties
Article Number: 000078749
Article Type: Solution
Last Modified: 16 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.