Avamar - Oracle RMAN yedeklemesi "Avamar sunucusundaki yedekleme birleştirilemedi" hatasıyla başarısız oldu

Summary: Avamar - Oracle RMAN yedeklemesi "Avamar sunucusundaki yedekleme birleştirilemedi" hatasıyla başarısız oldu

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Oracle RMAN kullanan bir Avamar yedeklemesi hata vererek başarısız oluyorAvamar sunucusunda yedekleme birleştirilemedi"

Aşağıda, avoracle eklentisi günlük oturumu tarafından bildirilen hataları gösteren bir günlük özeti verilmiştir.  Bu, tüm avtar oturumları başarıyla tamamlandıktan sonra yedeklemenin en sonunda görüntülenir
 
...
2020-03-20 15:53:56 avoracle Info <18470>: create_new_workorder: 9158
2020-03-20 15:53:56 avoracle Info <10684>: ctl mesaj sürümünü 3 (1'den) olarak ayarlama
2020-03-20 15:53:56 avoracle Info <16136>: ctl maksimum ileti boyutunu 268435456 olarak ayarlama
2020-03-20 15:54:00 avoracle Info <0000>: sbtbackup: avtar started successfully
2020-03-20 16:54:35 avoracle Error <43210>: Avamar sunucusundaki yedekleme birleştirilemedi
2020-03-20 16:54:46 avoracle Info <6686>: Oracle_EMR_L0_Backup_Group-1584673881637#0 numaralı iş emri için işlem 306793 (/usr/local/avamar/ora_rac/bin/avtar) başlatıldı
2020-03-20 16:55:59 avoracle Info <6688>: İşlem 306793 (/usr/local/avamar/ora_rac/bin/avtar) finished (code 0: success)
2020-03-20 16:55:59 avoracle Error <43351>: Snapview oluşturulamadı. Ancak veritabanı verileri başarıyla yedeklenmiştir ve gizli yedek olarak işaretlenir. Geri yükleme yalnızca CLI üzerinden yapılabilir. Gizli yedekleri geri yükleme hakkında bilgi için eklenti belgelerine bakın.

Günlük, tüm avtar oturumları tamamlandıktan sonra işlemin "Avamar sunucusunda yedekleme birleştirilemedi" hatasını bildirmeden önce 1 saat boyunca takıldığını gösteriyor.  Bu hata, Snapview oturumu başlatılmadan hemen önce meydana geldi.

2020-03-20 16:54:35 avoracle Error <43210>: Avamar sunucusundaki

yedekleme birleştirilemedi- Günlüğe kaydetme, snapview oturumunun başarıyla
tamamlandığını gösteriyor2020-03-20 16:54:46 avoracle Info <6686>: Process 306793 (/usr/local/avamar/ora_rac/bin/avtar) for workorder Oracle_EMR_L0_Backup_Group-1584673881637#0 started 2020-03-20 16:55:59 avoracle Info <6688>: İşlem 306793 (/usr/local/avamar/ora_rac/bin/avtar) finished (code 0: success)

- Snapview tamamlandıktan sonra avoracle başka bir hata yazdırır: "Snapview oluşturulamadı. Ancak veritabanı verileri başarıyla yedeklenmiştir ve gizli yedek olarak işaretlenir. Geri yükleme yalnızca CLI üzerinden yapılabilir".

Bu yedekleme aslında gizli değildir, Avamar Kullanıcı Arayüzü (AUI) veya Java GUI içinden görülebilir ve geri yüklenebilir. Ancak activity monitor'daki yedekleme işi başarısız olduğunu gösteriyor. 


 

Cause

Avoracle'ın tamamlama işlemini tamamlamasının daha uzun sürmesine neden olabilecek çok sayıda avtar oturumu vardı.  Sarma işlemi bir saat sonra zaman aşımına uğradı.  

Resolution

Bu sorun, oluşturulan avtar oturumlarının sayısını azaltarak veya wrapupprocesstimeoutsecs bayrağı aracılığıyla wrapup işlemine daha uzun bir zaman aşımı vererek çözülebilir.

Varsayılan olarak Oracle eklentisi (avoracle) bayrağı "
filesperset" "1" olarak ayarlanmıştır, bu "5" veya daha yükseğe yükseltilebilir.
Filesperset değerini artırmanın yedekleme tekilleştirme oranını etkileyeceğini unutmayın.


kA23a000000GJKyCAO_2_0

Yedekleme bir RMAN komut dosyası kullanıyorsa bayrağı rman komut dosyasına ekleyin.  Aşağıda bir örnek verilmiştir:
kanal ayır c0 maxopenfiles = 5 cihaz türü sbt;

Ayrıca sarma zaman aşımını artırmak için isteğe bağlı olarak veri kümesine avoracle bayrağı ekleyebilir, varsayılan olarak 3600 saniyedir:
--[avoracle]wrapupprocesstimeoutsecs=5400

Eklenti davranışını değiştirmek üzere özel bayraklar eklemek için bkz. 
KB 490673 - Avamar yedeklemelerine özel bayraklar sağlama

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for Oracle
Article Properties
Article Number: 000078749
Article Type: Solution
Last Modified: 16 Jun 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.