Technologie Data Domain Cloud Tier se systémem ECS je odpojena, protože v systému ECS dochází k interní chybě nebo k zaplnění systému

Summary: Existuje mnoho různých důvodů, proč systém souborů Data Domain hlásí, že došlo k odpojení profilu technologie Cloud Tier, což způsobí přerušení či ukončení spuštěných procesů přesouvání dat, navrácení a čištění cloudu. Děje se tak proto, že cloudová jednotka se dostane do stavu UNAVAILABLE a jeden z procesů obdrží od systému ECS interní chybu 500 serveru. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Existuje mnoho různých důvodů, proč systém souborů Data Domain hlásí, že došlo k odpojení profilu technologie Cloud Tier, což způsobí přerušení či ukončení spuštěných procesů přesouvání dat, navrácení a čištění cloudu. Děje se tak proto, že cloudová jednotka se dostane do stavu UNAVAILABLE.

Jedním z důvodů, proč se cloudová jednotka odpojí, je to, že systém ECS zobrazí interní chybu s kódem vrácené operace HTTP:500.

Pokud k tomu dojde, obdržíme podobnou výstražnou zprávu:
Time: Sun Mar 1 00:08:44 2020 Alert Id: m0-3761 Event Id: EVT-CLOUD-00001 Event Message: Unable to access provider for cloud unit XXXX-XXXX-XXX. Object: CloudUnit=XXXX-XXXX-XXXX Additional Information: Cause=We encountered an internal error. Please try again. 
Kvůli této chybě může být probíhající proces čištění technologie Cloud Tier ukončen:
Cloud Cleaning Status --------------------- Cloud tier cleaning started on cloud unit "XXXX-XXXX-XXXX" at 2020/02/12 15:56:11 and was aborted at 2020/02/14 03:12:56. Cloud tier cleaning was aborted because cloud is unavailable Background deletion completed. 

V souboru protokolu ddfs.info se mohou zobrazit podobné chybové zprávy z důvodu odpojení jednotky Cloud Tier: 
02/02 10:35:58.067 (tid 0xbf47f70): ERROR: CAL cl_request_convert_httpcode_to_err:1539 - HTTP operation returned code:500, request error:We encountered an internal error. Please try again. [5009] .... 02/02 10:35:58.067 (tid 0x7f6ab4714fd0): INFO: CAL cal_cloudunit_set_unavail:1339 - Marking cloud unit:XXXX-XXXX-XXXX-XXXX as UNAVAILABLE .... 02/02 10:35:58.067 (tid 0x7f77e22e2370): Fmig: fmig2_process_cal_event: XXXX-XXXX-XXXX-XXXX (path=cloud1/cp1): receiving DDR_EVENT_CAL_UNIT_UNAVAIL event .... 02/02 10:35:59.229 (tid 0x7f6ab4714fd0): INFO: Event posted: m0-1361 (21000551:553649489): EVT-CLOUD-00001: Unable to access provider for cloud unit XXXX-XXXX-XXXX-XXXX.EVT-OBJ::CloudUnit=XXXX-XXXX-XXXX-XXXX EVT-INFO::Cause=We encountered an internal error. Please try again. ... 02/02 10:35:58.067 (tid 0x7f6ab4714fd0): INFO: CAL cal_cloudunit_set_unavail:1339 - Marking cloud unit:XXXX-XXXX-XXXX as UNAVAILABLE 

Interní chyba serveru 500 je obecný stavový kód HTTP, který znamená, že na serveru došlo k chybě.
Chyby 5xx jsou stavové kódy vrácené serverem, když server narazí na neočekávaný stav, který mu zabránil splnit požadavek klienta, v tomto případě systém Data Domain.
Tato chybová odpověď je obecná chybová odpověď, která vyžaduje další zkoumání, aby byla zjištěna její příčina. 

Pomocí nejnovější automatické podpory můžete sledovat stav cloudových požadavků, a to prostřednictvím kontroly statistik chyb cloudu pro datový zásobník cloudové jednotky:

Cloud error stats for bucket:<name of the bucket>-d0 Number of Retries : 9180 ... Number of http 400 errors : 0 Number of http 403 errors : 0 ... Number of http 416 errors : 0 Number of http 429 errors : 0 Number of http 500 errors : 10195 ----------->lots of 500 errors Number of http 503 errors : 0 ...

Cause

1. důvod:
Jedním z hlavních důvodů, proč systém DD obdrží toto chybové hlášení, je to, že systém ECS se zcela zaplní, a dojde tak k odmítnutí příchozích požadavků z jednotky Data Domain. K vyřešení tohoto problému uvolněte místo v systému ECS, aby se obnovilo připojení DD ke cloudu ECS. 

2. důvod: 
Systém ECS je zaneprázdněný, takže nemůže splnit všechny příchozí požadavky.

Tato chyba má i jiné příčiny. 

Resolution

Řešení:
Pokud se cloud ECS zaplní, systém Data Domain bude nadále dostávat chybové zprávy o odpojení, dokud se pro profil technologie Cloud Tier neuvolní místo, takže systém Data Domain bude moci obnovit komunikaci. 

Řešení: 
Pokud je cloud ECS zaneprázdněný, doporučujeme nespouštět současně procesy „garbage collection“, přenos dat nebo navrácení. Pokud se zobrazí interní chyby 500 serveru, pokuste se procesy naplánovat tak, aby běžely v různou dobu, čímž technologie ECS Cloud Tier získá prostor pro zpracování všech příchozích požadavků. Požádejte podporu ECS, aby vám pomohla s dalším určením jakýchkoli problémů. 


Additional Information

Pokud problém přetrvává, otevřete nový případ podpory ECS i Data Domain, abyste jej mohli společně vyřešit. 
Při otevírání nového případu podpory Data Domain shromážděte a odešlete nový balíček podpory. 

Affected Products

Data Domain

Products

Data Domain, Data Domain Deduplication Storage Systems
Article Properties
Article Number: 000081881
Article Type: Solution
Last Modified: 11 Dec 2023
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.