Data Domain-Cloud-Tier mit ECS wird getrennt, da ECS auf einen internen Fehler stößt oder ausgelastet ist
Summary: Es gibt viele verschiedene Gründe, warum das Data Domain-Dateisystem meldet, dass das Cloud-Tier-Profil getrennt wurde, was dazu führt, dass die laufenden Datenverschiebungen, Abruf- oder Cloud-Bereinigungsvorgänge unterbrochen oder beendet werden, da die Cloud-Einheit in den Status NICHT VERFÜGBAR versetzt wird. Einer davon ist der Empfang interner 500-Serverfehler von ECS. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Es gibt viele verschiedene Gründe, warum das Data Domain-Dateisystem meldet, dass das Cloud-Tier-Profil getrennt wurde, was dazu führt, dass die laufenden Datenverschiebungen, Abruf- oder Cloud-Bereinigungsvorgänge unterbrochen oder beendet werden, da die Cloud-Einheit in den Status NICHT VERFÜGBAR versetzt wird.
Einer der Gründe, warum die Cloud-Tier-Einheit getrennt wird, ist der Empfang eines internen Fehlers von ECS mit dem HTTP-Code 500.
In diesem Fall wird eine ähnliche Warnmeldung angezeigt:
Time: Sun Mar 1 00:08:44 2020 Alert Id: m0-3761 Event Id: EVT-CLOUD-00001 Event Message: Unable to access provider for cloud unit XXXX-XXXX-XXX. Object: CloudUnit=XXXX-XXXX-XXXX Additional Information: Cause=We encountered an internal error. Please try again.
Aufgrund dieses Fehlers wird der laufende Cloud-Tier-Bereinigungsvorgang möglicherweise beendet:
Cloud Cleaning Status --------------------- Cloud tier cleaning started on cloud unit "XXXX-XXXX-XXXX" at 2020/02/12 15:56:11 and was aborted at 2020/02/14 03:12:56. Cloud tier cleaning was aborted because cloud is unavailable Background deletion completed.
In der ddfs.info-Protokolldatei werden möglicherweise ähnliche Fehlermeldungen mit dem Grund für die Trennung der Cloud-Tier-Einheit angezeigt:
02/02 10:35:58.067 (tid 0xbf47f70): ERROR: CAL cl_request_convert_httpcode_to_err:1539 - HTTP operation returned code:500, request error:We encountered an internal error. Please try again. [5009].... 02/02 10:35:58.067 (tid 0x7f6ab4714fd0): INFO: CAL cal_cloudunit_set_unavail:1339 - Marking cloud unit:XXXX-XXXX-XXXX-XXXX as UNAVAILABLE .... 02/02 10:35:58.067 (tid 0x7f77e22e2370): Fmig: fmig2_process_cal_event: XXXX-XXXX-XXXX-XXXX (path=cloud1/cp1): receiving DDR_EVENT_CAL_UNIT_UNAVAIL event .... 02/02 10:35:59.229 (tid 0x7f6ab4714fd0): INFO: Event posted: m0-1361 (21000551:553649489): EVT-CLOUD-00001: Unable to access provider for cloud unit XXXX-XXXX-XXXX-XXXX.EVT-OBJ::CloudUnit=XXXX-XXXX-XXXX-XXXX EVT-INFO::Cause=We encountered an internal error. Please try again. ... 02/02 10:35:58.067 (tid 0x7f6ab4714fd0): INFO: CAL cal_cloudunit_set_unavail:1339 - Marking cloud unit:XXXX-XXXX-XXXX as UNAVAILABLE
Der interne 500-Serverfehler ist ein allgemeiner HTTP-Statuscode, der darauf hindeutet, dass etwas mit dem Server nicht stimmt.
Die 5xx-Fehler sind die Statuscodes, die vom Server zurückgegeben werden, wenn der Server auf eine unerwartete Bedingung stößt, die verhindert, dass die Anfragen von einem Client, in diesem Fall des Data Domain-Systems, erfüllt werden.
Diese Fehlerantwort ist eine generische Fehlerantwort, die weitere Untersuchungen erfordert, um den Grund dafür zu ermitteln.
Im aktuellen AutoSupport-Bericht können Sie den Status der Cloud-Anfragen nachverfolgen, indem Sie die Cloud-Fehlerstatistiken für Ihr Daten-Bucket der Cloud-Einheit überprüfen:
Cloud error stats for bucket:<name of the bucket>-d0 Number of Retries : 9180... Number of http 400 errors : 0 Number of http 403 errors : 0 ... Number of http 416 errors : 0 Number of http 429 errors : 0 Number of http 500 errors : 10195 ----------->lots of 500 errors Number of http 503 errors : 0 ...
Cause
Grund 1:
Einer der Hauptgründe, warum DD diese Fehlermeldung erhält, ist, dass ECS komplett voll ist, was dazu führt, dass eingehende Anfragen von der Data Domain-Einheit abgelehnt werden. Um dieses Problem zu beheben, geben Sie Speicherplatz auf ECS frei, um die DD-Verbindung mit der ECS-Cloud wiederherzustellen.
Grund 2:
ECS ist ausgelastet, sodass es nicht in der Lage ist, alle eingehenden Anfragen zu erfüllen.
Es gibt noch weitere Gründe, die diesen Fehler auslösen können.
Einer der Hauptgründe, warum DD diese Fehlermeldung erhält, ist, dass ECS komplett voll ist, was dazu führt, dass eingehende Anfragen von der Data Domain-Einheit abgelehnt werden. Um dieses Problem zu beheben, geben Sie Speicherplatz auf ECS frei, um die DD-Verbindung mit der ECS-Cloud wiederherzustellen.
Grund 2:
ECS ist ausgelastet, sodass es nicht in der Lage ist, alle eingehenden Anfragen zu erfüllen.
Es gibt noch weitere Gründe, die diesen Fehler auslösen können.
Resolution
Lösung:
Wenn die ECS-Cloud voll ist, empfängt die Data Domain kontinuierlich Verbindungsfehlermeldungen, bis das Cloud-Tier-Profil über mehr freien Speicherplatz verfügt, damit das Data Domain-System die Kommunikation wiederherstellen kann.
Lösung:
Wenn die ECS-Cloud ausgelastet ist, wird empfohlen, automatische Speicherbereinigungen, Datenverschiebungs- oder Abrufvorgänge nicht gleichzeitig auszuführen, wenn Sie interne 500-Serverfehler erhalten. Versuchen Sie, die Ausführung zu unterschiedlichen Zeiten zu planen, damit das ECS-Cloud-Tier genügend Speicherplatz für die Verarbeitung aller eingehenden Anfragen hat. Wenden Sie sich an den ECS-Support, um die Probleme weiter einzugrenzen.
Wenn die ECS-Cloud voll ist, empfängt die Data Domain kontinuierlich Verbindungsfehlermeldungen, bis das Cloud-Tier-Profil über mehr freien Speicherplatz verfügt, damit das Data Domain-System die Kommunikation wiederherstellen kann.
Lösung:
Wenn die ECS-Cloud ausgelastet ist, wird empfohlen, automatische Speicherbereinigungen, Datenverschiebungs- oder Abrufvorgänge nicht gleichzeitig auszuführen, wenn Sie interne 500-Serverfehler erhalten. Versuchen Sie, die Ausführung zu unterschiedlichen Zeiten zu planen, damit das ECS-Cloud-Tier genügend Speicherplatz für die Verarbeitung aller eingehenden Anfragen hat. Wenden Sie sich an den ECS-Support, um die Probleme weiter einzugrenzen.
Additional Information
Wenn das Problem nicht behoben wird, stellen Sie eine neue Supportanfrage sowohl an den ECS- als auch den Data Domain-Support, um das Problem gemeinsam zu lösen.
Wenn Sie eine neue Data Domain-Supportanfrage eröffnen, stellen Sie ein neues Support-Bundle zusammen und laden Sie es hoch.
Wenn Sie eine neue Data Domain-Supportanfrage eröffnen, stellen Sie ein neues Support-Bundle zusammen und laden Sie es hoch.
Affected Products
Data DomainProducts
Data Domain, Data Domain Deduplication Storage SystemsArticle Properties
Article Number: 000081881
Article Type: Solution
Last Modified: 11 Dec 2023
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.