IDPA 2.0: Unable to sync Data Domain password in the ACM GUI

Summary: This issue is seen on IDPA 2.0. The password for 'sysadmin' user on Data Domain was changed. However, on ACM, when we click the "password out of sync" message for Protection Storage, it does not redirect to the update password pop up. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



The following error is seen on the IDPA ACM GUI for the Protection Storage:    

"Protection Storage password is out of sync. Please update the latest password"

Log in to the ACM VM and traverse to "/usr/local/dataprotection/var/configmgr/server_data/logs" directory and review the server.log file:    
cd  /usr/local/dataprotection/var/configmgr/server_data/logs
grep -i "DD password is out of sync" server.log

On the server.log, the following error is seen:    
2018-05-01 13:08:37,582 INFO  [http-nio-8543-exec-3]-ddadapter.DataDomainPlugin: Checking if DdPasswordOutOfSync
2018-05-01 13:08:37,583 INFO  [http-nio-8543-exec-3]-ddadapter.DataDomainPlugin: ddPasswordOutOfSync=true
2018-05-01 13:08:37,584 INFO  [http-nio-8543-exec-3]-ddadapter.DataDomainPlugin: DD password is out of sync, throwing exception
2018-05-01 13:08:37,584 ERROR [http-nio-8543-exec-3]-restadapter.ConfigInfoService: Exception occurred while serving request for retrieving storage details for Data Domain: com.emc.vcedpa.common.exception.ApplianceException: Data Domain password is out of sync. Please update the password.

 
On the ACM UI, after clicking on the "Protection Storage Password is out of sync. Please update the password" popup, it does not redirect us to the "Update Password" dialog box. 

Cause

This issue is seen on IDPA 2.0. The password for 'sysadmin' user on the Data Domain was changed. However, on ACM, when we click the "password out of sync" message for Protection Storage, it does not redirect to the update password pop up.

This is a bug on the ACM UI and is addressed using a tomcat hotfix.

Resolution

Contact Dell EMC IDPA support to get the hotfix applied to address this issue permanently.

Affected Products

Integrated Data Protection Appliance Family

Products

PowerProtect Data Protection Software, Integrated Data Protection Appliance Family, Integrated Data Protection Appliance Software
Article Properties
Article Number: 000082031
Article Type: Solution
Last Modified: 06 May 2024
Version:  3
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