ECS: S3 Error Codes with Possible Causes

Summary: Use this article for reference to S3 error codes when attempting to read, write, or delete S3 objects from the ECS buckets and their possible causes.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

HTTP status code indicates an error or exception that may occur when an S3 query is run to read, write, or delete data to an ECS bucket.

Cause

User or System Failure

Resolution

 

HTTP Status code Generic Error Error Type  Možné příčiny Článek
400 InvalidBucketName, InvalidRequest, InvalidArgument, InvalidPart, InvalidNamespace User Failure Bucket or namespace specified in the s3 query are invalid, invalid Metadata search argument. Refer to Notes for more information about troubleshooting S3 issues.
403 AccessDenied, Unauthorized, SignatureDoesNotMatch, Forbidden. User Failure Wrong S3 username or Secret key, improper object addressing style, permission denied due to bucket ACL or policy. Refer to Notes for more information about troubleshooting S3 issues.
404 ObjectNotFound, NoSuchBucket, NoSuchBucketPolicy, NoACLFound User Failure The object requested was deleted. Bucket was removed or there is a misspelling in the bucket name. Bucket ACLs cannot be found, wrong or no BaseUrl is set to the ECS VDC. ECS: Chybějící adresa BaseURL způsobuje chyby 400/404 během operací čtení a zápisu
405 MetadataSearchNotEnabled, MetadataOperationNotSupported, MethodNotAllowed User Failure Metadata search is not enabled on the bucket, invalid Operators used in metadata search query (allowed operators are: ==, >, <, <=, >= ) Refer to Notes for more information about troubleshooting S3 issues.
409 BucketAlreadyExists, BucketNotEmpty, ObjectUnderRetention, AccessModeNotSupported User Failure A bucket was already created, the bucket you tried to delete is not empty, the object is under retention and it cannot be deleted or modified. Refer to Notes for more information about troubleshooting S3 issues. 
411 MissingContentLength User Failure The Content-Length HTTP header must be provided. Refer to Notes for more information about troubleshooting S3 issues.
412 PreconditionFailed User Failure At least one of the preconditions you specified did not hold. Refer to Notes for more information about troubleshooting S3 issues.
416 InvalidRange User Failure The requested object cannot be found. Refer to Notes for more information about troubleshooting S3 issues. 
500 InternalError, ServerTimeout, InvalidAddressingHeader System Failure Response timeout from the ECS side, Capacity reached threshold 90%, no chunks available to perform the write request, ECS blobsvc service is restarting frequently. Refer to Notes for more information about troubleshooting S3 issues. 
501 NotImplemented System Failure The requested functionality is not implemented. Refer to Notes for more information about troubleshooting S3 issues.
503 ServiceUnavailable, SlowDown System Failure A high request rate was sent which must be reduced. Refer to Notes for more information about troubleshooting S3 issues.
507 InsufficientStorage System Failure The server cannot process the request because there is not enough space on disk. Refer to Notes for more information about troubleshooting S3 issues. 

Additional Information

See the following article for more information about troubleshooting these errors: ECS: Troubleshooting S3 Read/Write/Delete issues

Link for S3 HTTP status codes in the ECS 3.8.x Data Access Guide. (Log in as a registered user may be required to view this document.)

Affected Products

ECS Appliance Software with Encryption

Products

ECS Appliance Gen 1, ECS Appliance Gen 2, ECS Appliance Gen 3, ECS Appliance Software without Encryption
Article Properties
Article Number: 000120328
Article Type: Solution
Last Modified: 01 Dec 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.