PowerStore: Tjekliste for enhedslicensering

Summary: Denne artikel beskriver, hvordan du anskaffer, aktiverer og foretager fejlfinding af licensproblemer på PowerStore-produkter.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Efter installationen leveres alle enheder med en 30-dages prøvelicens, så konfigurationen kan fortsætte, indtil licensen kan fuldføres.

PowerStore forsøger at oprette forbindelse til Dell hver 24. time for at aktivere licensen. Hvis ekstern internetadgang ikke er tilladt, er en manuel procedure for at få licensen beskrevet nedenfor.

Cause

PowerStore-licenser er:
  • Alt inklusive.
  • Må ikke udløbe.
  • Udstedes pr. Apparat.
Bemærk: Tilføjelse af nye enheder til en eksisterende PowerStore-klynge kan medføre, at hele klyngen vender tilbage til prøvelicensering, indtil den nyligt tilføjede enhed er permanent licenseret.

Resolution

Emner:


Kontrol af licensstatus i PowerStore Manager

I PowerStore Manager-brugergrænsefladenskal duvælge >Indstillinger Licensering.  
 
Eksempel: Licensering udført.
 
Grafisk brugerflade til PowerStore-licenser – flueben

 
Eksempel: Licensen er ikke aktiveret, har stadig prøvelicens.
 
Installation af PowerStore GUI-licens

Klyngelicenseringbilledebillede

    Hvert apparat licenseres individuelt. Når alle medlemmer i klyngen har licens, vises licensbrugergrænsefladen som Aktiv.

    Brug kommandoen svc_license_status list til at identificere, om den enkelte enhedslicensstatus.
    Nedenstående eksempel fremhæver, at en enhed ikke er licenseret.
    [SVC:service@ABC1234-B user]$ svc_license_status list
     appliance_sn | days_remain | is_licensed
    --------------+-------------+-------------
     ABC1234      |     2048998 | t
     ZYX1234      |     2048998 | t
     CBA1234      |     2048998 | t
     XYZ1234      |          59 | f
    (4 rows)
    

      Automatisk licensering

      Enheden forsøger automatisk at nå online e-licensserverne hver 24. time for at hente og installere licenser, hvis en aktiv internetforbindelse er tilgængelig.
       
      Hvis systemet viser, at den er i prøvetilstand:
      Klik på linket Opdater for at udløse et forsøg på at hente licenserne ved hjælp af online e-licensservere. Hvis dette mislykkes efter flere forsøg, skal du gennemgå afsnittet Manuel licensering nedenfor
       

      Fejlfinding af automatiske licenseringsfejl i PowerStore

      Bemærk: Automatisk licensering understøtter ikke TLA-licenser (Transformational License Agreement). Denne licenstype skal aktiveres manuelt.
      1. Bekræft, at du kan fortolke DNS-navnet på licensserveren ssgosge.emc.com og oprette forbindelse til port 443 fra ethvert Windows- eller Linux-system i miljøet.
      • ncat er tilgængelig for mange operativsystemer som open source, https://nmap.org/ncat/.
      • ncat er ikke tilgængelig for servicebrugeren på PowerStore.
      • Licensserveren reagerer ikke på pingsignaler.
      nc -vz ssgosge.emc.com 443
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Connected to 168.159.208.38:443  <<Successful Connection
      Ncat: 0 bytes sent, 0 bytes received in 0.07 seconds.
      
      nc -vz ssgosge123.emc.com 443
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Could not resolve hostname "ssgosge123.emc.com": Name or service not known. QUITTING.  <<Cannot resolve DNS name
      
      nc -vz ssgosge.emc.com 440
      Ncat: Version 7.50 ( https://nmap.org/ncat )
      Ncat: Connection timed out.  <<Failed connection to port

      Hvis ovenstående ikke giver indsigt i et problem, skal du kontakte en repræsentant for teknisk support med henvisning til denne artikel.
       

      Manuel licensering

      Manuel licensering er påkrævet, hvis enheden er installeret på et sted uden internetforbindelse tilgængelig eller TLA-licens bruges.
      1. Gå til Software Licensing Central-portalen.
      2. Log på med din kontos loginoplysninger.
      3. Vælg Aktivér min software.
      4. Indtast servicekoden for PowerStore-enheden i feltet Licensgodkendelseskode, og klik derefter på Søg.
      • Bemærk: For systemer, der bruger TLA (Transformational License Agreement), skal aktiveringskoden være i feltet TLA-ID.
      1. Bekræft, at elementet PowerStore Base SW er valgt, og klik derefter på Start aktiveringsprocessen.
      2. Bekræft oplysninger om virksomhed og websted. Skift websted efter behov med linket Skift websted, og klik derefter på Angiv detaljer.
      3. MEGET VIGTIGT: Indtast PowerStore-servicekoden (udelukkende store bogstaver) i feltet med maskinnavn, og klik derefter på Gennemse.
      • Alle andre værdier i dette felt medfører, at aktiveringen mislykkes.
      1. Gennemgå alle oplysninger om denne side. Bekræft den e-mailadresse, som licensnøglefilen skal sendes til. Tilføj yderligere e-mailadresser, og klik derefter på Aktivér.
      2. Tjek din e-mail for aktiveringsfilen. Afsenderen er licensing@emc.com. Filen er vedhæftet.
      3. Upload licensfilen i PowerStore Manager.
        1. Menuen Indstillinger.
        2. Vælg Licensering.
        3. Klik på Installer licens.
        4. I trin 3 skal du klikke på knappen Vælg fil.
        5. Upload .xml-filen, der kom i e-mailen tidligere.
        6. Bekræft, at status ændres til Aktiv.
      Hvis ovenstående ikke løser problemet, skal du kontakte en teknisk supportmedarbejder, og henvise til denne artikel.
       

      Fejlfinding af manuelle licenseringsfejl i PowerStore

      1. Bekræft, at licensfiludvidelsen (*.xml) er uploadet.
      2. Åbn *.xml-filen, og undersøg indholdet.
      • Bekræft, at < BÅDE værdierne LockingID> og <MachineName>KUN indeholder servicekoden for PowerStore-enheden. (Udelukkende store bogstaver).
      • Hvis disse ikke stemmer overens, skal du rette værdierne på Software Licensing Central-portalen og registrere den rettede licensfil.

      Hvis ovenstående ikke giver indsigt i problemet, skal du kontakte en repræsentant for teknisk support med henvisning til denne artikel.

       

        Hentning af licensfiler, hvis tidligere aktiveret

        Hvis produktet blev aktiveret tidligere, kan disse trin følges for at downloade den oprindelige licensfil:
        1. Gå til Software Licensing Central-portalen.
        2. Log på med din kontos loginoplysninger.
        3. Vælg Licenser øverst til højre, og vælg derefter Vis certifikat.
        4. Indtast servicekoden for PowerStore-enheden i feltet Licensgodkendelseskode, og klik derefter på Søg.
        5. I tabellen Vis et certifikatskal du klikke på Vis.
        6. Klik på knappen Gem til fil, og vælg et sted at gemme .xml-filen.
        7. Upload licensfilen i PowerStore Manager.
          1. Menuen Indstillinger.
          2. Vælg Licensering.
          3. Klik på Installer licens.
          4. I trin 3 skal du klikke på knappen Vælg fil.
          5. Upload .xml-filen, der kom i e-mailen tidligere.
          6. Bekræft, at status ændres til Aktiv.
        Hvis ovenstående ikke løser problemet, skal du kontakte en teknisk supportmedarbejder, og henvise til denne artikel.

         
         

        Affected Products

        PowerStore
        Article Properties
        Article Number: 000123660
        Article Type: Solution
        Last Modified: 20 Jun 2025
        Version:  22
        Find answers to your questions from other Dell users
        Support Services
        Check if your device is covered by Support Services.