Dell Encryption potrebbe smettere di rispondere con un numero elevato di utenti attivati
Summary: Dell Encryption (in precedenza Dell Data Protection | Crittografia) potrebbe smettere di rispondere quando un numero elevato di utenti viene attivato su un singolo dispositivo. La mancata risposta può causare un errore del sistema operativo (errore schermata blu) sul dispositivo. ...
Symptoms
Prodotti interessati:
- Dell Encryption Enterprise
- Dell Encryption Personal
- Dell Data Protection | Encryption
- Dell Data Protection | Personal Edition
Versioni interessate:
- v8.9.0 e versioni precedenti
Cause
Dell Encryption archivia i dati utente attivati all'interno del credsys.vlt (comunemente chiamato file del vault), che è archiviato all'interno di C:\Windows\system32\. Questo file è un database di flat file di dimensione limitata che archivia le informazioni sull'utente attivato, le chiavi di crittografia per il dispositivo, i set di policy per gli utenti attivati e le associazioni secondo cui determinate chiavi sono in correlazione a determinati utenti sul dispositivo. In caso di molti utenti attivati sul dispositivo, i dati all'interno del file potrebbero superare il limite della dimensione configurata per il database di flat file, con conseguente danneggiamento. Questo danneggiamento può manifestarsi come un errore in CMGShield e poiché questo servizio è impostato come servizio critico per il sistema, è possibile che si verifichi un errore del sistema operativo in caso di errore del servizio.
Questo problema può essere identificato all'interno del file CMGShield.log , archiviato per impostazione predefinita all'interno della directory ProgramData di: C:\ProgramData\Dell\Dell Data Protection\Encryption\. Se sono presenti errori, ciò indica che l'insieme di credenziali supera la dimensione massima (dati generalizzati in quanto possono variare nel campo):
Vault Error - Cluster index <NUMBER> exceeds maximum clusters (<NUMBER>) while validating (<NUMBER>) <POLICYFILENAME> Size=<NUMBER>
Resolution
Gli amministratori che riscontrano questo problema possono eseguire WSDeactivate per risolvere un endpoint che entra in questo stato. WSDeactivate può essere acquistato dal supporto Dell, se necessario, poiché questa applicazione non è pubblicata esternamente, in quanto comporta una perdita di dati se il dispositivo non è in grado di raggiungere il server.
WSDeactivate Può essere utilizzato per risolvere i problemi di un computer crittografato. L'utilità rinomina il file del vault (credsys.vlt) e aggiunge una data e un timestamp alla fine del nome file dopo una richiesta di riavvio. Questo processo richiede la riattivazione di tutti gli utenti precedentemente attivati sul dispositivo al successivo accesso.
Il problema è stato risolto in Dell Encryption v8.9.1 e versioni successive. La risoluzione ha comportato la limitazione del numero massimo di utenti attivati a 25 per impostazione predefinita, oltre alla modifica dei calcoli della dimensione e dei checksum dei dati di attivazione all'interno del vault. Quando viene attivato il 26° utente, l'utente che non ha effettuato l'accesso da più lungo tempo viene eliminato dal vault.
Questo valore può essere modificato come desiderato cambiando la chiave di registro:
- Eseguire il backup del Registro di sistema prima di procedere, consultare Come eseguire il backup e il ripristino del Registro di sistema in Windows
.
- Quando si modifica il Registro di sistema, il computer potrebbe smettere di rispondere al riavvio successivo.
- Contattare i numeri di telefono internazionali del supporto di Dell Data Security per assistenza in caso di dubbi sull'esecuzione di questa procedura.
HKEY_LOCAL_MACHINE\SOFTWARE\Dell\Dell Data Protection\Encryption DWORD: MaxActivatedUsers Value: <IntegerHere>
Il valore definito è limitato a un minimo di cinque utenti e un massimo di 50.
Per contattare il supporto, consultare l'articolo Numeri di telefono internazionali del supporto di Dell Data Security.
Accedere a TechDirect per generare una richiesta di supporto tecnico online.
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