Dell Encryption peut ne plus répondre avec un nombre élevé d’utilisateurs activés

Summary: Dell Encryption (anciennement Dell Data Protection | Encryption) peut cesser de répondre lorsqu’un grand nombre d’utilisateurs sont activés sur un seul appareil. Cette absence de réponse peut entraîner une défaillance du système d’exploitation (erreur d’écran bleu) sur l’appareil. ...

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Symptoms

Produits concernés :

  • Dell Encryption Enterprise
  • Dell Encryption Personal
  • Dell Data Protection | Encryption
  • Dell Data Protection | Personal Edition

Versions concernées :

  • v8.9.0 et versions antérieures

Cause

Dell Encryption stocke les données utilisateur activées dans le fichier credsys.vlt (appelé fichier coffre-fort), qui est stocké dans C:\Windows\system32\. Il s’agit d’une base de données de fichiers plats d’une taille limitée qui stocke des informations sur l’utilisateur activé, les clés de chiffrement de l’appareil concerné, les ensembles de règles applicables aux utilisateurs activés, ainsi que les liaisons permettant de corréler les clés aux utilisateurs correspondants de l’appareil. Lorsque de nombreux utilisateurs sont activés sur l’appareil, les données contenues dans ce fichier peuvent dépasser la taille limite configurée pour la base de données de fichiers plats, et provoquer ainsi une corruption de la base de données. Cette corruption peut se manifester par une défaillance dans le CMGShield service, et puisque ce service est défini comme un service critique pour le système, une défaillance du système d’exploitation peut se produire en cas d’échec de ce service.

Ce problème peut être identifié dans le fichier CMGShield.log , qui est stocké par défaut dans le répertoire ProgramData de : C:\ProgramData\Dell\Dell Data Protection\Encryption\. Si des erreurs sont présentes, cela indique que le coffre-fort dépasse sa taille maximale (données généralisées car elles peuvent varier dans le champ) :

Vault Error - Cluster index <NUMBER> exceeds maximum clusters (<NUMBER>) while validating (<NUMBER>) <POLICYFILENAME> Size=<NUMBER>

Resolution

Les administrateurs qui rencontrent ce problème peuvent exécuter WSDeactivate à résoudre sur un point de terminaison qui passe dans cet état. WSDeactivate peut être obtenu auprès du support Dell si nécessaire, car cette application n’est pas publiée en externe, car elle entraîne une perte de données si l’appareil ne parvient pas à atteindre le serveur.

Remarque : WSDeactivate Peut être utilisé pour dépanner un ordinateur crypté. L’utilitaire renomme le fichier de coffre-fort (credsys.vlt) et ajoute une date et une heure à la fin de son nom de fichier après une invite de redémarrage. Avec ce processus, tous les utilisateurs précédemment activés doivent être réactivés sur cet appareil lors de leur prochaine connexion.

Ce problème est résolu dans Dell Encryption versions 8.9.1 et ultérieures. La solution consiste à limiter à 25 par défaut le nombre maximal d’utilisateurs activés et à modifier les calculs de taille et de somme de contrôle des données d’activation à l’intérieur du fichier Vault. Au moment de l’activation du 26e utilisateur, l’utilisateur qui ne s’est pas connecté depuis le plus longtemps est exclu du fichier Vault.

Vous pouvez modifier cette valeur à votre guise en modifiant la clé de registre :

Avertissement : L’étape suivante consiste à modifier le registre Windows :
HKEY_LOCAL_MACHINE\SOFTWARE\Dell\Dell Data Protection\Encryption
DWORD: MaxActivatedUsers
Value: <IntegerHere>

La valeur définie est limitée à un minimum de cinq utilisateurs et à un maximum de 50.


Pour contacter le support technique, consultez l’article Numéros de téléphone du support international Dell Data Security.
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Additional Information

 

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Affected Products

Dell Encryption
Article Properties
Article Number: 000125053
Article Type: Solution
Last Modified: 19 Jun 2024
Version:  8
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