PowerStore: resetowanie hasła i odzyskiwanie kont administratora i usługi

Summary: W tym artykule opisano sposób resetowania konta administratora lub konta usługi na urządzeniach PowerStore X i PowerStore T.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Metoda resetowania tych haseł zależy od tego, czy urządzenie to model PowerStore T, czy PowerStore X. Użyj metody odpowiadającej Twojemu urządzeniu, aby zresetować hasło administratora lub usługi albo oba hasła.

Cause

Urządzenie jest dostarczane z domyślnym kontem administratora, które umożliwia przeprowadzanie konfiguracji początkowej. Jest również dostarczany z domyślnym kontem użytkownika usługi, które wykonuje wyspecjalizowane funkcje usługi. Zaleca się początkowe skonfigurowanie systemu PowerStore przy użyciu interfejsu użytkownika PowerStore Manager, a nie innej metody, takiej jak interfejs API REST lub interfejs CLI. Korzystanie z interfejsu użytkownika PowerStore Manager zapewnia zmianę wszystkich domyślnych haseł. Jeśli zapomnisz nowych haseł, przywróć je do wartości domyślnych.

Resolution


Poniższa procedura została wygenerowana z PowerStore: Instrukcja konfiguracji
zabezpieczeńAktualne zalecenia można znaleźć w podręczniku konfiguracji zabezpieczeń PowerStore.

Procedury:

 

Resetowanie hasła administratora dla modelu PowerStore T z systemem PowerStoreOS w wersji 2.1 lub nowszej

 

W przypadku urządzenia PowerStore T ta procedura jest jedynym sposobem resetowania hasła w przypadku zapomnienia lub braku hasła administratora. Ta procedura resetuje hasło usługi i hasło administratora do odpowiednich wartości domyślnych.

Kroki:
  1. Znajdź przycisk niemaskowalnych przerwań (NMI) dla węzła z tyłu urządzenia. Umieśćprzycisk na module wbudowanym węzła, wewnątrz małego otworu oznaczonego dwoma pionowo ustawionymi trójkątami skierowanymi na siebie
Umiejscowienie przycisku NMI na wbudowanych modułach we/wy
Umiejscowienie przycisku NMI na wbudowanych modułach we/wy
Umiejscowienie przycisku NMI na wbudowanych modułach we/wy 2
  1. Używając cienkiego niemetalowego przedmiotu, naciśnij i przytrzymaj przycisk NMI tylko przez 1-2 sekundy, a następnie zwolnij go.
UWAGA: Ostrożnie. Naciśnięcie przycisku NMI przez ponad dziesięć sekund powoduje zresetowanie (ponowne uruchomienie) węzła. Ponadto w ciągu dwóch minut nie należy podejmować próby ponownego zresetowania hasła NMI w tym samym węźle.
  1. Połącz się z urządzeniem modelu PowerStore T za pomocą przeglądarki z adresem IP zarządzania i zaloguj się jako administrator przy użyciu domyślnego hasła początkowego Password123#. Powinien zostać wyświetlony monit o zresetowanie hasła administratora i hasła usługi.
Ekran resetowania programu PowerStore Manager
  1. Zmień hasło administratora z domyślnego na hasło określone przez użytkownika. Usuń zaznaczenie pola wyboru, aby hasło konta usługi było inne niż hasło administratora.
UWAGA: Jeśli nie zostanie wyświetlony monit o zresetowanie hasła po zalogowaniu, powtórz kroki 1–4 na drugim węźle. Działanie jest wykonywane tylko wtedy, gdy przy pierwszej próbie nie zostanie wyświetlony monit o zresetowanie hasła. Jeśli nadal nie ma monitu o zresetowanie hasła przy każdej próbie logowania po jednokrotnej próbie na każdym węźle, skontaktuj się z usługodawcą.
 

Resetowanie hasła administratora dla modelu PowerStore T z systemem PowerStoreOS w wersji 2.0 lub starszej

 

Do zresetowania hasła do konta administratora wymagany jest dysk USB. Obsługiwane systemy plików to FAT32 i ISO 9660. Funkcja portu USB zostanie usunięta w przyszłej wersji systemu PowerStoreOS.

UWAGA: Aby zresetować hasło, kiedy urządzenie jest w trybie serwisowym, należy wykonać następujące czynności. Zastosuj proces resetowania przy pomocy napędu USB do każdego węzła. Ta czynność gwarantuje, że po powrocie systemu do trybu normalnego. Po zalogowaniu do programu PowerStore Manager zostanie wyświetlony monit o podanie nowego hasła zarówno dla administratora, jak i użytkownika usługi.
 

Kroki

  1. Jeśli dysk USB jest sformatowany, przejdź do następnego kroku; W przeciwnym razie użyj wiersza polecenia, takiego jak: Format <D:> /FS:FAT32, aby sformatować dysk. Gdzie d: oznacza literę dysku USB, który został włożony do notebooka lub komputera osobistego.
     
  2. Ustaw etykietę za pomocą polecenia:
     label d: RSTPWD
Urządzenie nie montuje dysku USB bez etykiety RSTPWD. Po oznaczeniu dysku USB włóż pusty plik z hasłami do kont, które można zresetować z wiersza polecenia. Zresetuj hasło administratora lub konta usługi albo jedno i drugie.
  1. Aby utworzyć pusty plik na dysku, użyj jednego lub obu z następujących poleceń w razie potrzeby: Na urządzeniu podłączonym do portu USB otwórz wiersz poleceń i wprowadź d:\ (list podłączony do pendrive'a) i uruchom poniższe polecenia, aby utworzyć pliki na USB. 

    copy NUL d:\admin
    copy NUL d:\service
  2. Włóż dysk USB do portu USB dowolnego węzła urządzenia, odczekaj 10 sekund, a następnie wyjmij dysk. Hasło przy każdym zresetowaniu konta jest teraz wartością domyślną.
     
  3. Połącz się z klastrem za pomocą przeglądarki, korzystając z adresu IP klastra, i zaloguj się jako admin, podając domyślne hasło wstępne, czyli Password123#. Powinien pojawić się monit o zresetowanie hasła administratora lub hasła serwisowego, lub obu tych haseł. Jeśli wolisz, zresetuj hasło usługi przy użyciu protokołu SSH (Secure Shell), początkowe domyślne hasło dla konta usługi to usługa.
 
Ekran resetowania programu PowerStore Manager
  1. Zmień hasło administratora z domyślnego na hasło określone przez użytkownika. Usuń zaznaczenie pola wyboru, aby hasło konta usługi było inne niż hasło administratora.
    Ekran domyślnych użytkowników programu PowerStore Manager

Resetowanie hasła administratora dla modelu PowerStore X

 

W przypadku urządzenia modelu PowerStore X należy użyć obrazu ISO i zamontować go z poziomu vSphere. Wstępnie utworzone pliki graficzne można pobrać z https://www.dell.com/support. Nowy obraz można utworzyć w systemie Linux za pomocą następujących poleceń dotykowych:

UwagaMożna go pobrać za pomocą yum install -y mkisofs
mkdir iso 
touch iso/admin 
mkisofs -V RSTPWD -o reset.iso iso

Przykładowe tworzenie obrazu ISO

[root@computer tmp]# Obraz ISO mkdir
[root@computer tmp]# Dotknij ISO/admin

[root@computer tmp]# mkisofs -V RSTPWD -o reset.iso iso
I: -input-charset not specified, using utf-8 (detected in locale settings)
Total translation table size: 0
Total rockridge attributes bytes: 0
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
174 extents written (0 MB)
[root@computer tmp]#
UWAGA:
  • Obraz ISO, reset.iso, musi znajdować się w magazynie danych, zanim będzie można go zamontować jako wirtualny dysk CD z oprogramowaniem vSphere.
  • Aby zresetować hasło, kiedy urządzenie jest w trybie serwisowym, należy wykonać następujące czynności.
    • Najpierw: Prześlij obraz ISO do PRIVATE-XXXXXXX. A.WEWNĘTRZNY magazyn danych samej maszyny wirtualnej kontrolera (VM), ponieważ publiczny magazyn danych jest niedostępny.
    • Następnie: Prześlij i zastosuj plik reset.iso do obu węzłów A i B maszyny wirtualnej kontrolera. Ta akcja gwarantuje, że gdy urządzenie powróci do trybu normalnego i będzie dostępny dostęp do programu PowerStore Manager, zostanie wyświetlony monit o podanie nowego hasła zarówno dla administratora, jak i użytkownika usługi.

 

Kroki

  1. W oprogramowaniu vSphere w obszarze Storage wybierz swoje urządzenie PowerStore X. Na przykład DataCenter-WX-D6013 > , PowerStore D6013
     
  2. W obszarze Pliki wybierz pozycję ISO.
     
  3. Wybierz pozycję Prześlij , aby przekazać plik reset.iso, wstępnie utworzony plik obrazu z www.dell.com/support lub własny plik obrazu utworzony w systemie Linux. Plik reset.iso pojawi się w folderze ISOs.
    reset.iso plik pojawi się w folderze ISOs
  4. W oprogramowaniu vSphere w obszarze Host and Clusters wybierz główny węzełpodstawowego urządzenia modelu PowerStore X w klastrze. Na przykład wybierz pozycję Datacenter-WX-D6013, następnie Cluster WX-D6013, a następnie PSTX-44W1BW2-A.
     
  5. W obszarze Podsumowanie kliknij opcję CD/DVD drive 1 i wybierz opcję Connect to datastore ISO file. Pojawi się okno "Wybierz obraz ISO do zamontowania".
     
  6. W obszarze magazynu danych kliknij urządzenie modelu podstawowego PowerStore X w klastrze i wybierz folder ISOs. Plik reset.iso powinien pojawić się w obszarze Contents.
    reset.iso plik pojawi się w wybranym pliku
  7. Wybierz plik reset.iso i kliknij przycisk OK. W obszarze Podsumowanie napęd CD/DVD 1 powinien być wyświetlany jako podłączony przez około 10 sekund, a następnie zmieniony na odłączony. Hasło administratora klastrów lub hasło usługi lub oba te hasła zostaną ustawione na wartość domyślną.
    Napęd CD/DVD 1 powinien być wyświetlany jako podłączony
     
  8. Połącz się z klastrem za pomocą przeglądarki, korzystając z adresu IP klastra, i zaloguj się jako admin, podając domyślne hasło wstępne, czyli Password123#. Powinien pojawić się monit o zresetowanie hasła administratora lub hasła serwisowego, lub obu tych haseł. Aby zresetować hasło usługi przy użyciu protokołu SSH, początkowe domyślne hasło dla konta usługi to usługa.
    Ekran resetowania programu PowerStore Manager
     
  9. Zmień hasło administratora z domyślnego na hasło określone przez użytkownika. Usuń zaznaczenie pola wyboru, aby hasło konta usługi było inne niż hasło administratora.
    Ekran domyślnych użytkowników programu PowerStore Manager

Powrót do góry  


 

Affected Products

PowerStore
Article Properties
Article Number: 000125384
Article Type: Solution
Last Modified: 27 Jun 2025
Version:  13
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.