Для работы Dell Encryption Enterprise требуется System32 . Исключаемые EXE-файлы
Summary: Исключения Dell Encryption Enterprise (ранее Dell Data Protection Enterprise Edition) можно добавить для System32. EXE, выполнив следующие инструкции.
Symptoms
Затронутые продукты:
- Dell Encryption Enterprise
- Dell Data Protection | Enterprise Edition
Затронутые версии:
- v7.0.x и более поздние версии
Недавно корпорация Microsoft изменила процесс обновления Windows, изменив файлы в каталоге \Windows\System32 перед загрузкой драйверов Dell Encryption Enterprise. Это может привести к замене зашифрованных исполняемых файлов SDE (.exe) в папке System32 на файл с открытым текстом (незашифрованным) без уведомления Dell Encryption Enterprise об изменении.
Cause
Это приводит к тому, что Dell Encryption Enterprise пытается расшифровать незашифрованный файл, что приводит к появлению синего экрана.
Resolution
Как узнать, что меня это затронуло?
Эта проблема затрагивает только пользователей, использующих Dell Encryption Enterprise с шифрованием системных данных (SDE). Щелкните версию Dell Security Management Server, чтобы определить, присутствует ли проблема в вашей среде.
- Войдите в консоль удаленного управления Dell Data Protection (RMC).
- На панели меню слева нажмите Populations.

Рис. 1. (Только на английском языке) Населения
- Нажмите Enterprise, Endpoint Groups или Endpoints. Этот параметр зависит от того, где в организации были изменены политики SDE.

Рис. 2. (Только на английском языке) Выберите «Enterprise», «Endpoint Group» или «Endpoints»
- Выберите Шифрование файлов/папок (FFE).

Рис. 3. (Только на английском языке) Шифрование файлов/папок (FFE)
- Убедитесь, что установлен флажок Включено шифрование SDE.

Рис. 4. (Только на английском языке) Проверить, что шифрование SDE включено
- В разделе «Правила шифрования SDE» найдите
%ENV:SYSTEMROOT%\SYSTEM32\;exeилиC:\Windows\System32\;exeбез-Символ.
Пример политики, связанной с данной проблемой:
C:\Windows\System32\;exe @C:\Windows\System32\;exe %ENV:SYSTEMROOT%\System32\;exe @%ENV:SYSTEMROOT%\System32\;exe
^, ^2 или ^3 Символ.
Если не удается найти синтаксис, похожий на приведенные выше примеры, эта проблема вас не касается. Если вы видите синтаксис, похожий на приведенный выше пример, перейдите к: Как это исправить?
- Войдите в консоль удаленного управления Dell Data Protection (RMC).
- На панели меню слева выберите Enterprise, Endpoint Groups или Endpoints. Этот параметр зависит от того, где в организации были изменены политики SDE.

Рис. 5. (Только на английском языке) Выберите «Enterprise», «Endpoint Groups», «Endpoints»
Пример политики, связанной с данной проблемой:
^, ^2 или ^3 Символ.
Если вы не можете найти синтаксис, похожий на приведенные выше примеры, то эта проблема вас не касается. Если вы видите синтаксис, похожий на приведенный выше пример, перейдите к: Как это исправить?
- Выберите вкладку Security Policies.

Рис. 6. (Только на английском языке) Security Policies
- Если появилось меню шаблона, нажмите Override и перейдите к шагу 5.

Рис. 7. (Только на английском языке) Переопределить
- В раскрывающемся списке «Категория политики» выберите Шифрование Windows.

Рис. 8. (Только на английском языке) Выберите «Шифрование Windows».
- Разверните элемент «Фиксированное хранилище».

Рис. 9. (Только на английском языке) Фиксированное хранилище
- Убедитесь, что для параметра Включено шифрование SDE установлено значение true. Если для параметра «SDE Encryption Enabled » установлено значение «False», эта проблема не затрагивает вас.
- В разделе «Правила шифрования SDE» найдите
%ENV:SYSTEMROOT%\SYSTEM32\;exeилиC:\Windows\System32\;exeбез-Символ.
C:\Windows\System32\;exe @C:\Windows\System32\;exe %ENV:SYSTEMROOT%\System32\;exe @%ENV:SYSTEMROOT%\System32\;exe
Как разрешить эту проблему?
Выберите версию Dell Data Security Server / Dell Data Protection Server для решения.
- Снова войдите в RMC и перейдите в раздел «Правила шифрования SDE» (см. раздел «Как узнать, что меня это касается?»).
- Добавьте символ "-" (минус) к рассматриваемому синтаксису.
Пример изменения

Рис. 10. (Только на английском языке) Перед

Рис. 11. (Только на английском языке) После
- В правом верхнем меню нажмите Сохранить.

Рис. 12. (Только на английском языке) Сохранить
- В левой панели меню нажмите Управление.

Рис. 13. (Только на английском языке) Управления
- Нажмите Подтвердить.

Рис. 14. (Только на английском языке) Совершить
- В меню «Commit» при необходимости введите комментарии об изменении политики, а затем нажмите Commit Policy.
- Конечные точки, использующие Dell Encryption Enterprise, подметят новое изменение политики при следующем опросе политики и начнут расшифровку .exe в папке System32.
Это может привести к синему экрану, если .exe расширения зашифрованы с помощью шифрования системных данных (SDE), Common или User.
- Снова войдите в RMC и перейдите в раздел «Правила шифрования SDE» (см. раздел «Как узнать, что меня это касается?»).
- Добавьте
-(минус) к рассматриваемому синтаксису.
Пример изменения

Рис. 15. (Только на английском языке) Перед

Рис. 16. (Только на английском языке) После
- В правом нижнем углу нажмите кнопку Сохранить.

Рис. 17. (Только на английском языке) Сохранить
- В левой панели меню нажмите Подтвердить политики (в разделе «Действия»).

Рис. 18. (Только на английском языке) Commit Policies
- При необходимости введите комментарий об изменении политики и нажмите Применить изменения.
- Конечные точки, использующие Dell Data Protection | Enterprise Edition учтет новое изменение политики при следующем опросе политики и начнет расшифровку .exe в папке System32.
Чтобы связаться со службой поддержки, см. Номера телефонов международной службы поддержки Dell Data Security.
Перейдите в TechDirect, чтобы создать запрос на техническую поддержку в режиме онлайн.
Для получения дополнительной информации и ресурсов зарегистрируйтесь на форуме сообщества Dell Security.