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Clearing the Printer Spooler, Troubleshoot Printer Spooler Errors, and Removing Printers from Windows Registry

Summary: This article covers clearing and stopping the print spooler, troubleshooting printer spooler errors, and deleting a printer from Windows Registry. This article shows how you can clear the print spooler and troubleshoot printer spooler errors. The print spooler helps your Windows computer interact with the printer and orders the print jobs in your queue. This article provides information about resolving printer spooler errors within Windows 11, Windows 10, Windows 8(8.1), and Windows 7. ...

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Article Content


Symptoms

Print spooler errors are present. Documents sent to the printer are not printing and are stuck in the printer spooler.

Cause

Some printing and communications issues that are caused by a problem with the Print Spooler. In some case restarting or clearing the Print Spooler may resolve these issues. The print spooler helps your Windows computer interact with the printer, and orders the print jobs in your queue. Windows 11, Windows 10, Windows 8(8.1), and Windows 7.

Resolution

Table of Contents:

  1. How to Manually Stop and Start the Print Spooler
  2. How to Manually Delete Files from the Spool Folder
  3. How to Manually Delete a Printer from the Registry
  4. How to Resolve Printer Spooler Errors

1. How to Manually Stop and Start the Print Spooler

  1. Click the Start button and select Run. Type Command (Figure 1 [English only]) and then click OK to display the Command Prompt (Figure 2 [English only]). 

    SLN153544_en_US__11370445585439.command 1

    Figure 1: In the Run window type command


    SLN153544_en_US__21370445608922.command 2

    Figure 2: Command prompt

  2. In the Command Prompt type, net stop spooler, then press Enter to Stop the Print Spooler.
  3. In the Command Prompt type, net start spooler, then press Enter to Start the Print Spooler.

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2. How to Manually Delete Files from the Spool Folder

If you have jobs that are stuck in the print queue that will not delete, you might have to manually delete them.

  1. Stop the Print Spooler.
  2. Browse to C: Drive and Open.
  3. Browse to WINDOWS and Open.
  4. Browse to SYSTEM32 and Open.
  5. Browse to SPOOL and Select.
  6. Browse to PRINTERS.
  7. Delete all the files located in this folder, for example: FP00008 or FP00008.SHD.
  8. Restart the Print Spooler.

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3. How to Manually Delete a Printer from the Registry

It is also possible to delete Printers from the Computers Registry.

Warning: Changing or deleting files from the Registry may cause issues with your Operating System, such as being unable to Boot to Windows, do NOT make any changes unless you are comfortable doing so. If the Registry becomes corrupted, you may have to reinstall the Windows Operating System.
  1. If the printer cannot be deleted or removed and restarting the print spooler has not cleared the issue, you can remove the printer manually from the Registry.
  2. Click the Start button and then click Run. Type command and then click OK to display the command prompt (as described above).
  3. Type regedit, then press Enter. This will bring up the Registry Editor(Figure 3 [English only]).

    SLN153544_en_US__31370445675311.regedit 1

    Figure 3: Registry Editor

  4. In the Registry Editor, expand the My Computer area.
  5. Expand the HKEY_CURRENT_USER folder (Figure 4 [English-only]).

    SLN153544_en_US__41370445717310.regedit 2

    Figure 4: HKEY_CURRENT_USER folder

  6. Expand the Printers folder Click on the Connections folder (Figure 5 [English only]).

    SLN153544_en_US__51370445744434.regedit 3

    Figure 5: Connections folder

  7. Only delete the printer queue and the printer (Figure 6 [English-only]). DO NOT DELETE ANYTHING ELSE.

    SLN153544_en_US__61370445788245.regedit 4

    Figure 6: Printer queue and printer

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4. How to Resolve Printer Spooler Errors

Windows 10 and Windows 11

  1. Type troubleshooting in the search box.
  2. Touch or click Troubleshooting (control panel)
  3. Touch or click Use a printer, under Hardware and Sound.
  4. Touch or click Advanced.
  5. Touch or click Run as administrator (when asked, input your credentials or cancel if you do not know them).
  6. Touch or click Next and follow the prompts.
    Note: If the issue persists, you must uninstall and reinstall the latest printer drivers for your printer. For more information concerning Dell printers, see Dell Knowledge Base article Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware. For non-Dell branded printers, see the printer's manufacturer’s website.

Windows 8 (8.1)

  1. Press and hold the Windows key then press the q key on the keyboard.
  2. Type troubleshooting in the search box.
  3. Touch or click Troubleshooting.
  4. Touch or click Use a printer, under Hardware and Sound.
  5. Touch or click Advance.
  6. Touch or click Run as administrator (when asked, input your credentials or cancel if you do not know them).
  7. Touch or click Next and follow the prompts.
    Note: If the issue persists, you must uninstall and reinstall the latest printer drivers for your printer. For more information concerning Dell printers, see Dell Knowledge Base article Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware. For non-Dell branded printers, see the printer's manufacturer’s website.

Windows 7

  1. Click Start.
  2. In the search box type troubleshooting.
  3. Click Troubleshooting (it should be at the top of the list under Control Panel).
  4. Click Use a printer, under Hardware and Sound.
  5. Click Advanced.
  6. Click Run as administrator (when asked, input your credentials or cancel if you do not know them).
  7. Click Next and follow the prompts.
    Note: If the issue persists, you must uninstall and reinstall the latest printer drivers for your printer. For more information concerning Dell printers, see Dell Knowledge Base article Dell Printer Uninstalling, Downloading and Installing Printer Drivers, Software, Manuals, and Firmware. For non-Dell branded printers, see the printer's manufacturer’s website.
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Article Properties


Affected Product

Printers & Accessories

Last Published Date

30 Sep 2021

Version

5

Article Type

Solution