Aktualizace zabezpečení společnosti Microsoft mohou způsobit selhání komunikace v nástroji Dell Encryption

Summary: Aktualizace zabezpečení společnosti Microsoft mohou způsobit selhání komunikace v nástroji Dell Encryption (dříve Dell Data Protection | Encryption).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Dotčené produkty:

  • Dell Encryption
  • Dell Data Protection | Encryption

Cause

Společnost Microsoft rozesílá aktualizace zabezpečení, které řeší chyby zabezpečení, a tyto aktualizace ovlivňují komunikaci s nástrojem Dell Encryption. V prostředích, kde jsou v nástroji Dell Security Management Server (dříve Dell Data Protection) povoleny sady šifer Diffie-Hellman Export (DHE). Serveru Enterprise Edition) se po instalaci aktualizací společnosti Microsoft může objevit následující chování:

V tomto příkladu selhaly aktivace. V protokolu štítu byly uvedeny následující zprávy:

[07.08.16 11:54:38:824 CredantServerIn: 211] [ERROR] SSL request failed.. HTTP error An error occurred in the secure channel support [MS ec=12157].
[07.08.16 11:54:38:824 CredantServerIn: 211] [ERROR] HTTP error. HTTP error A security error occurred [MS ec=12175].

a

[07.08.16 11:54:38:864 XmlRpcActivate: 128] Activating user...
[07.08.16 11:54:38:924 XmlRpcActivate: 415] SSL Failure status code. HTTP error(-2147483648) -
[07.08.16 11:54:38:934 XmlRpcActivate: 415] SSL request failed.. HTTP error(12157) - An error occurred in the secure channel support
[07.08.16 11:54:38:934 XmlRpcActivate: 415] HTTP error. HTTP error(12175) - A security error occurred
[07.08.16 11:54:38:934 XmlRpcActivate: 148] Activation request failed [code:0x2f8f]:
[07.08.16 11:54:38:934 Activator: 709] [SUPPORT] [W] Activation - Unable to activate new user XXXXXXX [error = 0x2f8f]
[07.08.16 11:54:38:934 Activator: 711] Activation - Verify that the CMG Shield is properly installed.
[07.08.16 11:54:38:934 Activator: 716] Activation - Verify network connectivity to the CMG Server at "XXXXXXX" and CMG Device Server at
[07.08.16 11:54:38:934 ] - Device Server Connection error (12175)

Koncový bod může odeslat příkaz ping na server a úspěšně se přes protokol telnet připojit k portu. Dokonce i některé prohlížeče, jako je Chrome, se mohou dostat na webové stránky, zatímco IE nemůže.

V protokolech událostí systému Windows pro komponentu SChannel existují položky:


- 


36888
0
2
0
0
0x8000000000000000

19178


System
XXXXXXXXXXXXXXX.com



- 

40
808


Resolution

Poznámka: Tento problém vyřeší upgrade serveru na verzi v9.4.1.

Pokud se tato chování zobrazují, zkontrolujte, které aktualizace společnosti Microsoft byly na koncový bod aplikovány. Problémy způsobují dvě aktualizace:

  • Aktualizace zabezpečení společnosti Microsoft MS15-055/KB3061518
  • KB3161608 aktualizace zabezpečení společnosti Microsoft

Jedna z aktualizací změní minimální délku klíče DHE z 512 bitů na 1024 bitů v koncovém bodě. Ve výchozím nastavení nástroj Dell Security Management Server umožňuje použití 768bitových skupin DHE, které po použití těchto aktualizací způsobí selhání handshaku SSL nebo TLS. Chcete-li koncový bod vrátit zpět, aby bylo možné použít minimálně 512bitovou délku klíče DHE, musíte aktualizovat registr koncového bodu. Vyhledejte v registru následující podklíč:

Varování: Dalším krokem je úprava registru systému Windows:
  1. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\KeyExchangeAlgorithms\Diffie-Hellman
  2. Poté přidejte hodnotu DWORD ClientMinKeyBitLength a nastavte ji na 00000200.

Chcete-li kontaktovat podporu, přečtěte si článek Telefonní čísla mezinárodní podpory Dell Data Security.
Přejděte na portál TechDirect a vygenerujte online žádost o technickou podporu.
Další informace a zdroje získáte na fóru komunity Dell Security.

Affected Products

Dell Encryption
Article Properties
Article Number: 000126675
Article Type: Solution
Last Modified: 05 Jul 2023
Version:  9
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.