Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Troubleshooting Touchpads and Other Input Devices in Ubuntu on a Dell Computer

Summary: The following article provides troubleshooting instructions to identify and resolve an input device issue on a Dell computer running the Ubuntu operating system. (Touchpad, Mouse, Touchscreen, and so on.) ...

This article may have been automatically translated. If you have any feedback regarding its quality, please let us know using the form at the bottom of this page.

Article Content


Symptoms

Are you experiencing issues with input devices on your Ubuntu Dell Computer?

There are some issues common to various input devices (Touchpad, Mouse, Touchscreen, and so on.). The following sections deal with troubleshooting steps to take in the Ubuntu operating system.

Cause

These steps deal with issues such as:

  • Device not working or not detected
  • Cursor moving or jumping of its own accord
  • Device conflicts
  • Unable to configure the input devices

Resolution

 

Troubleshooting steps

Take these steps in order to resolve any input issues:

Most Dell computers now come with a BIOS that uses your input devices to navigate its options:

  1. Boot the computer into the BIOS, test each input device. Did any device not work in the BIOS?

    1. If the answer is yes, contact Dell Support if your computer is in warranty to get further help.

    2. If the answer is no, the issue is with the operating system or the software for the device. Carry on with this guide to further troubleshoot this fault.

Note: On most computer's, you can enter the BIOS directly by pressing the F2 key down while at the Dell Splash screen.

If you have an older BIOS and were not able to isolate the faulty device, follow these instructions:

Note: It is not recommended that you disable the touchpad unless you have an external USB, wireless USB, Bluetooth mouse, or your computer has a touch screen.
  1. Try each input device on its own, to see if you can isolate the faulty device.

    • To disable the touchpad:

      • Using the Ubuntu Graphical User Interface:

        1. Go to system and settings

        2. Go to Mouse and Touchpad

        3. Click on the on/off slide at the right-hand side of the window to turn the touchpad off or back on

      • Using Terminal:

        1. Identify the device:

           xinput -list

        2. Disable the device:

           xinput --disable <device ID>

    • To disable the mouse:

      • Disconnect the Bluetooth, Wireless, or the USB mouse that you are using from the computer.

    • To disable the touch screen:

      • Using Terminal:

        1. Identify the device:

          xinput -list

        2. Disable the device:

          xinput --disable <device ID>

Is you device detected, have you identified all your input devices?

  1. Type the following command in Terminal:

    xinput -list

  2. It should show a list of input devices on your computer:

    Xinput List

    (Figure.1 An example of what the list of devices look like)

  3. Was the device that you were having trouble with listed?

    • Yes, carry on to the next section of troubleshooting

    • No, it is not listed and there is no other similar device listed.

    • No, a different device is shown instead.

  4. If the answer is NO, you can identify the hardware that shipped with your computer by going to the Dell Support Site:

    1. Enter your service tag or express service code to get information specific to your computer.

    2. Go to System Configuration.

    3. Choose the Original Configuration tab.

    4. You can go down through the list of components to find out the manufacturer and type of any devices that shipped with your computer. 

In this section, I give some advice on how to accomplish this. This is the last step possible before an Operating system reinstallation is recommended.

Note: You may not find many Ubuntu drivers on the Dell Support site. As with all other Ubuntu ISOs, the Dell Ubuntu ISO contains all the Dell drivers built in. It is available from the support site. The drivers install automatically as part of the operating system installation process. If your computer did not come installed with Ubuntu, you may want to check the ISO version you are using against the Ubuntu Compatibility list  This hyperlink is taking you to a website outside of Dell Technologies..

The last resort is to recover the system image or to reinstall the operating system from install media.

Ubuntu Came Installed on your computer

You are looking to install Ubuntu on a computer that came with a Windows operating system

Your issue continues after reinstalling the Operating System

Article Properties


Affected Product

G Series, Inspiron, Latitude, Vostro, XPS, Fixed Workstations

Last Published Date

05 May 2023

Version

5

Article Type

Solution