Core Server och Inventory Server startar inte efter uppgradering av Dell Security Management Server Virtual från v9.11 till 10.0.0.29

Summary: I den här artikeln beskrivs hur du uppgraderar Dell Security Management Server Virtual från v9.11 till 10.0.0.29 och kärnservern och lagerservern startar inte.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Berörda produkter:

  • Dell Security Management Server Virtual

Berörda versioner:

  • v10.0.0.29

Det går inte att starta Core Server och Inventory Server när du utför en onlineuppgradering av Dell Security Management Server v9.11 till 10.0.0.29, även om uppgraderingen verkar slutföras utan problem.

Cause

Om du vill kontrollera att Tjänsterna Core Server och Inventory Server har startat ansluter du till Dell Security Management Server Virtual Administration Console med delluser och väljer System Dashboard.

Det gick inte att starta Core Server and Inventory Server
Bild 1: (Endast på engelska) Det gick inte att starta Core Server and Inventory Server

Onlinetillgängligheten av en icke-kompatibel Mono-version högre än v5.14.0.177 under uppgraderingsprocessen leder till detta.

Följ stegen nedan för att bekräfta att den installerade versionen av Mono är högre än 5.14.0.177:

  1. Anslut till Dell Security Management Server Virtual Administration Console och delluser välj Launch Shell.

Välj Launch Shell (starta gränssnitt)
Bild 2: (Endast på engelska) Välj Launch Shell (starta gränssnitt)

  1. I gränssnittet skriver du mono --version

SLN314455_en_US__3ddpKM2052c
Bild 3: (Endast engelska) mono --version

 

Resolution

Om den version som visas är högre än 5.14.0.177 utför du stegen nedan för att lösa problemet.

  1. Kontakta Dell Pro Support för att få skriptet install_mono_5.14.0.177.sh .
  2. Använd ett FTP-program för att kopiera skriptet till supportmappen på Dell Security Management Server Virtual:

Flytta skriptet till en mapp som stöds med ftp-klienten
Bild 4: (Endast på engelska) Flytta skriptet till en mapp som stöds med ftp-klienten

  • IP-adressen till Dell Security Management Server Virtual finns på Dell Security Management Server Virtual System Dashboard.
  1. Om FTP inte är aktiverat på Dell Security Management Server Virtual aktiverar du det genom att följa stegen nedan:
    1. Anslut till Den virtuella administrationskonsolen för Dell Security Management Server som delluser.
    2. Välj Basic Configuration > SFTP.

Välj SFTP
Bild 5: (Endast på engelska) Välj SFTP

  1. Lägg till en FTP-användare, ange en användare och ett lösenord och välj Apply (Verkställ).

Lägg till och FTP-användare
Bild 6: (Endast på engelska) Lägg till och FTP-användare

  1. Öppna gränssnittet från Dell Security Management Server Virtual Administration Console:

Välj Launch Shell (starta gränssnitt)
Bild 7: (Endast på engelska) Välj Launch Shell (starta gränssnitt)

  1. Kör skriptet på följande sätt:
su dellsupport
  • Ange lösenordet för dellsupport (standardlösenordet dellsupport).
cd /var/opt/dell/dsmsv/ftp/files/support/
sudo chmod +x install_mono_5.14.0.177.sh
sudo ./install_mono_5.14.0.177.sh
  1. Vänta tills skriptet slutförs.
  2. Kontrollera att den installerade versionen av Mono är 5.14.0.177 genom att skriva kommandot mono --version.

Typ mono --version
Bild 8: (Endast på engelska) Skriv mono --version

  1. Kontrollera System Dashboard för att se om Core Server och Inventory Server nu körs:

Kärnserver och inventeringsserver eller körning
Bild 9: (Endast på engelska) Kärnserver och inventeringsserver eller körning


Om du vill kontakta support, se Dell Data Security telefonnummer till internationell support.
Gå till TechDirect för att skapa en begäran om teknisk support online.
Om du vill ha mer information och resurser kan du gå med i Dell Security Community-forumet.

Additional Information

Videos

 

Affected Products

Dell Encryption
Article Properties
Article Number: 000130513
Article Type: Solution
Last Modified: 10 Oct 2023
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.