PowerStore: VM deployment can fail with “A general system error occurred”.

Summary: VM deployment can fail with “A general system error occurred”.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In rare case, vVol-based VM deployment can fail with "A general system error occurred: vDS host error: See faultCause".

Cause

A software limitation in VMware vSphere causes the issue to occur. There is an ESXi timing issue that, in rare cases, affects the management of namespaces for vVols and empty namespaces. The fix will be added in a future vSphere release.

The output below (with appropriate storage container and vVol identifiers) can be seen in vvold.log in ESXi to identify the issue:
2019-11-15T05:24:35.161Z info vvold[2112740] [Originator@6876 sub=Default] VVolAbandonedObjectScan::ProcessNamespace examining namespace /vmfs/volumes/vvol:47019ee7844f427a-9704983221f4659a/naa.68ccf098008904859065fa973d72d13e …

2019-11-15T05:24:35.318Z warning vvold[2112740] [Originator@6876 sub=Libs] 2112740:VVOLLIB : VVolLib_OpenObjectTrackingFile:11348: VVolLib_OpenObjectTrackingFile: Failed to open object tracking file /vmfs/volumes/vvol:47019ee7844f427a-9704983221f4659a/naa.68ccf098008904859065fa973d72d13e/.vvolObjList with error 6

Resolution

Retry VM deploy operation.

Permanent fix:
Recommend upgrading to PowerStore 2.0.1.3 or greater which has a fix for the issue discussed in this article.

Affected Products

PowerStore
Article Properties
Article Number: 000132277
Article Type: Solution
Last Modified: 23 Mar 2022
Version:  4
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