Serie MD: Md3xxx Cómo reemplazar un disco en caso de falla predictiva o inminente

Summary: En este artículo, se explica cómo reemplazar de manera segura una unidad de falla predictiva en un almacenamiento MD3xxx mediante la administración de almacenamiento en disco modular (MDSM). ...

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Instructions

Introducción  

En este tutorial se explica cómo reemplazar un disco en falla predictiva o inminente. Una falla predictiva es una función de las unidades de disco duro modernas (disco duro) diseñada para mejorar la confiabilidad de RAID. Una falla predictiva indica que se debe reemplazar un disco duro antes de que se produzca una falla. 

 


Causa

Durante las operaciones normales de lectura/escritura, es posible que se produzca un error en un disco duro. La controladora identifica este error y lo repara. Estos errores también se conocen como “Bloques dañados”. Por lo tanto, el espacio de memoria en un disco duro suele ser ligeramente mayor que lo especificado. Este espacio se utiliza para reubicar o reparar los bloques dañados que ocurren durante las operaciones normales. Se asigna un umbral predeterminado de bloques dañados a un disco duro individual. Cuando se alcanza este umbral, la controladora cambia el estado del disco duro a “Predictive Fail”. El disco duro sigue funcionando; sin embargo, existe la probabilidad de que falle pronto.

Se recomienda reemplazar rápidamente un disco duro en estado de "Falla predictiva" para mantener la integridad del volumen RAID. Para reemplazar el disco duro, se puede quitar de forma segura del volumen RAID antes del reemplazo físico. Realice el proceso descrito a continuación para cambiar el estado del disco duro a Sin conexión y extraerlo de manera segura del volumen RAID.

 


Solución

Nota : Antes de continuar, Modular Disc Storage Manager(MDSM) debe estar instalado. MDSM se puede descargar desde el sitio de soporte. El sistema debe tener acceso al arreglo de almacenamiento.
Siga el proceso que se indica a continuación para quitar el disco duro del volumen RAID de manera segura y offline.

  1. Inicie MDSM y seleccione el arreglo PowerVault correspondiente.
    1. Verifique el arreglo correcto mediante el estado del gabinete
    2. Si no hay problemas con un arreglo, se muestra como "óptimo", como se muestra en la Figura 1 a continuación
      1. Vista de dispositivos de MDSM en la que se muestra el estado óptimo
      2. Figura 1: Vista de dispositivos de MDSM en la que se muestra el estado óptimo
    3. Si el arreglo tiene un disco duro en falla predictiva, el estado cambia a "Need attention"
  2. Haga doble clic en el arreglo para acceder al administrador de arreglos
  3. Verifique que no haya otras unidades faltantes o fallidas en el mismo conjunto RAID
  4. Haga clic en Hardware y, luego, seleccione la unidad de disco duro con falla predictiva. El estado se muestra como "Requiere atención"
    1. Sección de hardware de MDSM
    2. Figura 2: Sección de hardware de MDSM
  5. Haga clic con el botón secundario en el disco duro, seleccione Avanzado y, a continuación, Falla
    1. Menú tras hacer clic con el botón secundario en el que se muestra la opción Fail
    2. Figura 3: Menú tras hacer clic con el botón secundario en el que se muestra la opción Fail
  6. Escriba "Yes" para confirmar la operación de falla de la unidad
    1. Si hay un disco de repuesto en el arreglo, también conocido como "hot spare", deje marcada la casilla "Copiar el contenido del disco duro antes de que falle"
    2. Los datos del disco de falla predictiva se copian en el hot spare para evitar cualquier degradación de un RAID
    3. Esto se muestra a continuación en la Figura 4
    4. Si no hay un hot spare, desmarque la casilla "Copiar el contenido del disco físico antes de que falle"
      1. No intente copiar el contenido a menos que haya un hot spare disponible en el arreglo
      2. Intentar esto puede provocar la pérdida o corrupción de datos
    5. Cuadro de diálogo de Confirm Fail Physical Disk
    6. Figura 4: Cuadro de diálogo de Confirm Fail Physical Disk
  7. Si se utiliza la opción de copiar el contenido,
    1. Puede pasar algún tiempo antes de que la unidad falle y el estado cambie a "Fallido"
  8. El estado del disco duro cambia a "Fallido" y aparece una "X" roja junto a él
  9. Ahora es seguro reemplazar físicamente el disco duro

 


Affected Products

MD Series, Dell PowerVault OEM Ready MD34XX and MD38XX, PowerVault MD3200, PowerVault MD3200i, PowerVault MD3220, PowerVault MD3220i, PowerVault MD3260, PowerVault MD3260i, PowerVault MD3400, PowerVault MD3420, PowerVault MD3460, PowerVault MD3600F , PowerVault MD3600i, PowerVault MD3620F, PowerVault MD3620i, PowerVault MD3660f, PowerVault MD3660i, PowerVault MD3800f, PowerVault MD3800i, PowerVault MD3820f, PowerVault MD3820i, PowerVault MD3860f, PowerVault MD3860i ...
Article Properties
Article Number: 000132906
Article Type: How To
Last Modified: 21 Mar 2025
Version:  6
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