MD 시리즈: Md3xxx 예측 또는 임박한 오류의 디스크를 교체하는 방법

Summary: 이 문서에서는 MDSM(Modular Disk Storage Management)을 사용하여 MD3xxx 스토리지에서 예측 장애 드라이브를 안전하게 교체하는 방법에 대해 설명합니다.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Instructions

소개  

이 자습서에서는 예측 오류 또는 임박한 오류가 있는 디스크를 교체하는 방법을 설명합니다. 예측 오류는 RAID 신뢰성을 향상하기 위해 설계된 최신 하드 디스크 드라이브(하드 드라이브)의 기능입니다. 예측 오류는 오류가 발생하기 전에 하드 드라이브를 교체해야 한다는 것을 나타냅니다. 

 


원인

정상적인 읽기/쓰기 작업을 수행하는 동안에도 하드 드라이브에서 오류가 발생할 수 있습니다. 컨트롤러에서 이 오류를 식별하고 복구합니다. 이러한 오류는 "불량 블록"이라고도 합니다. 이러한 오류가 발생하는 원인은 하드 드라이브의 메모리 공간이 일반적으로 지정된 것보다 약간 더 크기 때문입니다. 이 공간은 정상 작동 중에 발생하는 불량 블록을 재배치하거나 복구하는 데 사용됩니다. 미리 정해진 불량 블록 임계값이 개별 하드 드라이브에 할당됩니다. 이 임계값에 도달하면 컨트롤러에서 하드 드라이브의 상태를 "Predictive Fail"로 변경합니다. 하드 드라이브는 계속 작동하지만 하드 드라이브가 곧 고장날 가능성이 있습니다.

RAID 볼륨의 무결성을 유지하기 위해 "예상 장애" 상태의 하드 드라이브를 즉시 교체하는 것이 좋습니다. 하드 드라이브를 교체하려면 물리적 교체 전에 RAID 볼륨에서 하드 드라이브를 안전하게 제거할 수 있습니다. 아래에 설명된 절차에 따라 하드 드라이브 상태를 오프라인으로 변경하고 RAID 볼륨에서 안전하게 분리합니다.

 


해결책

참고: 계속하기 전에 MDSM(Modular Disc Storage Manager)을 설치해야 합니다. MDSM은 지원 사이트에서 다운로드할 수 있습니다. 시스템이 스토리지 어레이에 액세스할 수 있어야 합니다.
아래 절차에 따라 오프라인으로 전환하여 RAID 볼륨에서 하드 드라이브를 안전하게 제거합니다.

  1. MDSM을 시작하고 해당하는 PowerVault 어레이를 선택합니다.
    1. 인클로저의 상태를 사용하여 올바른 어레이를 확인합니다.
    2. 어레이에 문제가 없으면 아래 그림 1과 같이 "Optimal"로 표시됩니다
      1. Optimal 상태를 표시하는 MDSM 디바이스 보기
      2. 그림 1: Optimal 상태를 표시하는 MDSM 디바이스 보기
    3. 어레이에 예측 장애 상태의 하드 드라이브가 있는 경우 상태가 "Need attention"으로 변경됩니다
  2. 어레이를 두 번 클릭하여 어레이 관리자에 액세스합니다
  3. 동일한 RAID 세트에 누락되거나 장애가 발생한 다른 드라이브가 없는지 확인합니다.
  4. 하드웨어를 클릭한 후 예측 오류 상태인 하드 드라이브를 선택합니다. 상태가 "Need attention"으로 표시됩니다.
    1. MDSM의 하드웨어 섹션
    2. 그림 2: MDSM의 하드웨어 섹션
  5. 하드 드라이브를 오른쪽 클릭하고 Advanced, Fail을 차례로 선택합니다 .
    1. Fail 옵션을 보여 주는 마우스 오른쪽 버튼 클릭 메뉴
    2. 그림 3: Fail 옵션을 보여 주는 마우스 오른쪽 버튼 클릭 메뉴
  6. "Yes"를 입력하여 드라이브 장애 작업을 확인합니다.
    1. 어레이에 "핫 스페어"라고도 하는 스페어 디스크가 있는 경우 "Copy contents of hard drive before failing" 확인란을 선택한 상태로 둡니다.
    2. 예측 장애 디스크의 데이터는 RAID의 성능 저하를 방지하기 위해 핫 스페어로 복사됩니다
    3. 이는 아래 그림 4에 나와 있습니다
    4. 핫 스페어가 없는 경우 "Copy contents of physical disk before failing" 확인란의 선택을 취소합니다.
      1. 어레이에 사용 가능한 핫 스페어가 없는 한 콘텐츠를 복사하지 마십시오
      2. 이를 시도하면 데이터가 손실되거나 손상될 수 있습니다.
    5. 물리적 디스크 실패 확인 대화 상자
    6. 그림 4: 물리적 디스크 실패 확인 대화 상자
  7. 내용을 복사하는 옵션을 사용하는 경우
    1. 드라이브에 장애가 발생하고 상태가 "Failed"로 변경될 때까지 다소 시간이 걸릴 수 있습니다
  8. 하드 드라이브의 상태가 "Failed"로 변경되고 옆에 빨간색 "X"가 표시됩니다.
  9. 이제 하드 드라이브를 물리적으로 교체하는 것이 안전합니다.

 


Affected Products

MD Series, Dell PowerVault OEM Ready MD34XX and MD38XX, PowerVault MD3200, PowerVault MD3200i, PowerVault MD3220, PowerVault MD3220i, PowerVault MD3260, PowerVault MD3260i, PowerVault MD3400, PowerVault MD3420, PowerVault MD3460, PowerVault MD3600F , PowerVault MD3600i, PowerVault MD3620F, PowerVault MD3620i, PowerVault MD3660f, PowerVault MD3660i, PowerVault MD3800f, PowerVault MD3800i, PowerVault MD3820f, PowerVault MD3820i, PowerVault MD3860f, PowerVault MD3860i ...
Article Properties
Article Number: 000132906
Article Type: How To
Last Modified: 21 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.