MD-serien: Md3xxx Så här byter du ut en disk vid förutsägbart eller överhängande fel

Summary: I den här artikeln beskrivs hur du på ett säkert sätt byter ut en förutsägbar felenhet i en MD3xxx-lagring med hjälp av MDSM (Modular Disk Storage Management).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Instructions

Introduktion  

I den här självstudiekursen kan du läsa om hur du ersätter en disk vid förutsägbart eller förestående fel. Förutsägbara fel är en funktion för moderna hårddiskar som är avsedd att förbättra RAID-tillförlitligheten. Om det uppstår ett förutsägbart fel anger det att en hårddisk måste bytas innan det uppstår fel. 

 


Orsak

Under normala läs-/skrivåtgärder kan det uppstå ett fel på hårddiskar. Felen identifieras och repareras i styrenheten. Den här typen av fel kallas för skadade block. Det är anledningen till att minnesutrymmet på hårddiskar vanligtvis är något större än vad som anges. Det utrymmet används till att flytta eller reparera skadade block som identifieras under normal drift. Fördefinierade tröskelvärden för antal skadade block tilldelas för hårddiskar. När det tröskelvärdet har uppnåtts för en hårddisk ändras statusen för den till Predictive Fail i styrenheten. Hårddisken fortsätter att fungera, men sannolikheten för att hårddisken kommer att gå sönder snart.

Vi rekommenderar att en hårddisk med statusen "Predictive Fail" byts ut omedelbart för att upprätthålla integriteten hos RAID-volymen. Du kan byta ut hårddisken genom att på ett säkert sätt ta bort den från RAID-volymen innan den byts ut fysiskt. Om du vill ändra hårddiskstatusen till offlineläge och ta bort den från RAID-volymen följer du stegen nedan.

 


Lösning

Obs! Innan du fortsätter måste Modular Disc Storage Manager(MDSM) installeras. MDSM kan laddas ner från supportwebbplatsen. Systemet måste ha åtkomst till lagringsdisksystemet.
Följ nedanstående process för att koppla från och på ett säkert sätt ta bort hårddisken från RAID-volymen.

  1. Starta MDSM och välj motsvarande PowerVault-disksystem.
    1. Verifiera rätt disksystem med hjälp av kapslingens status
    2. Om det inte finns några problem med ett disksystem visas det som "Optimal", som visas i bild 1 nedan
      1. Vyn MDSM-enheter som visar optimalt tillstånd
      2. Bild 1: Vyn MDSM-enheter som visar optimalt tillstånd
    3. Om disksystemet har en hårddisk i förutsägbart fel ändras statusen till "Behöver åtgärdas"
  2. Dubbelklicka på disksystemet för att komma åt disksystemshanteraren
  3. Kontrollera att det inte finns några andra saknade eller trasiga enheter i samma RAID-uppsättning
  4. Klicka på Hardware och välj sedan hårddisken med förutsägbart fel. Statusen visas som Need attention.
    1. Avsnittet Maskinvara i MDSM
    2. Bild 2: Avsnittet Maskinvara i MDSM
  5. Högerklicka på hårddisken och välj Avancerat och sedan Misslyckas
    1. Högerklicksmenyn som visar alternativet Misslyckades
    2. Bild 3: Högerklicksmenyn som visar alternativet Misslyckades
  6. Bekräfta diskfelet genom att skriva "Yes"
    1. Om det finns en reservdisk i disksystemet, även kallad Hot Spare, låter du rutan "Kopiera innehållet i hårddisken innan den misslyckas" vara markerad
    2. Data på den förutsägbara feldisken kopieras till reservenheten för att undvika försämring av RAID
    3. Detta visas nedan i figur 4
    4. Om det inte finns någon reservdisk avmarkerar du rutan "Kopiera innehållet på den fysiska disken innan den misslyckas"
      1. Försök inte att kopiera innehåll om det inte finns en reservdisk i disksystemet
      2. Om du försöker göra detta kan det orsaka dataförlust eller skada
    5. Bekräfta misslyckad dialogruta för fysisk disk
    6. Bild 4: Bekräfta misslyckad dialogruta för fysisk disk
  7. Om alternativet att kopiera innehållet används,
    1. Det kan ta lite tid innan enheten slutar fungera och status ändras till Failed
  8. Hårddiskens status ändras till "Failed" och har ett rött "X" bredvid sig
  9. Nu kan du byta ut hårddisken fysiskt

 


Affected Products

MD Series, Dell PowerVault OEM Ready MD34XX and MD38XX, PowerVault MD3200, PowerVault MD3200i, PowerVault MD3220, PowerVault MD3220i, PowerVault MD3260, PowerVault MD3260i, PowerVault MD3400, PowerVault MD3420, PowerVault MD3460, PowerVault MD3600F , PowerVault MD3600i, PowerVault MD3620F, PowerVault MD3620i, PowerVault MD3660f, PowerVault MD3660i, PowerVault MD3800f, PowerVault MD3800i, PowerVault MD3820f, PowerVault MD3820i, PowerVault MD3860f, PowerVault MD3860i ...
Article Properties
Article Number: 000132906
Article Type: How To
Last Modified: 21 Mar 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.