PowerStore Alerts: Embedded Module State Failed

Summary: Node's IOM has failed. ICW HW check error - Fault Status Register FLT | Embedded Module

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

When Dell PowerStore encounters an issue, an error alert is generated to help identify the issue. This article explains the different possible causes and the relevant solutions for these error alerts. If your issue is not resolved despite the solution provided, check the technical Dell Technical Support contact options.

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Alert ID XMS_IOM_FRU_STATE_FAILED
Alert Text Node's IOM has failed.
Error Code (0x00309203)
Resolution Cause
Embedded module failed state alerts occur when the system firmware detects an issue during self-testing which is run on power on and on every reboot. The platform software monitors the firmware for these errors and reports them by raising the alert and setting the FRU health state to FAILED.

For systems which are not configured, the Initial Config Wizard runs a Health Check which also checks the firmware for errors and reports the appliance as in an Unconfigured Faulted state. Appliances in the faulted state cannot be configured. The error condition must be resolved before you can complete the configuration process.

For some classes of errors, the firmware may indict multiple FRUs because it is not technically possible to determine exactly which FRU caused the error. For example, if the firmware detects a PCI error for the 4-Port Card, it is not possible to determine if the 4-port Card, the Embedded Module, or the Node is the cause of the issue.

The same issue is seen on svc_diag list --icw_hardware output on the service container in the section. For example:
Node A|B Fault Status Register as:
FLT | Embedded Module

and possibly some of the following will also appear:

FLT | I/O Module 0
FLT | I/O Module 1
FLT | 4-Port Card

and possibly: 

FLT | Node


Solution
Resolving these errors may require replacing the embedded module or if multiple FRU indictments, potentially the node, or the attached 4-port card. There are also some known error conditions where it is possible to clear the condition without requiring any hardware replacement. It is recommended to contact Technical Support so they can review the underlying cause of the error to determine the best course of action.

Note: The embedded module on a PowerStore 500T is not a FRU component. If replacing the 4-port card does not resolve the error, replacing the node is the next step.

 


 

Cause

Embedded module failed state alerts occur when the system firmware detects an issue during self-testing which runs on power on and on every reboot. The platform software monitors the firmware for these errors and reports them by raising the alert and setting the FRU health state to FAILED.

For systems which are not configured, the Initial Config Wizard runs a Health Check which also checks the firmware for errors and report the appliance in an Unconfigured Faulted state. Appliances in the faulted state cannot be configured. The error condition must be resolved before you can complete the configuration process.

For some classes of errors, the firmware may indict multiple FRUs because it is not technically possible to determine exactly which FRU caused the error. For example, if the firmware detects a PCI error for the 4-Port Card, it is not possible to determine if the 4-port Card, the Embedded Module, or the Node is the cause of the issue.

The same issue is seen on the svc_diag list --icw_hardware output on the service container in the section. For example:
Node A|B Fault Status Register as:
FLT | Embedded Module

and possibly some of the following will also appear:

FLT | I/O Module 0
FLT | I/O Module 1
FLT | 4-Port Card

and possibly: 

FLT | Node

Resolution

Resolving these errors may require replacing the embedded module or if multiple FRU indictments, potentially the node, or the attached 4-port card. There are also some known error conditions where it is possible to clear the condition without requiring any hardware replacement. It is recommended to contact Technical Support so they can review the underlying cause of the error to determine the best course of action.

 


Note: The embedded module on a PowerStore 500T is not a FRU component. If replacing the 4-port card does not resolve the error, replacing the node is the next step.

Affected Products

PowerStore
Article Properties
Article Number: 000132989
Article Type: Solution
Last Modified: 19 Feb 2025
Version:  5
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