Skip to main content
  • Place orders quickly and easily
  • View orders and track your shipping status
  • Enjoy members-only rewards and discounts
  • Create and access a list of your products
  • Manage your Dell EMC sites, products, and product-level contacts using Company Administration.

Article Number: 000137766


PowerVault Tape Drive or Library - ML6000 Tape Library: How-to update the Tape Library Firmware

Summary: PowerVault Tape Drive or Library - ML6000 Tape Library: How-to update the Tape Library Firmware

Article Content


Symptoms

 
Article Summary: This article provides information on the "PowerVault Tape Drive or Library - ML6000 Tape Library: How-to update the Tape Library Firmware".

Table of Contents:
  1. How to Check the Firmware Revision
  2. Preparation
  3. Updating through the Web Interface

 
Issue 1.


How-to Check
the Firmware Revision


The ML6000 Tape Library firmware can be checked in the
following ways:
  1. Web Interface or RMU (Remote Management Unit):
    1. Reports > System Information
    2. Reports > About
  2. Operator Panel > About

Use the following link for more information:
PowerVault Tape Drive or Library - ML6000 Tape Library: How-to find the Library Firmware Revision

 


Cause


 
Issue 2.


Preparation


The following should be considered before updating
the ML6000 Tape Library's firmware:
  1. It is recommended that the host(s) or server(s) that "see"
    the ML6000 Tape Library will need to be restarted after the
    library firmware is updated.
  2. Typically, if the tape drive firmware has not been updated,
    consider updating tape drive firmware after the library's
    firmware has been completed.
  3. Saving the current library configuration before you upgrade library firmware
    is recommended in case the upgrade fails.

    After you have upgraded the firmware, save the library configuration again.
    Web Interface / RMU > Tools > Save / Restore Configuration
  4. It is also a good idea to capture a snapshot of current logged information before
    making any significant change to your system such as upgrading library firmware.

    Technical support personnel can, if necessary, use the snapshot file to troubleshoot the library.
  5. Additionally, consider capturing a snapshot of current logged information before
    making any significant change to your system such as upgrading library firmware.

    Technical support personnel can, if necessary, use the snapshot file to troubleshoot the library.

    The paths to open the appropriate screens are as follows:

    From the Web Interface, select Tools > Capture Snapshot.
    From the Operator Panel, select Tools > Capture Snapshot.

    See the following link for more information:
    PowerVault Tape Drive or Library - ML6000 Tape Library: How-to Gather a Snapshot

Resolution

 
Issue 3.


Updating through
the Web Interface

 
SLN156233_en_US__11342610665542.new_note Note:
  The following can also be referenced at the following link:

Dell PowerVault ML6000 Tape Library User's Guide


There are two types of firmware that can be upgraded on the library:
library firmware (including drive sled firmware) and tape drive firmware.

There may be times when you will need to upgrade your library and tape drive
firmware as directed by Dell Technical Support.

The library firmware upgrade operation allows you to upgrade library firmware
using the Web client. Upgrading library firmware can take up to an hour for large
configurations. You can download library firmware upgrades from the Dell Support
website: Support for PowerVault ML6000 | Documentation | Dell US

 

SLN156233_en_US__21342610700371.new_notice Notice:
  If you are currently running library firmware version 320G.GS004 or 400G.GS006, you must first install and run the Library Service Utility before upgrading firmware.

If you do not first run the Library Service Utility, then the firmware upgrade may not complete successfully.  The Library Service Utility and installation instructions are located in the ".zip" file that contains the firmware download files.

If you are currently running library firmware prior to version 320G.GS004, do not upgrade to
version 320G.GS004 or 400G.GS006, but instead upgrade to the latest version.
You will not need to run the Library Service Utility.
 
SLN156233_en_US__11342610665542.new_note Note:
  If you downgrade from one major firmware version to an earlier major version, library configuration settings will be reset to the factory defaults. You can restore the other configurable items using a configuration file that was saved when the earlier version of library firmware was installed on the library, or you can reconfigure your library's settings.
 
SLN156233_en_US__11342610665542.new_note Note:
  If you purchased your library after October 15, 2008, you cannot downgrade library firmware to below version 520G.
 
SLN156233_en_US__11342610665542.new_note Note:
  This operation should not be performed concurrently by multiple administrators. You can access the screen, but you cannot apply changes while another administrator is performing the same operation.

The library automatically restarts after the firmware upgrade is complete. Before logging into the library, clear
the web browser cache. See your Web browser's documentation for instructions on how to clear the cache.

You cannot upgrade library firmware from the operator panel. The path to open the appropriate screen is as follows:
  • From the Web Interface (or RMU), select Tools > Update Library Firmware.
See the following images below for the same process:

SLN156233_en_US__61376066419132.Figure-1_ML6000_Login_Screen

Figure 1 - ML6000 Login Screen (using default or other username and password)

SLN156233_en_US__71376066495790.Figure-2_ML6000_Tools_Update_Firmware

Figure 2 - ML6000 Tools Menu > Update Library Firmware

SLN156233_en_US__81376066570292.Figure-3_ML6000_Update_Library_Firmware

Figure 3 - ML6000 Update Library Firmware (select Browse)

SLN156233_en_US__91376066884941.Figure-4_ML6000_Update_Library_Firmware_File

Figure 4 - ML6000 Update Library Firmware File (typically a .tgz file)

Article Properties


Affected Product

Servers, PowerVault ML6000

Last Published Date

05 Mar 2021

Version

5

Article Type

Solution